Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Mobile

12/29/2011
03:02 PM
Connect Directly
Twitter
RSS
E-Mail
50%
50%

Secured WiFi Networks Can Be Circumvented

Disable WPS in WiFi routers -- if that's possible in your device, experts say

Millions of wireless routers worldwide are susceptible to a brute-force attack that breaks a widely deployed built-in security feature for WiFi and ultimately cheats the newest generation of secure WiFi, WPA/WPA2. And as of today, two open-source tools are circulating that simulate the attack.

Security researcher Stefan Viehbock this week published a white paper exposing vulnerabilities in the WiFi Protected Setup (WPS) protocol that lets an attacker grab WPA/WPA2 passwords in just a few hours. WPS contains a design flaw that allows an attacker to easily guess the PIN on a WiFi router and then obtain the network's WPA password. In response, US-CERT issued an advisory on the newly discovered flaws, noting that while there's no solution to the issue, the best mitigation for now is to disable WPS altogether, although not all routers allow this.

Among the vendors affected by the WPS flaw are Cisco/Linksys, Netgear, D-Link, Belkin, Buffalo, ZyXEL, and Technicolor.

WPS was developed by the WiFi Alliance as a means of simplifying and ensuring that consumers and other users deploy the security features within their WiFi routers. It cuts the number of steps required for users to set up a WiFi network in half.

Viehbock's research was echoed this week by researchers at Tactical Network Solutions, who had been working on the same issue for some time: They have now released a homegrown tool called Reaver into the public domain so that users can test for the problem. Viehbock also released his own proof-of-concept tool today.

"Once you know the WPS PIN, you can verify you have the correct PIN, which gives you the WPA key," says Craig Heffner, who conducts exploit development for TNS. "The protocol needs to be fixed and then vendors need to implement the changes."

The WiFi Alliance today noted that it had updated the protocol a year ago to prevent the risk of such an attack: "The Wi-Fi Alliance takes security seriously and introduced an updated specification a year ago that addresses this concern," says Kelly Davis-Felner, marketing director of The Wi-Fi Alliance. "We are currently evaluating whether additional updates are needed."

[Secure Open Wireless Access (SOWA) proof-of-concept aims to make openly available WiFi networks safer by giving users encrypted connections to wireless networks without their risking connecting to a rogue wireless access point or their traffic getting sniffed or hijacked. See Baking Security Into Open WiFi Networks.]

TNS's Reaver tool can crack WPS PINs and grab plain-text WPA/WPA2 passphrases within a four- to 10-hour time frame, according to TNS. What makes this type of attack especially dangerous is not only that it expedites WPS PIN-hacking, but also lets the attacker recover the WPA password, even if the user changes it.

The attack lets a bad guy get onto the WLAN and conduct man-in-the middle attacks and other exploits relatively easily, Heffner says.

Just how this will be fixed is unclear: "Hopefully, the vendors will implement the fixes fairly quickly. But they typically do not release new firmware updates for devices that are no longer supported. A lot are only a couple of years old, but most [users] neglect to apply updates as well," Heffner says. "Even if vendors publish a patch today, I still see this as a viable attack for the next couple of years."

Disabling WPS is the best bet, but not all routers provide an option to do so. Others don't actually disable even after the user hits the "disable" command.

WPA2 encryption itself isn't the problem: It's other features like WPS that destabilize it. "WPA2 is very strong as long as you have a good passphrase. But you never know when other vulnerabilities out there could allow the compromise of your device -- therefore your WPA key," Heffner says. "When a new technology comes out, unfortunately even if it's intended to help, it can hurt."

Have a comment on this story? Please click "Add Your Comment" below. If you'd like to contact Dark Reading's editors directly, send us a message.

Kelly Jackson Higgins is the Executive Editor of Dark Reading. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
News
Inside the Ransomware Campaigns Targeting Exchange Servers
Kelly Sheridan, Staff Editor, Dark Reading,  4/2/2021
Commentary
Beyond MITRE ATT&CK: The Case for a New Cyber Kill Chain
Rik Turner, Principal Analyst, Infrastructure Solutions, Omdia,  3/30/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-26030
PUBLISHED: 2021-04-14
An issue was discovered in Joomla! 3.0.0 through 3.9.25. Inadequate escaping allowed XSS attacks using the logo parameter of the default templates on error page
CVE-2021-26031
PUBLISHED: 2021-04-14
An issue was discovered in Joomla! 3.0.0 through 3.9.25. Inadequate filters on module layout settings could lead to an LFI.
CVE-2021-27710
PUBLISHED: 2021-04-14
Command Injection in TOTOLINK X5000R router with firmware v9.1.0u.6118_B20201102, and TOTOLINK A720R router with firmware v4.1.5cu.470_B20200911 allows remote attackers to execute arbitrary OS commands by sending a modified HTTP request. This occurs because the function executes glibc's system funct...
CVE-2021-28484
PUBLISHED: 2021-04-14
An issue was discovered in the /api/connector endpoint handler in Yubico yubihsm-connector before 3.0.1 (in YubiHSM SDK before 2021.04). The handler did not validate the length of the request, which can lead to a state where yubihsm-connector becomes stuck in a loop waiting for the YubiHSM to send i...
CVE-2021-29654
PUBLISHED: 2021-04-14
AjaxSearchPro before 4.20.8 allows Deserialization of Untrusted Data (in the import database feature of the administration panel), leading to Remote Code execution.