Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

11/10/2009
12:10 PM
50%
50%

Apple Issues Patch For 40 Vulnerabilities In Snow Leopard OS

Among security flaws addressed by Mac OS X 10.6.2 is login bypass vulnerability

Apple on Monday released Mac OS X 10.6.2, an update to its Snow Leopard operating system that fixes several dozen security issues and enhances general operating system performance.

The Snow Leopard update addresses 40 security vulnerabilities, many of which occur in open source components of Mac OS X, such as Apache or Subversion.

Security Update 2009-006 describes fixes for Mac OS X 10.6.2 and for earlier Apple operating system versions. It includes 58 Common Vulnerabilities and Exposures (CVE) entries, 18 of which don't affect Snow Leopard.

The 10.6.2 update resolves a bug that could lead to the deletion of files in a user's home directory following a Guest account login. It also repairs an unexpected logout issue, a problem with Spotlight search that prevented Exchange contacts from being seen, and numerous other stability and usability issues, as explained on Apple's Web site.

Among the security flaws fixed is a login bypass vulnerability. "If an account on the system has no password, such as the Guest account, a user may log in to any account without supplying a password," Apple's update summary states. "This update addresses the issue through improved access checks."

Apple is disabling support for X.509 certificates with MD2 encryption for uses other than trusted root certificates. This is due to a weakness in the MD2 hash algorithm identified by IOACTIVE security researcher Dan Kaminsky andMicrosoft (NSDQ: MSFT) Vulnerability Research.

Though Apple says an attack on this weakness isn't yet computationally feasible, the company is nonetheless limiting the use of X.509 certificates as "a proactive change to protect users in advance of improved attacks against the MD2 hash algorithm."

The update also addresses several QuickTime and CoreMedia flaws that could be exploited with maliciously crafted media files to allow remote code execution.

A flaw in CUPS, an open source printing system adopted by Apple, could allow a cross-site scripting attack to expose information about print system configuration and the titles of print jobs.

The update can be downloaded using Apple's Software Update preference panel, or from Apple's Web site.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
News
FluBot Malware's Rapid Spread May Soon Hit US Phones
Kelly Sheridan, Staff Editor, Dark Reading,  4/28/2021
Slideshows
7 Modern-Day Cybersecurity Realities
Steve Zurier, Contributing Writer,  4/30/2021
Commentary
How to Secure Employees' Home Wi-Fi Networks
Bert Kashyap, CEO and Co-Founder at SecureW2,  4/28/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-24259
PUBLISHED: 2021-05-05
The “Elementor Addon Elements� WordPress Plugin before 1.11.2 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
CVE-2021-24260
PUBLISHED: 2021-05-05
The “Livemesh Addons for Elementor� WordPress Plugin before 6.8 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
CVE-2021-24261
PUBLISHED: 2021-05-05
The “HT Mega – Absolute Addons for Elementor Page Builder� WordPress Plugin before 1.5.7 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by ...
CVE-2021-24262
PUBLISHED: 2021-05-05
The “WooLentor – WooCommerce Elementor Addons + Builder� WordPress Plugin before 1.8.6 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-priv...
CVE-2021-24263
PUBLISHED: 2021-05-05
The “Elementor Addons – PowerPack Addons for Elementor� WordPress Plugin before 2.3.2 for WordPress has several widgets that are vulnerable to stored Cross-Site Scriptin...