Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

3/27/2007
03:19 AM
50%
50%

Yosemite Adds Media Encryption

Yosemite Technologies announced the release of Yosemite Backup 8.5 data protection software enriched with several important new features

SAN JOSE, Calif. -- On the heels of its strategic acquisition of FileKeeper™, Yosemite Technologies, Inc., today announced the release of Yosemite Backup™ 8.5 data protection software enriched with several important new features. Yosemite’s effective and affordable solution for Small and Medium Businesses (SMBs) now includes media encryption, keeping data secure in the event it is lost or stolen.

"Despite recognizing the need to secure business critical information, most companies do not secure data stored on removable tape and removable disks,” said Mitchell Cipriano, vice president of marketing, Yosemite Technologies. “Yosemite Backup 8.5 allows SMBs to affordably add encryption to their backup strategy, safeguarding this vital data. Overall we are meeting the SMBs’ need for simplified scalability & cost effective backup by reducing limitations and increasing the capability of existing offerings; Yosemite Backup 8.5 provides a more valuable backup solution than ever before.”

With a platform-agnostic approach to backup, Yosemite Backup provides native support for Windows, Netware, and Linux, and has been upgraded to support the protection of Windows Vista files. Additional enhancements include language features, support for Windows SharePoint services and an enhanced user interface.

In addition to the new release, Yosemite has expanded and enhanced its most popular edition of Yosemite Backup, building on the company’s reputation for delivering value. Yosemite Backup Standard is now available as a Single Server Edition packaged, priced, and targeted directly at customers needing to protect a single-server. For those customers needing greater capabilities and performance, Yosemite Backup Standard now supports backup of an unlimited number of servers within a backup domain. With the associated Yosemite license and an unlimited backup-to-disk capacity, organizations can easily grow from a single-server to a many-server environment.

Yosemite Backup Standard can now also be purchased as a core to edge Data Protection Suite that includes a Yosemite FileKeeper (using file level CDP) 10-pack license, protecting every document a user edits at the instant they save their documents to disk, regardless of where the documents are stored or whether the system is connected to or disconnected from the network. This Suite can be enhanced by adding Yosemite Backup Agents and Options according to the user’s needs. For environments demanding greater levels of performance, Yosemite Backup Advanced™ also now includes a FileKeeper 10-pack, 2 SAN Media Server & D2D2Ne™ software licenses, offering a total data protection value previously only available for purchase separately.

"Data security is of prime importance today and most companies are now realizing that their off-site tape media is at serious risk," said Arun Taneja, consulting analyst and founder, Taneja Group. “The addition of media data encryption to the popular Yosemite Backup software solves this problem. Yosemite is also giving small and mid-size businesses the convenience of a one-stop-shop for data protection with the combination of FileKeeper for notebooks and desktop PCs using continuous data protection for data files and Yosemite Backup for servers.”

Yosemite Technologies Inc.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
News
Inside the Ransomware Campaigns Targeting Exchange Servers
Kelly Sheridan, Staff Editor, Dark Reading,  4/2/2021
Commentary
Beyond MITRE ATT&CK: The Case for a New Cyber Kill Chain
Rik Turner, Principal Analyst, Infrastructure Solutions, Omdia,  3/30/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-21392
PUBLISHED: 2021-04-12
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 requests to user provided domains were not restricted to external IP addresses when transitional IPv6 addre...
CVE-2021-21393
PUBLISHED: 2021-04-12
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 Synapse is missing input validation of some parameters on the endpoints used to confirm third-party identif...
CVE-2021-29429
PUBLISHED: 2021-04-12
In Gradle before version 7.0, files created with open permissions in the system temporary directory can allow an attacker to access information downloaded by Gradle. Some builds could be vulnerable to a local information disclosure. Remote files accessed through TextResourceFactory are downloaded in...
CVE-2021-21394
PUBLISHED: 2021-04-12
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.28.0 Synapse is missing input validation of some parameters on the endpoints used to confirm third-party identif...
CVE-2021-22497
PUBLISHED: 2021-04-12
Advanced Authentication versions prior to 6.3 SP4 have a potential broken authentication due to improper session management issue.