Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Network Security

// // //
4/16/2019
09:50 AM
Larry Loeb
Larry Loeb
Larry Loeb

Warning: VPN Application Vulnerabilities Found

That enterprise-grade virtual private network might not be as private as you think.

The Department of Homeland Security's Cybersecurity and Infrastructure Security Agency (CISA) has issued an alert about enterprise-grade virtual private networks that points to a vulnerability noteissued by CERT/CC.

The note points out that multiple virtual private network (VPN) applications store the authentication and/or session cookies insecurely in memory and/or log files.

It lists the following products performing insecure cookie storage in log files: Palo Alto Networks GlobalProtect Agent 4.1.0 for Windows and GlobalProtect Agent 4.1.10 and earlier for macOS (CVE-2019-1573) as well as Pulse Secure Connect Secure prior to 8.1R14, 8.2, 8.3R6, and 9.0R2.

The same insecurity, but stored within memory, is to be found in Palo Alto Networks GlobalProtect Agent 4.1.0 for Windows and GlobalProtect Agent 4.1.10 and earlier for macOS, Pulse Secure Connect Secure prior to 8.1R14, 8.2, 8.3R6, and 9.0R2, and Cisco AnyConnect 4.7.x and prior.

If an attacker manages to have persistent access to a VPN user's endpoint (or exfiltrates the cookie using other methods), they will be able to replay the session and bypass other authentication methods. An attacker would then have access to the same applications that the user does through their VPN session. They could potentially intercept and read traffic data, or inject malicious code/data to perform a Man-in-the-Middle (MitM) attack.

The note worryingly says that, "It is likely that this configuration is generic to additional VPN applications" and asks affected vendors to contact them with any mitigation details.

There are 237 vendors that the note gives which could possibly be affected. Check Point Software, LANCOM Systems and pfSense are given an all-clear by the note.

Pulse Secure issued a special advisory to its customers on how to deal with the situation. Calling it of medium severity, they say that "Under certain conditions, the Pulse Desktop Client and Network Connect could allow an attacker to access session tokens to replay and spoof sessions, and as a result, gain unauthorized access as an end user. The endpoint would need to be already compromised for this vulnerability to work."

They also noted that "Pulse Secure PSIRT is not aware of any malicious exploitation for this vulnerability." F5 has reissued a security advisory on the topic. They are not going to be issuing a patch, and instead say to “use a one-time password or two-factor authentication instead of password-based authentication.” Palo Alto Networks issued an advisory that points out the patched versions of the software.

CERT/CC noted that it "is unaware of any patches at the time of publishing for Cisco AnyConnect."

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Black Hat USA 2022 Attendee Report
Black Hat attendees are not sleeping well. Between concerns about attacks against cloud services, ransomware, and the growing risks to the global supply chain, these security pros have a lot to be worried about. Read our 2022 report to hear what they're concerned about now.
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2022-35942
PUBLISHED: 2022-08-12
Improper input validation on the `contains` LoopBack filter may allow for arbitrary SQL injection. When the extended filter property `contains` is permitted to be interpreted by the Postgres connector, it is possible to inject arbitrary SQL which may affect the confidentiality and integrity of data ...
CVE-2022-35949
PUBLISHED: 2022-08-12
undici is an HTTP/1.1 client, written from scratch for Node.js.`undici` is vulnerable to SSRF (Server-side Request Forgery) when an application takes in **user input** into the `path/pathname` option of `undici.request`. If a user specifies a URL such as `http://127.0.0.1` or `//127.0.0.1` ```js con...
CVE-2022-35953
PUBLISHED: 2022-08-12
BookWyrm is a social network for tracking your reading, talking about books, writing reviews, and discovering what to read next. Some links in BookWyrm may be vulnerable to tabnabbing, a form of phishing that gives attackers an opportunity to redirect a user to a malicious site. The issue was patche...
CVE-2022-35956
PUBLISHED: 2022-08-12
This Rails gem adds two methods to the ActiveRecord::Base class that allow you to update many records on a single database hit, using a case sql statement for it. Before version 0.1.3 `update_by_case` gem used custom sql strings, and it was not sanitized, making it vulnerable to sql injection. Upgra...
CVE-2022-35943
PUBLISHED: 2022-08-12
Shield is an authentication and authorization framework for CodeIgniter 4. This vulnerability may allow [SameSite Attackers](https://canitakeyoursubdomain.name/) to bypass the [CodeIgniter4 CSRF protection](https://codeigniter4.github.io/userguide/libraries/security.html) mechanism with CodeIgniter ...