Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Perimeter

Guest Blog // Selected Security Content Provided By Sophos
What's This?
4/29/2009
01:48 AM
Graham Cluley
Graham Cluley
Security Insights
50%
50%

Zero-Day Flaw Hits All Versions Of Adobe PDF Reader

I can't put this any more plainly: If you use Adobe Reader, I urge you to disable its JavaScript support today.

I can't put this any more plainly: If you use Adobe Reader, I urge you to disable its JavaScript support today.A serious security vulnerability has been found in all versions of Adobe's ubiquitous PDF reading software that could allow hackers to run unauthorized code to execute on your computer.

According to a blog post from Adobe's security response team, all currently supported shipping versions of Adobe Reader and Acrobat (Adobe Reader and Acrobat 9.1, 8.1.4, 7.1.1, and earlier versions) are vulnerable.

Yes, that means this advice is for you whether you use Windows, Macintosh, or Unix.

Users are advised to disable JavaScript in Adobe Reader and Acrobat by following these instructions:

1. Launch Acrobat or Adobe Reader. 2. Select Edit/Preferences 3. Select the JavaScript Category 4. Uncheck the 'Enable Acrobat JavaScript' option 5. Click OK

Why most people would ever need JavaScript support inside their PDF readers is another matter entirely. Seems to me like a time bomb that was always waiting to explode.

In my view it would be safer if a wider variety of PDF readers were in use, rather than the vast majority of computer users all relying on Adobe. A list of alternative (and free) PDF readers can be found at pdfreaders.org/

It's not that alternative PDF readers can't have bugs and serious security issues. They can. But at least it would mean a more diverse environment that would make life trickier for the hackers.

Graham Cluley is senior technology consultant at Sophos, and has been working in the computer security field since the early 1990s. When he's not updating his other blog on the Sophos Website, then you can find him on Twitter at @gcluley. Special to Dark Reading.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
MoviePass Leaves Credit Card Numbers, Personal Data Exposed Online
Kelly Sheridan, Staff Editor, Dark Reading,  8/21/2019
New FISMA Report Shows Progress, Gaps in Federal Cybersecurity
Curtis Franklin Jr., Senior Editor at Dark Reading,  8/21/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
7 Threats & Disruptive Forces Changing the Face of Cybersecurity
This Dark Reading Tech Digest gives an in-depth look at the biggest emerging threats and disruptive forces that are changing the face of cybersecurity today.
Flash Poll
The State of IT Operations and Cybersecurity Operations
The State of IT Operations and Cybersecurity Operations
Your enterprise's cyber risk may depend upon the relationship between the IT team and the security team. Heres some insight on what's working and what isn't in the data center.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-13139
PUBLISHED: 2019-08-22
In Docker before 18.09.4, an attacker who is capable of supplying or manipulating the build path for the "docker build" command would be able to gain command execution. An issue exists in the way "docker build" processes remote git URLs, and results in command injection into the ...
CVE-2019-15325
PUBLISHED: 2019-08-22
In GalliumOS 3.0, CONFIG_SECURITY_YAMA is disabled but /etc/sysctl.d/10-ptrace.conf tries to set /proc/sys/kernel/yama/ptrace_scope to 1, which might increase risk because of the appearance that a protection mechanism is present when actually it is not.
CVE-2019-15326
PUBLISHED: 2019-08-22
The import-users-from-csv-with-meta plugin before 1.14.2.1 for WordPress has directory traversal.
CVE-2019-15327
PUBLISHED: 2019-08-22
The import-users-from-csv-with-meta plugin before 1.14.1.3 for WordPress has XSS via imported data.
CVE-2019-15328
PUBLISHED: 2019-08-22
The import-users-from-csv-with-meta plugin before 1.14.0.3 for WordPress has XSS.