Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

7/23/2008
08:38 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Apple's iPhone Mail, Safari Apps Vulnerable To Attack

Apple's iPhone Mail and Safari apps under the iPhone 1.1.4 and 2.0 firmware are vulnerable to URL spoofing, a security researcher said Wednesday.

Apple's iPhone Mail and Safari applications are vulnerable to URL spoofing, security researcher Aviv Raff said on Wednesday.

"By creating a specially crafted URL, and sending it via an e-mail, an attacker can convince the user that the spoofed URL, showed in the mail application, is from a trusted domain...," Raff explained in a blog post. "When clicking on the URL, the Safari browser will be opened. The spoofed URL, [shown] in the address bar of the Safari browser, will still be viewed by the victim as if it is of a trusted domain."

Apple's iPhone Mail and Safari applications under the iPhone 1.1.4 and 2.0 firmware are affected. Earlier versions may be affected, too.

Raff said he plans to withhold technical details until Apple issues a fix for the flaw. He said that Apple has acknowledged the Mail vulnerability and is investigating the Safari issue.

Raff recommended that users not click on links to get to trusted sites, like online banks. Rather they should type URLs in manually until the problem is resolved.

Raff observeed that in addition to being vulnerable to phishing, iPhone users are also vulnerable to being spammed. "IPhone users should consider [not] using the Mail application until Apple fixes this issue, unless they want to be spammed," he said.

Earlier this month, Raff criticized Apple for failing to learn from past browser design mistakes.

Apple has patched 20 Safari vulnerabilities so far this year.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
How to Think Like a Hacker
Dr. Giovanni Vigna, Chief Technology Officer at Lastline,  10/10/2019
7 SMB Security Tips That Will Keep Your Company Safe
Steve Zurier, Contributing Writer,  10/11/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
7 Threats & Disruptive Forces Changing the Face of Cybersecurity
This Dark Reading Tech Digest gives an in-depth look at the biggest emerging threats and disruptive forces that are changing the face of cybersecurity today.
Flash Poll
2019 Online Malware and Threats
2019 Online Malware and Threats
As cyberattacks become more frequent and more sophisticated, enterprise security teams are under unprecedented pressure to respond. Is your organization ready?
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-13116
PUBLISHED: 2019-10-16
The MuleSoft Mule runtime engine before 3.8 allows remote attackers to execute arbitrary code because of Java Deserialization, related to Apache Commons Collections.
CVE-2019-17664
PUBLISHED: 2019-10-16
NSA Ghidra through 9.0.4 uses a potentially untrusted search path. When executing Ghidra from a given path, the Java process working directory is set to this path. Then, when launching the Python interpreter via the "Ghidra Codebrowser > Window > Python" option, Ghidra will try to ex...
CVE-2019-17665
PUBLISHED: 2019-10-16
NSA Ghidra before 9.0.2 is vulnerable to DLL hijacking because it loads jansi.dll from the current working directory.
CVE-2019-17435
PUBLISHED: 2019-10-16
A Local Privilege Escalation vulnerability exists in the GlobalProtect Agent for Windows 5.0.3 and earlier, and GlobalProtect Agent for Windows 4.1.12 and earlier, in which the auto-update feature can allow for modification of a GlobalProtect Agent MSI installer package on disk before installation.
CVE-2019-17436
PUBLISHED: 2019-10-16
A Local Privilege Escalation vulnerability exists in GlobalProtect Agent for Linux and Mac OS X version 5.0.4 and earlier and version 4.1.12 and earlier, that can allow non-root users to overwrite root files on the file system.