Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Network Security

4/16/2019
09:50 AM
Larry Loeb
Larry Loeb
Larry Loeb
50%
50%

Warning: VPN Application Vulnerabilities Found

That enterprise-grade virtual private network might not be as private as you think.

The Department of Homeland Security's Cybersecurity and Infrastructure Security Agency (CISA) has issued an alert about enterprise-grade virtual private networks that points to a vulnerability noteissued by CERT/CC.

The note points out that multiple virtual private network (VPN) applications store the authentication and/or session cookies insecurely in memory and/or log files.

It lists the following products performing insecure cookie storage in log files: Palo Alto Networks GlobalProtect Agent 4.1.0 for Windows and GlobalProtect Agent 4.1.10 and earlier for macOS (CVE-2019-1573) as well as Pulse Secure Connect Secure prior to 8.1R14, 8.2, 8.3R6, and 9.0R2.

The same insecurity, but stored within memory, is to be found in Palo Alto Networks GlobalProtect Agent 4.1.0 for Windows and GlobalProtect Agent 4.1.10 and earlier for macOS, Pulse Secure Connect Secure prior to 8.1R14, 8.2, 8.3R6, and 9.0R2, and Cisco AnyConnect 4.7.x and prior.

If an attacker manages to have persistent access to a VPN user's endpoint (or exfiltrates the cookie using other methods), they will be able to replay the session and bypass other authentication methods. An attacker would then have access to the same applications that the user does through their VPN session. They could potentially intercept and read traffic data, or inject malicious code/data to perform a Man-in-the-Middle (MitM) attack.

The note worryingly says that, "It is likely that this configuration is generic to additional VPN applications" and asks affected vendors to contact them with any mitigation details.

There are 237 vendors that the note gives which could possibly be affected. Check Point Software, LANCOM Systems and pfSense are given an all-clear by the note.

Pulse Secure issued a special advisory to its customers on how to deal with the situation. Calling it of medium severity, they say that "Under certain conditions, the Pulse Desktop Client and Network Connect could allow an attacker to access session tokens to replay and spoof sessions, and as a result, gain unauthorized access as an end user. The endpoint would need to be already compromised for this vulnerability to work."

They also noted that "Pulse Secure PSIRT is not aware of any malicious exploitation for this vulnerability." F5 has reissued a security advisory on the topic. They are not going to be issuing a patch, and instead say to “use a one-time password or two-factor authentication instead of password-based authentication.” Palo Alto Networks issued an advisory that points out the patched versions of the software.

CERT/CC noted that it "is unaware of any patches at the time of publishing for Cisco AnyConnect."

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
Why Vulnerable Code Is Shipped Knowingly
Chris Eng, Chief Research Officer, Veracode,  11/30/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-16123
PUBLISHED: 2020-12-04
An Ubuntu-specific patch in PulseAudio created a race condition where the snap policy module would fail to identify a client connection from a snap as coming from a snap if SCM_CREDENTIALS were missing, allowing the snap to connect to PulseAudio without proper confinement. This could be exploited by...
CVE-2018-21270
PUBLISHED: 2020-12-03
Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an out-of-bounds read because of allocation of uninitialized buffers when a number is passed in the input stream (when using Node.js 4.x).
CVE-2020-26248
PUBLISHED: 2020-12-03
In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.
CVE-2020-29529
PUBLISHED: 2020-12-03
HashiCorp go-slug before 0.5.0 does not address attempts at directory traversal involving ../ and symlinks.
CVE-2020-29534
PUBLISHED: 2020-12-03
An issue was discovered in the Linux kernel before 5.9.3. io_uring takes a non-refcounted reference to the files_struct of the process that submitted a request, causing execve() to incorrectly optimize unshare_fd(), aka CID-0f2122045b94.