Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Network Security

7/24/2019
09:45 AM
Larry Loeb
Larry Loeb
Larry Loeb
50%
50%

Palo Alto Networks Does Not Fully Address Vulnerability in GlobalProtect SSL VPN Solution

If Palo Alto Networks wants to keep the trust of its customers in the future, it will have to do much better in how it relates to them.

Palo Alto Networks has published an advisory about its Palo Alto GlobalProtect SSL VPN solution which is used by many organizations. The advisory was a response to research carried out by Orange Tsai and Meh Changabout their discovery of a pre-authentication remote code execution (RCE) vulnerability in it.

The researchers found that the vulnerability exists because the gateway passes the value of a particular parameter to snprintf in an unsanitized, therefore exploitable, fashion. An unauthenticated attacker could exploit this vulnerability by sending a "specially crafted" request to a vulnerable SSL VPN target in order to remotely execute code on the system.

The researchers found that, "The bug is very straightforward. It is just a simple format string vulnerability with no authentication required! The sslmgr is the SSL gateway handling the SSL handshake between the server and clients. The daemon is exposed by the Nginx reverse proxy and can be touched via the path /sslmgr. During the parameter extraction, the daemon searches the string scep-profile-name and pass its value as the snprintf format to fill in the buffer. That leads to the format string attack."

Satnam Narang at Tenable described the problem in Tenable's own blog as a "format string vulnerability in the PAN SSL Gateway, which handles client/server SSL handshakes."

Though the researchers responsibly reported the problem to PAN, the company allegedly responded that the vulnerability had been identified internally and fixed. Therefore, no CVE identifier was assigned and newer versions of GlobalProtect would not be vulnerable.

After the researchers continued to investigate, PAN assigned a CVE identifier, CVE-2019-1579, and published a security advisory, PAN-SA-2019-0020, regarding it.

This may be related to the researchers finding that Uber was running an unpatched version and was therefore vulnerable. Their in-blog exploit worked against Uber and the researchers reported their findings. Uber responded it did not use PAN SSL VPN as its "primary VPN" and that PAN's VPN was hosted on Amazon Web Services (AWS) and not a part of Uber's "core infrastructure," which mitigated some of the potential impact of this vulnerability.

The affected systems and their updates are:

  • PAN-OS 7.1.18 and earlier
  • PAN-OS 7.1.19 and later
  • PAN-OS 8.0.11 and earlier
  • PAN-OS 8.0.12 and later
  • PAN-OS 8.1.2 and earlier
  • PAN-OS 8.1.3 and later
  • PAN-OS 9.0 is not affected.

The PAN advisory admits some customers can not patch or upgrade. PAN recommends updating to "content release 8173, or a later version" as well as ensuring threat prevention is "enabled and enforced on traffic that passes through the GlobalProtect portal and GlobalProtect."

PAN tried a quick end-run around the community by not initially declaring a problem here. Just because it made internal fixes doesn't mean that these will migrate to the users that need them. The security advisory PAN issued about all of this was minimalist to the point of absurd, and unhelpful in a practical sense. If PAN wants to keep the trust of its customers in the future, it will have to do much better in how it relates to them.

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
The State of Cybersecurity Incident Response
In this report learn how enterprises are building their incident response teams and processes, how they research potential compromises, how they respond to new breaches, and what tools and processes they use to remediate problems and improve their cyber defenses for the future.
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-36239
PUBLISHED: 2021-07-29
Jira Data Center, Jira Core Data Center, Jira Software Data Center from version 6.3.0 before 8.5.16, from 8.6.0 before 8.13.8, from 8.14.0 before 8.17.0 and Jira Service Management Data Center from version 2.0.2 before 4.5.16, from version 4.6.0 before 4.13.8, and from version 4.14.0 before 4.17.0 e...
CVE-2021-37578
PUBLISHED: 2021-07-29
Apache jUDDI uses several classes related to Java's Remote Method Invocation (RMI) which (as an extension to UDDI) provides an alternate transport for accessing UDDI services. RMI uses the default Java serialization mechanism to pass parameters in RMI invocations. A remote attacker can send a malic...
CVE-2021-23416
PUBLISHED: 2021-07-28
This affects all versions of package curly-bracket-parser. When used as a template library, it does not properly sanitize the user input.
CVE-2021-23417
PUBLISHED: 2021-07-28
All versions of package deepmergefn are vulnerable to Prototype Pollution via deepMerge function.
CVE-2021-23415
PUBLISHED: 2021-07-28
This affects the package elFinder.AspNet before 1.1.1. The user-controlled file name is not properly sanitized before it is used to create a file system path.