Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Network Security

8/9/2019
01:08 PM
Larry Loeb
Larry Loeb
Larry Loeb
50%
50%

MSFT Walks Back Original Action, Admits RDP Vulnerability Affects Hyper-V

Check Point Research's Eyal Itkin told the world in February of this year that there were multiple critical vulnerabilities in the widely used RDP protocol.

Check Point Research's Eyal Itkin told the world in February of this year that there were multiple critical vulnerabilities in the widely used RDP protocol. RDP is a proprietary protocol developed by Microsoft and is usually used when a user wants to connect to a remote Windows machine.

Check Point started their investigation with open source RDP implementations, and found 11 vulnerabilities with a major security impact (19 vulnerabilities overall in the library) in the "rdesktop" v1.8.3 RDP client.

The FreeRDP 2.0.0-rc3 client performed a bit better, with five vulnerabilities with major security impact, as well as six vulnerabilities overall in the library.

Then then started looking at Mstsc.exe, which is Microsoft's RDP client. As they put it, "Soon enough, we realized that Microsoft's implementation is much better than the implementations we tested previously. Actually, it seems like Microsoft's code is better by several orders of magnitude."

But, what it did with the clipboard was interesting. The client doesn't verify the received blob that comes from the RDP server. And indeed, if the server includes a path traversal path of the form: ..\canary1.txt it was stored "as is" on the client's clipboard. Bingo. Client and server will share a clipboard, if that option is enabled. This means communication in the protocol between server and client is possible in a reverse manner through use of a shared clipboard, which could allow an attack vector for hijacking and remote code execution.

Microsoft's reply at the time to all of this was reported to be, "We determined your finding is valid but does not meet our bar for servicing. For more information, please see the Microsoft Security Servicing Criteria for Windows (https://aka.ms/windowscriteria)." Gee, that seems like a pretty gruff blowoff.

But -- aha -- it seems that the attack vector affects Hyper-V, the MSFT virtual machine controller. In fact, Dana Baril just posted a blog entry about the situation.

Baril says in it that "...because Hyper-V uses RDP, it inherits the security vulnerabilities in RDP. Hyper-V uses RDP behind the scenes for managing the VM, meaning that the vulnerability could be used to escape a Hyper-V VM, resulting in a guest-to-host sandbox escape vulnerability."

That's the sound of crows being eaten.

Microsoft Security Response Center (MSRC) worked with Check Point (they now say) to further investigate and address the vulnerability. The fix for CVE-2019-0887 was released as part of the July 2019 security update.

The icing on the cake is that CheckPoint and Microsoft had a Wednesday buddy session at this week's Black Hat convention in Las Vegas to give the "inside story." There was no word if Entertainment Tonight was going to be covering the story.

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
COVID-19: Latest Security News & Commentary
Dark Reading Staff 8/3/2020
'BootHole' Vulnerability Exposes Secure Boot Devices to Attack
Kelly Sheridan, Staff Editor, Dark Reading,  7/29/2020
Out-of-Date and Unsupported Cloud Workloads Continue as a Common Weakness
Robert Lemos, Contributing Writer,  7/28/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Special Report: Computing's New Normal, a Dark Reading Perspective
This special report examines how IT security organizations have adapted to the "new normal" of computing and what the long-term effects will be. Read it and get a unique set of perspectives on issues ranging from new threats & vulnerabilities as a result of remote working to how enterprise security strategy will be affected long term.
Flash Poll
The Threat from the Internetand What Your Organization Can Do About It
The Threat from the Internetand What Your Organization Can Do About It
This report describes some of the latest attacks and threats emanating from the Internet, as well as advice and tips on how your organization can mitigate those threats before they affect your business. Download it today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-4560
PUBLISHED: 2020-08-03
IBM Financial Transaction Manager 3.2.4 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
CVE-2019-4589
PUBLISHED: 2020-08-03
IBM Cognos Analytics 11.0 and 11.1 is vulnerable to privlege escalation where the "My schedules and subscriptions" page is visible and accessible to a less privileged user. IBM X-Force ID: 167449.
CVE-2020-4328
PUBLISHED: 2020-08-03
IBM Financial Transaction Manager 3.2.4 is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements, which could allow the attacker to view, add, modify or delete information in the back-end database. IBM X-Force ID: 177839.
CVE-2020-4377
PUBLISHED: 2020-08-03
IBM Cognos Anaytics 11.0 and 11.1 is vulnerable to an XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources. IBM X-Force ID: 179156.
CVE-2020-4534
PUBLISHED: 2020-08-03
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 could allow a local authenticated attacker to gain elevated privileges on the system, caused by improper handling of UNC paths. By scheduling a task with a specially-crafted UNC path, an attacker could exploit this vulnerability to execute arbi...