Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Attacks/Breaches

1/16/2019
12:00 PM
Connect Directly
Twitter
LinkedIn
Google+
RSS
E-Mail
50%
50%

Fortnite Players Compromised Via Epic Games Vulnerability

Bugs in Epic Games' platform could let intruders take over players' accounts, view personal data, and/or buy in-game currency.

The Fortnite logo is seen at the Paris Games Week (PGW), a trade fair for video games in Paris, France, October 25, 2018. Image Source: REUTERS/Benoit Tessier, via Adobe Stock
The Fortnite logo is seen at the Paris Games Week (PGW), a trade fair for video games in Paris, France, October 25, 2018. Image Source: REUTERS/Benoit Tessier, via Adobe Stock

Gamers beware: a vulnerability in Epic Games' online platform could have threatened data belonging to players of the massively popular video game Fortnite, Check Point researchers disclosed today. Epic Games was made aware of the problem, which has since been addressed.

Fortnite, created by Epic Games, has more than 80 million players and is responsible for nearly half of the video game developer's estimated value of $5 billion to $8 billion. Newly discovered flaws in its system could let attackers take over players' accounts, view personal account data, buy V-bucks (digital in-game currency), and record in-game chats and background home conversations.

It's not the first time Fortnite has been targeted. Previous scams tricked players into accessing fake websites that promised to generate V-bucks, which are typically only acquired in the official Fortnite store or earned through the game. These phishing sites prompted players to enter game login credentials and personal data: name, address, and credit card information.

Fortnite players, many of whom are minors, were being scammed as a result of their involvement with the game, but nobody could tell how. It may just be a game, but with millions of players, it also presents a huge opportunity for cybercriminals to take advantage of players.

"When we started to research, we immediately understood that Fortnite is not a game – it's an infrastructure," says Oded Vanunu, head of product vulnerability research at Check Point. It gives players the ability to connect, talk with people around the world, and sell and buy weapons. The business logic is deeply sophisticated and bring a lot of potential vulnerabilities.

New data indicates a more sophisticated attack method, which doesn't require users to enter any of their login details. A vulnerability in some of Epic Games' subdomains enabled a cross-site scripting (XSS) attack with a user only needing to click a link sent by the attacker. When they clicked, the adversary could instantly capture their username and password with no interaction at all.

A Risky Login Page

From the start of their research, a member of the Check Point team had a strong feeling about Epic Games' single sign-on (SSO) mechanism, analysts explain in a blog post on the discovery. They took a closer look and found that Epic Games had written a generic SSO implementation to support several login providers, so they investigated further and found the flaw.

Researchers found when a player logged into their account by clicking the "Sign In" button, the platform generated a URL with a "redirectedUrl" parameter. The redirect URL could be manipulated to send the player to any site within the domain ".epicgames.com." With this parameter under their control, attackers could send victims to a site with the XSS payload. The payload could make a request to any SSO provider—and Fortnite uses many, they point out.

Players accessing Fortnite will see Epic Games uses multiple SSO providers: PlayStationNetwork, Xbox Live, Nintendo, Facebook, and Google+. Researchers decided to use Facebook as the SSO provider for their proof-of-concept to show how players could be redirected to a vulnerable webpage where the XSS payload is executed and steals authentication code.

"Once [we've] exploited this sub-domain, we chain this specific vulnerability into an account takeover vulnerability by manipulating a parameter which is part of the main logic of the authentication process of Epic Games," Vanunu explains. Because the flaw is linked to Epic Games, he calls it a "very sophisticated method" to silently steal Fortnite users' tokens.

When they have access to a player's account, attackers can buy access or weapons, shift it to their own account, and sell it. "Lots of gamers' accounts are worth a lot of money," says Vanunu. "As long as you play on this platform, every day you're getting more seniority."

Intruders can also use their point within a user's account to chat with other Fortnite players and send them malicious content, he continues.

Epic Games has responded to the report, thanking Check Point for bringing the problem to its attention. "As always, we encourage players to protect their accounts by not re-using passwords and using strong passwords, and not sharing account information with others," a company spokesperson says.

Related Content:

Kelly Sheridan is the Staff Editor at Dark Reading, where she focuses on cybersecurity news and analysis. She is a business technology journalist who previously reported for InformationWeek, where she covered Microsoft, and Insurance & Technology, where she covered financial ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
RyanSepe
100%
0%
RyanSepe,
User Rank: Ninja
1/16/2019 | 2:52:49 PM
Extremely Simple to Exploit via a Phish
Not sure if I can post a link but here is the video of the exploit being performed via Check Point's Youtube page.

<https://www.youtube.com/watch?v=poQmRWWh45s>

If it gets redacted you can search youtube for "fortnite vulnerability". It was posted today.

 

 
The Problem with Proprietary Testing: NSS Labs vs. CrowdStrike
Brian Monkman, Executive Director at NetSecOPEN,  7/19/2019
RDP Bug Takes New Approach to Host Compromise
Kelly Sheridan, Staff Editor, Dark Reading,  7/18/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Building and Managing an IT Security Operations Program
As cyber threats grow, many organizations are building security operations centers (SOCs) to improve their defenses. In this Tech Digest you will learn tips on how to get the most out of a SOC in your organization - and what to do if you can't afford to build one.
Flash Poll
The State of IT Operations and Cybersecurity Operations
The State of IT Operations and Cybersecurity Operations
Your enterprise's cyber risk may depend upon the relationship between the IT team and the security team. Heres some insight on what's working and what isn't in the data center.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-2873
PUBLISHED: 2019-07-23
Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.2.32 and prior to 6.0.10. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox...
CVE-2019-2874
PUBLISHED: 2019-07-23
Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.2.32 and prior to 6.0.10. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox...
CVE-2019-2875
PUBLISHED: 2019-07-23
Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.2.32 and prior to 6.0.10. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox...
CVE-2019-2876
PUBLISHED: 2019-07-23
Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.2.32 and prior to 6.0.10. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox...
CVE-2019-2877
PUBLISHED: 2019-07-23
Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.2.32 and prior to 6.0.10. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox...