Vulnerabilities / Threats
7/27/2009
04:50 PM
Connect Directly
LinkedIn
Twitter
Google+
RSS
E-Mail
50%
50%

Microsoft Plans Emergency Patch Tuesday

Two out-of-band security bulletins will be issued tomorrow to fix a critical flaw in Internet Explorer and a related issue in Visual Studio. Microsoft is withholding details until the patches are released.

Microsoft late Friday said it would issue two security bulletins on Tuesday, July 28, outside of its regular monthly patch cycle. The company typically releases "out-of-band" bulletins to address vulnerabilities that demand immediate attention.

In a statement, Mike Reavey, director of the Microsoft Security Response Center, provided few particulars other than saying the two bulletins -- one affecting Visual Studio and one affecting Internet Explorer -- will address a single, overall issue. "While we can't go into specifics about the issue prior to release, we can say that the Visual Studio bulletin will address an issue that can affect certain types of applications," he said. "The Internet Explorer bulletin will provide defense-in-depth changes to Internet Explorer to help provide additional protections for the issues addressed by the Visual Studio bulletin."

He said that the Internet Explorer bulletin will address "critical" issues in Internet Explorer unrelated to the Visual Studio vulnerability.

He also said that Microsoft customers who have the most current security updates are protected from known attacks related to the vulnerabilities addressed by the two emergency bulletins.

A substantial portion of Microsoft customers are nonetheless likely to have vulnerable software. In mid-2008, according to Google, 45.2% of Internet users visiting the search site weren't using the most up-to-date version of their browser.

Out-of-band patches are unusual but certainly not unheard of. Last December, Microsoft released an out-of-band security update, MS08-078, to fix a vulnerability in Internet Explorer.

The company also released an out-of-band update last October, MS08-067, to fix a problem with Windows Server that could, and did, allow a malicious worm to spread: The vulnerability was subsequently exploited by the Conficker/Downadup worm because Microsoft users didn't patch quickly enough.

InformationWeek Analytics and DarkReading.com have published an independent analysis of security outsourcing. Download the report here (registration required).

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Flash Poll
Current Issue
Cartoon
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2014-3541
Published: 2014-07-29
The Repositories component in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via serialized data associated with an add-on.

CVE-2014-3542
Published: 2014-07-29
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) is...

CVE-2014-3543
Published: 2014-07-29
mod/imscp/locallib.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via a package with a manifest file containing an XML external entity declaration in conjunction with an entity referenc...

CVE-2014-3544
Published: 2014-07-29
Cross-site scripting (XSS) vulnerability in user/profile.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via the Skype ID profile field.

CVE-2014-3545
Published: 2014-07-29
Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to execute arbitrary code via a calculated question in a quiz.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Sara Peters hosts a conversation on Botnets and those who fight them.