Vulnerabilities / Threats
5/19/2009
01:36 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%
Repost This

Microsoft Issues IIS Security Advisory

An exploit of the vulnerability could give an attacker access to a directory that normally requires authentication.

Microsoft on Monday issued a security advisory about an authentication bypass vulnerability in certain Microsoft Internet Information Services configurations.

The company said it's investigating reports of a vulnerability that could allow privilege elevation but that it isn't aware of any attacks that have attempted to exploit this vulnerability.

Microsoft's most current IIS software, IIS 7.0 in Windows Server 2008, is not affected.

The problem has to do with the way the WebDAV extension for IIS processes HTTP requests. Using a maliciously crafted HTTP request, the attacker could gain access to a directory that normally requires authentication.

Jonathan Ness, an engineer with the Microsoft Security Response Center, characterizes the risk as primarily one of information disclosure.

"[T]he most likely attack would be a malicious anonymous user requesting contents of a Web server subdirectory that uses IIS permission restricting access to only authenticated users," he explains in a blog post. "The root of the Web server would typically grant read access to the anonymous user account so this vulnerability would allow the protected subdirectories to be accessed using the permissions of the Web server root (allowing anonymous access)."

A number of factors mitigate the severity of the vulnerability:

  • The file system's access control list remains in place, so an attacker who managed to access a system using the vulnerability would still be limited by ACL permissions for an anonymous user account.
  • Anonymous user accounts are limited to read-only access by default. So unless an administrator has overridden this setting, an attacker would not have the ability to write files.
  • WebDAV is not enabled by default on Windows Server 2003 systems running IIS 6.0.

IIS users most at risk are those running IIS 5, 5.1, or 6.0 with WebDAV enabled, using IIS permissions to restrict access to a subdirectory that's inside a directory allowing anonymous access, and who have granted file system access to the anonymous user account.


InformationWeek Analytics has published an independent analysis on what executives really think about security. Download the report here (registration required).

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2012-3946
Published: 2014-04-24
Cisco IOS before 15.3(2)S allows remote attackers to bypass interface ACL restrictions in opportunistic circumstances by sending IPv6 packets in an unspecified scenario in which expected packet drops do not occur for "a small percentage" of the packets, aka Bug ID CSCty73682.

CVE-2012-5723
Published: 2014-04-24
Cisco ASR 1000 devices with software before 3.8S, when BDI routing is enabled, allow remote attackers to cause a denial of service (device reload) via crafted (1) broadcast or (2) multicast ICMP packets with fragmentation, aka Bug ID CSCub55948.

CVE-2013-6738
Published: 2014-04-24
Cross-site scripting (XSS) vulnerability in IBM SmartCloud Analytics Log Analysis 1.1 and 1.2 before 1.2.0.0-CSI-SCALA-IF0003 allows remote attackers to inject arbitrary web script or HTML via an invalid query parameter in a response from an OAuth authorization endpoint.

CVE-2014-0188
Published: 2014-04-24
The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to...

CVE-2014-2391
Published: 2014-04-24
The password recovery service in Open-Xchange AppSuite before 7.2.2-rev20, 7.4.1 before 7.4.1-rev11, and 7.4.2 before 7.4.2-rev13 makes an improper decision about the sensitivity of a string representing a previously used but currently invalid password, which allows remote attackers to obtain potent...

Best of the Web