Vulnerabilities / Threats
9/4/2009
02:26 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Microsoft Expands IIS Vulnerability Warning

Following up on a Security Advisory published earlier this week, Microsoft has added IIS 7.0 to the list of vulnerable configurations

Microsoft on Friday updated the Security Advisory it issued on Tuesday, expanding its warning about a vulnerability in its Internet Information Services (IIS) server software.

Based on additional proof-of-concept exploits that could allow denial-of-service attacks and on limited attempts to exploit the vulnerability, Microsoft now says that IIS 5.0, 5.1, 6.0, and 7.0 are vulnerable to a denial-of-service attacks.

This supersedes Microsoft's previous assertion that "IIS 7.0 (Windows Vista, Windows Server 2008) is not vulnerable."

In addition, users of IIS 5.0 are vulnerable to remote code execution if they allow anonymous FTP.

The IIS vulnerability is related to a stack overflow bug in the IIS FTP module. If an IIS installation allows anonymous FTP, a malicious user could log in and create a directory name so long that it created an overflow condition. A successful attempt to exploit this flaw allows the execution of code in the context of LocalSystem.

Microsoft is advising IIS users to turn off the FTP service unless its needed. It is also recommending that users configure their servers to prevent the creation of new directories and to deny anonymous users write privileges using the appropriate IIS settings.

Microsoft says that it plans to release five "critical" Security Bulletins on Tuesday, September 8, its regularly scheduled "patch day."

It's not clear whether the IIS flaw will be addressed, but given the circumstances under which the vulnerability was disclosed -- a public posting, without prior notification to Microsoft -- it's unlikely that Microsoft will have enough time to thoroughly test a fix for the problem.


InformationWeek Analytics has published an analysis of the current state of identity management. Download the report here (registration required).

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Flash Poll
Current Issue
Cartoon
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2014-0640
Published: 2014-08-20
EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote authenticated users to bypass intended restrictions on resource access via unspecified vectors.

CVE-2014-0641
Published: 2014-08-20
Cross-site request forgery (CSRF) vulnerability in EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote attackers to hijack the authentication of arbitrary users.

CVE-2014-2505
Published: 2014-08-20
EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote attackers to trigger the download of arbitrary code, and consequently change the product's functionality, via unspecified vectors.

CVE-2014-2511
Published: 2014-08-20
Multiple cross-site scripting (XSS) vulnerabilities in EMC Documentum WebTop before 6.7 SP1 P28 and 6.7 SP2 before P14 allow remote attackers to inject arbitrary web script or HTML via the (1) startat or (2) entryId parameter.

CVE-2014-2515
Published: 2014-08-20
EMC Documentum D2 3.1 before P24, 3.1SP1 before P02, 4.0 before P11, 4.1 before P16, and 4.2 before P05 does not properly restrict tickets provided by D2GetAdminTicketMethod and D2RefreshCacheMethod, which allows remote authenticated users to gain privileges via a request for a superuser ticket.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Three interviews on critical embedded systems and security, recorded at Black Hat 2014 in Las Vegas.