Vulnerabilities / Threats
7/23/2008
08:38 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Apple's iPhone Mail, Safari Apps Vulnerable To Attack

Apple's iPhone Mail and Safari apps under the iPhone 1.1.4 and 2.0 firmware are vulnerable to URL spoofing, a security researcher said Wednesday.

Apple's iPhone Mail and Safari applications are vulnerable to URL spoofing, security researcher Aviv Raff said on Wednesday.

"By creating a specially crafted URL, and sending it via an e-mail, an attacker can convince the user that the spoofed URL, showed in the mail application, is from a trusted domain...," Raff explained in a blog post. "When clicking on the URL, the Safari browser will be opened. The spoofed URL, [shown] in the address bar of the Safari browser, will still be viewed by the victim as if it is of a trusted domain."

Apple's iPhone Mail and Safari applications under the iPhone 1.1.4 and 2.0 firmware are affected. Earlier versions may be affected, too.

Raff said he plans to withhold technical details until Apple issues a fix for the flaw. He said that Apple has acknowledged the Mail vulnerability and is investigating the Safari issue.

Raff recommended that users not click on links to get to trusted sites, like online banks. Rather they should type URLs in manually until the problem is resolved.

Raff observeed that in addition to being vulnerable to phishing, iPhone users are also vulnerable to being spammed. "IPhone users should consider [not] using the Mail application until Apple fixes this issue, unless they want to be spammed," he said.

Earlier this month, Raff criticized Apple for failing to learn from past browser design mistakes.

Apple has patched 20 Safari vulnerabilities so far this year.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Flash Poll
Current Issue
Cartoon
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2014-0640
Published: 2014-08-20
EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote authenticated users to bypass intended restrictions on resource access via unspecified vectors.

CVE-2014-0641
Published: 2014-08-20
Cross-site request forgery (CSRF) vulnerability in EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote attackers to hijack the authentication of arbitrary users.

CVE-2014-2505
Published: 2014-08-20
EMC RSA Archer GRC Platform 5.x before 5.5 SP1 allows remote attackers to trigger the download of arbitrary code, and consequently change the product's functionality, via unspecified vectors.

CVE-2014-2511
Published: 2014-08-20
Multiple cross-site scripting (XSS) vulnerabilities in EMC Documentum WebTop before 6.7 SP1 P28 and 6.7 SP2 before P14 allow remote attackers to inject arbitrary web script or HTML via the (1) startat or (2) entryId parameter.

CVE-2014-2515
Published: 2014-08-20
EMC Documentum D2 3.1 before P24, 3.1SP1 before P02, 4.0 before P11, 4.1 before P16, and 4.2 before P05 does not properly restrict tickets provided by D2GetAdminTicketMethod and D2RefreshCacheMethod, which allows remote authenticated users to gain privileges via a request for a superuser ticket.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Three interviews on critical embedded systems and security, recorded at Black Hat 2014 in Las Vegas.