Vulnerabilities / Threats
2/20/2009
01:36 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Adobe Warns Of Critical Vulnerability In Acrobat, Reader

Users are advised to disable JavaScript until Adobe releases a patch, which may not occur for more than two weeks.

Adobe on Thursday warned that a critical security vulnerability exists in its Acrobat and Reader software.

"This vulnerability would cause the application to crash and could potentially allow an attacker to take control of the affected system," Adobe says in its security advisory. "There are reports that this issue is being exploited."

Symantec security researcher Patrick Fitzgerald explains that the vulnerability is caused by a PDF parsing error. "Once the malicious document is opened it will trigger the vulnerability," he said in a blog post. "The JavaScript payload then sprays the heap with the malicious shellcode in an attempt to increase the chances of a successful exploit. If the exploit is successful, a malicious binary will be dropped and executed on the victim's system."

Fitzgerald says that the malicious payload is a backdoor Trojan that comes from an open source toolkit known as Ghost that originated in China. Once installed on a computer, it allows the attacker to view the victim's desktop, record keystrokes, and access the machine remotely.

The vulnerability affects Adobe Reader 9 and earlier versions, and Adobe Acrobat Standard, Pro, Pro Extended 9, and earlier versions.

Adobe plans to release updates for Acrobat Reader 9 and Acrobat 9 by March 11, with updates for earlier versions of the software to follow.

In the meantime, Steven Adair, a security researcher with Shadowserver Foundation, advises that users disable JavaScript on their computers if they use either Adobe Reader or Adobe Acrobat.

"[W]e found that disabling JavaScript would definitely prevent the malware from being installed on the system," he explained in an online post. "However, it would still result in the crash of the application. We would HIGHLY recommend that you DISABLE JAVASCRIPT in your Adobe Acrobat [Reader] products. You have the choice of small loss in functionality and a crash versus your systems being compromised and all your data being stolen. It should be an easy choice."

In addition, US-CERT recommends preventing PDF documents from being opened automatically in Internet Explorer, disabling the display of PDF documents in any Web browser, and exercising caution when one receives PDF files from an unknown source.


Want to hear more about security for rich Internet applications? Black Hat is hosting a Webcast on this topic on Thursday, Feb. 26. Find out more (registration required).

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Companies Blindly Believe They've Locked Down Users' Mobile Use
Dawn Kawamoto, Associate Editor, Dark Reading,  11/14/2017
Microsoft Word Vuln Went Unnoticed for 17 Years: Report
Kelly Sheridan, Associate Editor, Dark Reading,  11/14/2017
121 Pieces of Malware Flagged on NSA Employee's Home Computer
Kelly Jackson Higgins, Executive Editor at Dark Reading,  11/16/2017
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Managing Cyber-Risk
An online breach could have a huge impact on your organization. Here are some strategies for measuring and managing that risk.
Flash Poll
The State of Ransomware
The State of Ransomware
Ransomware has become one of the most prevalent new cybersecurity threats faced by today's enterprises. This new report from Dark Reading includes feedback from IT and IT security professionals about their organization's ransomware experiences, defense plans, and malware challenges. Find out what they had to say!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.