Vulnerabilities / Threats
3/26/2013
04:43 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

The Scope Of The Java Problem

New Websense data highlights why Java is attackers' favorite target: most end users run outdated versions of the app

Nearly 95 percent of endpoints actively running Java are vulnerable to at least a single Java exploit, according to new data from Websense.

The security firm decided to measure the actual state of Java vulnerability when it comes to users and their Java versions, and the numbers weren't pretty: 75 percent of end users run a version of Java in their browser that's at least six months out of date; two-thirds, a year out of date; and 50 percent, more than two years out of date. And nearly one-fourth of users employ a Java version that is more than four years old.

"It is probably no surprise that the largest single exploited vulnerability is the most recent one, with a vulnerable population of browsers at 93.77%. That's what the bad guys do — examine your security controls and find the easiest way to bypass them," according to a Websense blog post yesterday with the new data. "Grabbing a copy of the latest version of Cool and using a pre-packaged exploit is a pretty low bar to go after such a large population of vulnerable browsers."

Then there are the earlier versions of Java, prior to Version 7: some 79 percent of end users are still running that iteration of the app. The really bad news here is that the latest update to Java Development Kit 6, update 43, is the last one Oracle plans to release for that version of JDK . The software firm recommends that users move to JDK 7. "This means that more than 77 percent of users (based on requests from our research) are currently using Java version that are essentially [end of life] and will not be updated, patched or supported by Oracle," according to Websense.

The security firm got the real-time data on tens of millions of endpoints worldwide from its ThreatSeeker network. It found that only five percent of users are running the newest version of the Java Runtime Environment, 1.7.17.

Java Users Release Dates
(click image for larger view)
A look at the versions of Java Runtime Environment, based on active browser usage. Source: Websense

Have a comment on this story? Please click "Add Your Comment" below. If you'd like to contact Dark Reading's editors directly, send us a message.

Kelly Jackson Higgins is Executive Editor at DarkReading.com. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
hunterpj
50%
50%
hunterpj,
User Rank: Strategist
4/4/2013 | 4:46:59 PM
re: The Scope Of The Java Problem
In the corporate world-ádisconnecting-áfrom older versions of Java is difficult. We have numerous internal applications and tools as well as external partners that do not support JDK 7. We are considering virtual systems locked down so that they just connect to our internal and partner resources when Java is required, while everyday user systems will be prevented from installing Java.
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Dark Reading Must Reads - September 25, 2014
Dark Reading's new Must Reads is a compendium of our best recent coverage of identity and access management. Learn about access control in the age of HTML5, how to improve authentication, why Active Directory is dead, and more.
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2003-1598
Published: 2014-10-01
SQL injection vulnerability in log.header.php in WordPress 0.7 and earlier allows remote attackers to execute arbitrary SQL commands via the posts variable.

CVE-2011-4624
Published: 2014-10-01
Cross-site scripting (XSS) vulnerability in facebook.php in the GRAND FlAGallery plugin (flash-album-gallery) before 1.57 for WordPress allows remote attackers to inject arbitrary web script or HTML via the i parameter.

CVE-2012-0811
Published: 2014-10-01
Multiple SQL injection vulnerabilities in Postfix Admin (aka postfixadmin) before 2.3.5 allow remote authenticated users to execute arbitrary SQL commands via (1) the pw parameter to the pacrypt function, when mysql_encrypt is configured, or (2) unspecified vectors that are used in backup files gene...

CVE-2012-5485
Published: 2014-09-30
registerConfiglet.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via unspecified vectors, related to the admin interface.

CVE-2012-5486
Published: 2014-09-30
ZPublisher.HTTPRequest._scrubHeader in Zope 2 before 2.13.19, as used in Plone before 4.3 beta 1, allows remote attackers to inject arbitrary HTTP headers via a linefeed (LF) character.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Chris Hadnagy, who hosts the annual Social Engineering Capture the Flag Contest at DEF CON, will discuss the latest trends attackers are using.