Vulnerabilities / Threats
1/15/2016
03:13 PM
Connect Directly
Twitter
LinkedIn
RSS
E-Mail
50%
50%

OpenSSH Patches Flaw That Lets Attackers Steal Private Keys

Flaw exists in an a feature that is turned on by default in all OpenSSH clients between versions 5.4 and 7.1, says Qualys

OpenSSH has patched a vulnerability that could allow an attacker to steal the private cryptographic keys that are used by client computers to authenticate access to different systems.

The flaw exists in an undocumented feature in all OpenSSH versions between 5.4 and 7.1, security vendor Qualys, which discovered the flaw, and OpenSSH, said in two separate advisories this week. An attacker that exploited the issue would potentially be able to steal the private keys of users and then impersonate them to log into other systems.

“The information disclosed [is] SSH keys, which are widely used for automation of system administration tasks and interactive logins,” Qualys CTO Wolfgang Kandek said in a statement, accompanying the alert.

“Gaining access to these keys would allow an attacker to pose as [the] owner of the keys, often then with system administration privileges,” Kandek noted. Such access would allow the attackers to install anything they wanted on the vulnerable system including malware and backdoors.

One big caveat though is that in order to exploit the flaw, an attacker has to have actual administrative control of an SSH server, he said. It is only when a user with a computer running OpenSSH connects to a malicious SSH server, or a server that has been compromised, that the vulnerability can be exploited. The likelihood of that happening should be pretty rare, Kandek noted.

The problem exists in OpenSSH client code starting from version 5.4 that provides what OpenSSH described as “experimental support” for resuming SSH-connections that may have been interrupted.

According to Kandek, the goal in including the “roaming” support was to ensure that if the connection between an SSH server and client terminated unexpectedly, the client is able to reconnect and resume the interrupted SSH session. The roaming support is enabled by default on all OpenSSH client versions from 5.4 to 7.1 but is not available on SSH servers. Even so, an attacker with administrative access to an SSH server would be able to exploit the flaw.

Amol Sarwate, director of engineering and head of vulnerability research for Qualys says that flaws like these show how client-side vulnerabilities are not exclusive to software like Adobe, but also to command line software such as OpenSSH.

“Most people forget that when they are connecting to a server using OpenSSH client, the server can adversely affect you using such client-side vulnerabilities,” he says.

OpenSSH is the most commonly used protocol by administrators and server operators to connect to a remote machine in Linux and Unix environments, Sarwate adds.

One way an attacker could exploit the flaw on a large scale is to host a malicious SSH server and get users with OpenSSH clients to connect to it, by blogging about the server or emailing the address to the target audience, Sarwate says. “When victim machines connect to the server using the OpenSSH client, they will be compromised.”

Both Qualys and OpenSSH urged users to apply the patch immediately. In its alert OpenSSH said that turning off the Use Roaming function in the OpenSSH client is also another way to mitigate the risk posed by the vulnerability.

Jai Vijayan is a seasoned technology reporter with over 20 years of experience in IT trade journalism. He was most recently a Senior Editor at Computerworld, where he covered information security and data privacy issues for the publication. Over the course of his 20-year ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
gsatpathy
50%
50%
gsatpathy,
User Rank: Apprentice
1/20/2016 | 5:55:13 PM
Work Around
Work Around i,e dont "UseRoaming" seems ok.However upgrading to latest OpenSSH client would be a better solution.
RyanSepe
50%
50%
RyanSepe,
User Rank: Ninja
1/19/2016 | 12:51:11 PM
Large Caveat
That is a hefty caveat. One might say that if the caveat comes to pass that even if your servers were still vulnerable that the infiltrator could do a good deal of damage.
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: Janice, I think I've got a message from the code father!
Current Issue
Security Operations and IT Operations: Finding the Path to Collaboration
A wide gulf has emerged between SOC and NOC teams that's keeping both of them from assuring the confidentiality, integrity, and availability of IT systems. Here's how experts think it should be bridged.
Flash Poll
New Best Practices for Secure App Development
New Best Practices for Secure App Development
The transition from DevOps to SecDevOps is combining with the move toward cloud computing to create new challenges - and new opportunities - for the information security team. Download this report, to learn about the new best practices for secure application development.
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.

Dark Reading Radio
Archived Dark Reading Radio
In past years, security researchers have discovered ways to hack cars, medical devices, automated teller machines, and many other targets. Dark Reading Executive Editor Kelly Jackson Higgins hosts researcher Samy Kamkar and Levi Gundert, vice president of threat intelligence at Recorded Future, to discuss some of 2016's most unusual and creative hacks by white hats, and what these new vulnerabilities might mean for the coming year.