Risk

9/7/2009
10:08 PM
George V. Hulme
George V. Hulme
Commentary
50%
50%

Patch Tuesday: Five Critical

Security managers and operation teams will be greeted with a handful of significant Microsoft patches when they return to work Tuesday afternoon. Unfortunately for them, the most aggravation and the significant danger may come from the patch that isn't on the docket.

Security managers and operation teams will be greeted with a handful of significant Microsoft patches when they return to work Tuesday afternoon. Unfortunately for them, the most aggravation and the significant danger may come from the patch that isn't on the docket.While most of us were thinking about what we're going to do over the long holiday weekend, Microsoft delivered its advance security notification on Thursday. That notification details that all five of the patches address "remote code execution" flaws in Windows. Four of the bulletins affect all supported versions of Windows, while one bulletin may not involved Vista or Server 2008. Expect a lot of system reboots, as all may require a system restart. Since all of these flaws are reportedly remotely exploitable and affect all currently supported versions of Windows, it's best to prepare to patch right away and assume functioning exploit code will surface faster than one can say Windows 7.

However, there is a known issue with versions (of which plenty are still running) of Internet Information Systems (IIS) software. Exploit code for this flaw is already available, and Microsoft's Jerry Bryant posted this blog that said Microsoft software engineers are diligently working on a fix:

In related news, you will note that the ANS does not specify an update for the Internet Information Services FTP service vulnerability for which we released security advisory 975191 on Tuesday of this week. As noted in an earlier blog post, we have spun up our SSIRP (Software Security Incident Response Process) process to address this issue and our teams are working hard to produce an update.
InformationWeek's Thomas Claburn, on Friday, reported that Microsoft enhanced its warning on Internet Information Services software, stating that the vulnerabilities don't just affect older IIS versions but:
Based on additional proof-of-concept exploits that could allow denial-of-service attacks and on limited attempts to exploit the vulnerability, Microsoft now says that IIS 5.0, 5.1, 6.0, and 7.0 are vulnerable to a denial-of-service attacks.
So, let's hope a workable patch comes fast.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Companies Blindly Believe They've Locked Down Users' Mobile Use
Dawn Kawamoto, Associate Editor, Dark Reading,  11/14/2017
Microsoft Word Vuln Went Unnoticed for 17 Years: Report
Kelly Sheridan, Associate Editor, Dark Reading,  11/14/2017
121 Pieces of Malware Flagged on NSA Employee's Home Computer
Kelly Jackson Higgins, Executive Editor at Dark Reading,  11/16/2017
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Managing Cyber-Risk
An online breach could have a huge impact on your organization. Here are some strategies for measuring and managing that risk.
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.