Risk
7/15/2010
12:34 PM
50%
50%

Mozilla Disables Firefox Add-On, Recommends Upgrade

The disabled Mozilla Sniffer was intercepting login data and transmitting it to a third-party website; upgrading to the latest version of the CoolPreviews add-on is recommended due to security vulnerability.

The Mozilla Foundation, which maintains the popular Firefox web browser, announced Tuesday that it removed a Firefox add-on called "Mozilla Sniffer" which was intercepting login data and transmitting it to a third-party website. Mozilla also warned of a security escalation vulnerability in the CoolPreviews add-on and recommended that users upgrade immediately to the latest version.

Before its removal, Mozilla Sniffer had been downloaded approximately 1,800 times and had 334 active daily users. Mozilla said that each of them should have now received an uninstall notification. Furthermore, anyone with the add-on currently installed can uninstall it to prevent further passwords from being intercepted. Mozilla also recommended that anyone who has used the tool immediately change all of their passwords.

At the time of the vulnerability announcement, however, Mozilla noted that the website collecting information from Mozilla Sniffer was down, making it unclear whether the threat was still active.

Mozilla Sniffer was a variation on Tamper Data, designed for viewing and modifying HTTP and HTTPS headers and post parameters. Many developers use that add-on for testing web application behavior, to monitor exactly what data gets passed via HTTP, or for penetration testing. Tamper Data, however, doesn't route intercepted data to an external website.

Mozilla also warned that a security escalation vulnerability had been found in version 3.0.1 of the CoolPreviews add-on, which could be exploited via a specially crafted hyperlink. According to Mozilla, "if the user hovers the cursor over this link, the preview function executes remote JavaScript code with local chrome privileges, giving the attacking script control over the host computer."

Proof of concept code for exploiting the vulnerability has been released, though Mozilla said that no malicious exploits have yet been detected. But as of Tuesday, 177,000 users - less than one-quarter of the software's install base - were still running a vulnerable version. Mozilla advised them to install the latest, patched version.

To prevent add-ons such as Tamper Data from gaining distribution, Mozilla is also retooling its code-review policies. Technically, Tamper Data was an experimental add-on, meaning that users had to click through warnings that it hadn't been reviewed and might pose a threat.

As Mozilla noted in its security announcement, "unreviewed add-ons are scanned for known viruses, trojans, and other malware, but some types of malicious behavior can only be detected in a code review."

Accordingly, Mozilla plans to require code reviews for all add-ons before they become publicly available on Mozilla's website.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2015-0211
Published: 2015-06-01
mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 does not consider the moodle/course:manageactivities and mod/lti:addinstance capabilities before proceeding with registered-tool list searches, which allows remote authenticated users to obtain s...

CVE-2015-0212
Published: 2015-06-01
Cross-site scripting (XSS) vulnerability in course/pending.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted course summary.

CVE-2015-0213
Published: 2015-06-01
Multiple cross-site request forgery (CSRF) vulnerabilities in (1) editcategories.html and (2) editcategories.php in the Glossary module in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allow remote attackers to hijack the authentication of unspecified victims.

CVE-2015-0214
Published: 2015-06-01
message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

CVE-2015-0215
Published: 2015-06-01
calendar/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to obtain sensitive calendar-event information via a web-services request.

Dark Reading Radio
Archived Dark Reading Radio
After a serious cybersecurity incident, everyone will be looking to you for answers -- but you’ll never have complete information and you’ll never have enough time. So in those heated moments, when a business is on the brink of collapse, how will you and the rest of the board room executives respond?