Risk

9/9/2010
12:02 PM
Connect Directly
Twitter
RSS
E-Mail
50%
50%

Federal Cyber Watchdog Bombs Cybersecurity Audit

Department of Homeland Security inspector general says US-CERT isn't properly patching and securing its systems or complying with policy.




Slideshow: Next Generation Defense Technologies
(click for larger image and for full photo gallery)
The United States Computer Emergency Readiness Team (US-CERT), the federal agency tasked with compiling and disseminating information and technical assistance about cybersecurity incidents to both the government and public, doesn't have its own cybersecurity entirely in order, according to a review by Department of Homeland Security (DHS) auditors.

The review looked into US-CERT's four main IT systems, including the Mission Operating Environment (MOE), Einstein, the Homeland Security Information Network (the agency's portal), and the agency's public website. The MOE allows US-CERT personnel to exchange and access security incident data and system anomalies. Einstein includes intrusion detection and network flow monitoring systems mandated for use by federal agencies.

While the MOE server rooms require smartcards for access and are monitored by video, the DHS's inspector general warned that the MOE systems themselves suffered from hundreds of high-risk vulnerabilities. The inspector general used Tenable Network Security's Nessus vulnerability scanning software to discover a total of 540 vulnerabilities on MOE systems, including 202 that were deemed to be "high-risk," meaning that they "can compromise the confidentiality, integrity, and availability of sensitive data."

"MOE application and operating system vulnerabilities that are not mitigated could compromise the Einstein data accessed through the system," the report said. "These vulnerabilities could lead to arbitrary code execution, buffer overflow, escalation of privileges, and denial-of-service attacks."

The vulnerabilities, the report said, generally result from inadequate application patching, despite edicts from DHS and the National Institute of Standards and Technology to keep software patches up-to-date. The problems include vulnerabilities in Microsoft applications, Adobe Acrobat, and Sun Java running on both Windows and Red Hat Linux operating systems.

While auditors were carrying out their review, MOE application patches were being applied manually, rather than automatically, and because MOE consists of hundreds of machines, this process was arduous and patches weren't getting applied quickly or universally. This has since changed, as the National Cyber Security Division (the agency that operates US-CERT) recently deployed software management systems that can automatically patch software. NCSD has also patched the identified vulnerabilities.

The report found that, contrary to Federal Information Security Management Act requirements, NCSD hadn't updated the status of known security weaknesses as part of its cybersecurity plan. It also hadn't established adequate cybersecurity awareness or role-based cybersecurity training programs, as it hadn't identified required security courses and focus areas for system administrators and contractors and hadn't appointed a cybersecurity training coordinator.

In addition, NCSD's staff hadn't reviewed or approved FISMA-required certification and accreditation documentation and conducted only incomplete self-assessments of the agency's cybersecurity systems. It also wasn't complying with DHS policies for firewall testing and physical security of server rooms.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Ransomware Grabs Headlines but BEC May Be a Bigger Threat
Marc Wilczek, Digital Strategist & CIO Advisor,  10/12/2017
20 Questions to Ask Yourself before Giving a Security Conference Talk
Joshua Goldfarb, Co-founder & Chief Product Officer, IDDRA,  10/16/2017
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: Be a unicorn, not a donkey...
Current Issue
Security Vulnerabilities: The Next Wave
Just when you thought it was safe, researchers have unveiled a new round of IT security flaws. Is your enterprise ready?
Flash Poll
The State of Ransomware
The State of Ransomware
Ransomware has become one of the most prevalent new cybersecurity threats faced by today's enterprises. This new report from Dark Reading includes feedback from IT and IT security professionals about their organization's ransomware experiences, defense plans, and malware challenges. Find out what they had to say!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.