Endpoint

10/18/2017
02:45 PM
Connect Directly
Twitter
Twitter
RSS
E-Mail
50%
50%

Game Change: Meet the Mach37 Fall Startups

CEOs describe how they think their fledgling ventures will revolutionize user training, privacy, identity management and embedded system security.
Previous
1 of 7
Next

With a growing pedigree in cybersecurity, the Mach37 Cyber Accelerator is back in session for the fall with a new crop of participants hoping to gain valuable advice and direction from mentors connected to the program.

Sponsored by the Center for Innovation Technology in Virginia, Mach37 has now helped 52 companies with launch or development assistance that includes close mentorship from fellow entrepreneurs, investors and domain experts in the security world, and a modest $50,000 grant to help bring ideas to fruition. Most importantly, the experience provides a valuable networking opportunity for participants to rub shoulders with the who's who of security.

The momentum continues during the next three months with another round of six companies that aim to change the game in a range of security niches, including training, privacy, identity management and embedded systems security. We reached out to the CEOs of each firm to get to know their companies better. 

 

Ericka Chickowski specializes in coverage of information technology and business innovation. She has focused on information security for the better part of a decade and regularly writes about the security industry as a contributor to Dark Reading.  View Full Bio

Previous
1 of 7
Next
Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
jpbourget
50%
50%
jpbourget,
User Rank: Author
10/20/2017 | 2:19:52 PM
Congrats
Congrats to all the new companys. - Syncurity Mach37 Fall 2014
royJfischer
50%
50%
royJfischer,
User Rank: Apprentice
10/20/2017 | 12:58:46 AM
Dissertation Writing Service
Thanks for sharing
New Mexico Man Sentenced on DDoS, Gun Charges
Dark Reading Staff 5/18/2018
Is Threat Intelligence Garbage?
Chris McDaniels, Chief Information Security Officer of Mosaic451,  5/23/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: Shhh!  They're watching... And you have a laptop?  
Current Issue
Flash Poll
[Strategic Security Report] How Enterprises Are Attacking the IT Security Problem
[Strategic Security Report] How Enterprises Are Attacking the IT Security Problem
Enterprises are spending more of their IT budgets on cybersecurity technology. How do your organization's security plans and strategies compare to what others are doing? Here's an in-depth look.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2013-3018
PUBLISHED: 2018-05-24
The AXIS webapp in deploy-tomcat/axis in IBM Tivoli Application Dependency Discovery Manager (TADDM) 7.1.2 and 7.2.0 through 7.2.1.4 allows remote attackers to obtain sensitive configuration information via a direct request, as demonstrated by happyaxis.jsp. IBM X-Force ID: 84354.
CVE-2013-3023
PUBLISHED: 2018-05-24
IBM Tivoli Application Dependency Discovery Manager (TADDM) 7.1.2 and 7.2.0 through 7.2.1.4 might allow remote attackers to obtain sensitive information about Tomcat credentials by sniffing the network for a session in which HTTP is used. IBM X-Force ID: 84361.
CVE-2013-3024
PUBLISHED: 2018-05-24
IBM WebSphere Application Server (WAS) 8.5 through 8.5.0.2 on UNIX allows local users to gain privileges by leveraging improper process initialization. IBM X-Force ID: 84362.
CVE-2018-5674
PUBLISHED: 2018-05-24
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader before 9.1 and PhantomPDF before 9.1. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw...
CVE-2018-5675
PUBLISHED: 2018-05-24
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader before 9.1 and PhantomPDF before 9.1. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw...