Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

10/9/2009
04:01 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Google Patches Google Pack Vulnerability

Google Pack, the company's collection of free Google and third-party applications, had a vulnerable component that Google has just fixed.

Google says that it has fixed a vulnerability in its Google Pack software suite, a flaw that could have allowed an attacker to execute arbitrary commands.

The PC version of Google Pack contains a Google Apps component, googleapps.exe, that, until earlier this week, was vulnerable to remote command injection. The Mac version of Google Pack is not affected because it does not contain the vulnerable component.

"We developed a fix for this issue earlier this week, and we're in the process of rolling it out to affected versions of Google Pack," a Google spokesperson said.

The PC version of Google Pack that's available online was repaired on Wednesday. Users who downloaded the software previously will receive a patch, if they haven't already, through Google's automatic updater.

According to Google's spokesperson, the issue was introduced as a result of code change four months ago, so users who downloaded Google Pack before then do not have the vulnerable component.

The vulnerability has to do with the way the "googleapps.url.mailto:" URI handles data, such as the "--renderer-path" argument.

Proof of concept code appears to have been posted on October 1, without prior disclosure to Google. The company found out about the exploit code the following day and says it isn't aware of attempts to exploit the flaw.

The scenario by which this vulnerability could be exploited requires several preconditions: a potential victim would have to visit a malicious Web site using Internet Explorer after having installed a vulnerable version of Google Pack with Google Chrome. The malicious site would initiate the attack, which would pass through Internet Explorer, the vulnerable Google Apps component, and Google Chrome.

Through remote command injection, the vulnerability could be used to launch an arbitrary batch file from a remote network share or to launch an arbitrary executable from the local system, according to the inline comments posted with the exploit code.

Were such an attack to take place -- an increasingly remote possibility as the patch percolates out -- it would affect the user's computer rather than Google's servers.



InformationWeek and Dr. Dobb's have published an in-depth report on how Web application development is moving to online platforms. Download the report here (registration required).

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
6 Emerging Cyber Threats That Enterprises Face in 2020
This Tech Digest gives an in-depth look at six emerging cyber threats that enterprises could face in 2020. Download your copy today!
Flash Poll
State of Cybersecurity Incident Response
State of Cybersecurity Incident Response
Data breaches and regulations have forced organizations to pay closer attention to the security incident response function. However, security leaders may be overestimating their ability to detect and respond to security incidents. Read this report to find out more.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-10696
PUBLISHED: 2020-03-31
A path traversal flaw was found in Buildah in versions before 1.14.5. This flaw allows an attacker to trick a user into building a malicious container image hosted on an HTTP(s) server and then write files to the user's system anywhere that the user has permissions.
CVE-2020-5344
PUBLISHED: 2020-03-31
Dell EMC iDRAC7, iDRAC8 and iDRAC9 versions prior to 2.65.65.65, 2.70.70.70, 4.00.00.00 contain a stack-based buffer overflow vulnerability. An unauthenticated remote attacker may exploit this vulnerability to crash the affected process or execute arbitrary code on the system by sending specially cr...
CVE-2020-5292
PUBLISHED: 2020-03-31
Leantime before versions 2.0.15 and 2.1-beta3 has a SQL Injection vulnerability. The impact is high. Malicious users/attackers can execute arbitrary SQL queries negatively affecting the confidentiality, integrity, and availability of the site. Attackers can exfiltrate data like the users' and admini...
CVE-2020-7009
PUBLISHED: 2020-03-31
Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
CVE-2019-13495
PUBLISHED: 2020-03-31
In firmware version 4.50 of Zyxel XGS2210-52HP, multiple stored cross-site scripting (XSS) issues allows remote authenticated users to inject arbitrary web script via an rpSys.html Name or Location field.