Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

Adobe Patches Zero Day Vulnerabilities

Out-of-cycle updates fix bugs in Reader and Acrobat affecting Windows, Mac, and Unix.




Image Gallery: Top 12 Firefox Add-Ons
(click for larger image and for full photo gallery)
Adobe on Thursday released out-of-cycle security updates for a vulnerability in its Reader and Acrobat software.

"The vulnerability is critical and can be used to take control of the targeted computer and should be addressed as soon as possible," said Wolfgang Kandek, chief technology officer of Qualys, in a blog post.

According to the U.S. Computer Emergency Readiness Team (US-CERT), the vulnerability stems from an "integer overflow in CoolType.dll" in Reader and Acrobat, which could allow remote attackers "to execute arbitrary code via a TrueType font with a large maxCompositePoints value in a Maximum Profile (maxp) table."

Adobe Acrobat version 9 -- up to and including 9.3.3 -- for Windows and Macintosh is vulnerable. Adobe Reader 9, up to and including version 9.3.3, for Windows, Macintosh, and Unix, and Adobe Reader 8, up to and including version 8.2.3, for Windows and Macintosh are also affected.

The underlying vulnerability was first detailed by security researcher Charlie Miller last month at the Black Hat USA 2010 conference.

Interestingly, however, Adobe gives credit for discovering the vulnerability to Tavis Ormandy. "It seems that Tavis reported the vulnerability to Adobe before Charlie's Black Hat presentation. This is an example that illustrates an effect that security researchers have long tried to call attention to: it is possible and seems to happen every once in a while that vulnerabilities are discovered independently, both by security researchers and/or malware writers," said Qualys's Kandek.

To fix the security flaws, Adobe released Adobe Reader 9.3.4, Acrobat 9.3.4, and Acrobat 8.2.4. The updates also bundle a new version of Adobe Flash Player, released earlier this month, which addressed critical vulnerabilities in Flash. It also improves on another security update released in June.

Adobe's next regularly scheduled Adobe Reader and Acrobat quarterly security update will be October 12, 2010.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Commentary
Ransomware Is Not the Problem
Adam Shostack, Consultant, Entrepreneur, Technologist, Game Designer,  6/9/2021
Edge-DRsplash-11-edge-ask-the-experts
How Can I Test the Security of My Home-Office Employees' Routers?
John Bock, Senior Research Scientist,  6/7/2021
News
New Ransomware Group Claiming Connection to REvil Gang Surfaces
Jai Vijayan, Contributing Writer,  6/10/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win an Amazon Gift Card! Click Here
Latest Comment: Zero Trust doesn't have to break your budget!
Current Issue
The State of Cybersecurity Incident Response
In this report learn how enterprises are building their incident response teams and processes, how they research potential compromises, how they respond to new breaches, and what tools and processes they use to remediate problems and improve their cyber defenses for the future.
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-25414
PUBLISHED: 2021-06-17
A local file inclusion vulnerability was discovered in the captcha function in Monstra 3.0.4 which allows remote attackers to execute arbitrary PHP code.
CVE-2021-32078
PUBLISHED: 2021-06-17
An Out-of-Bounds Read was discovered in arch/arm/mach-footbridge/personal-pci.c in the Linux kernel through 5.12.11 because of the lack of a check for a value that shouldn't be negative, e.g., access to element -2 of an array, aka CID-298a58e165e4.
CVE-2021-31818
PUBLISHED: 2021-06-17
Affected versions of Octopus Server are prone to an authenticated SQL injection vulnerability in the Events REST API because user supplied data in the API request isn’t parameterised correctly. Exploiting this vulnerability could allow unauthorised access to database tables.
CVE-2021-34825
PUBLISHED: 2021-06-17
Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.
CVE-2021-32944
PUBLISHED: 2021-06-17
A use-after-free issue exists in the DGN file-reading procedure in the Drawings SDK (All versions prior to 2022.4) resulting from the lack of proper validation of user-supplied data. This can result in a memory corruption or arbitrary code execution, allowing attackers to cause a denial-of-service c...