Adobe Fixes 52 Vulnerabilities In Flash

Updated version fixes CVEs that allowed remote code execution on affected machines.



Software firm Adobe has launched an updated version of Flash Player patching 52 vulnerabilties -- one of the biggest security updates in Flash this year, Threatpost reports. The vulns were being exploited in targeted attacts that allowed control of a system. None of the exploits corrected are presently under attack in the wild, says Threatpost.

Of the CVEs patched, 33 of them resolve memory corruption weaknesses leading to code execution while 12 updates were use-after-free vulnerabilities that allowed machines to be exposed to code execution attacks. Other problems fixed include a race condition, type-confusion flaws, heap buffer overflow and security bypass vulnerabilities, memory leak weakness and stack corruption.

New versions of Acrobat and Reader were released after 30 patches and XMP Toolkit for Java was published after patching with recommendations to update to version 5.1.3.

For details, click here.

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio
 

Recommended Reading:

Comment  | 
Email This  | 
Print  | 
RSS
More Insights
Copyright © 2020 UBM Electronics, A UBM company, All rights reserved. Privacy Policy | Terms of Service