Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

6/29/2010
02:08 PM
Connect Directly
Twitter
RSS
E-Mail
50%
50%

Researchers Report Vulnerability In Microsoft Office 2010

European researchers say they've discovered a flaw in Excel 2010, and another possible bug in Word 2010

Researchers at VUPEN Security in France say they found one of the first vulnerabilities in Microsoft's new Office Excel 2010 application, but have not yet officially reported it to Microsoft.

Chaouki Bekrar, CEO and director of research at VUPEN, says the flaw is a heap corruption vulnerability that, if exploited, would let an attacker run arbitrary code on the victim's machine and take over the machine once the user opened a specially crafted Office document. "We are currently verifying if the vulnerability affects previous versions of Office. What we have seen so far is that the vulnerable code is only present in Office 2010," Bekrar says.

VUPEN also has found a separate, potential bug in Word 2010. "But the analysis of this potential flaw to determine its exploitability is still ongoing," he says.

Even so, Bekrar says Office 2010 is much more secure than previous versions of the software. "What we can say after this research session is that Office 2010 is definitely more secure than previous Office versions. The use of new features like Office File Validation or Protected View makes the discovery and exploitation of vulnerabilities harder, but we managed to reliably execute arbitrary code via a specially crafted document," he says.

Jerry Bryant, group manager for response communications at Microsoft, says Microsoft is "aware" of the vulnerability discovery claim, but doesn't have the details to verify it. "To minimize risk to computer users, Microsoft continues to encourage responsible disclosure," Bryant says. "Reporting vulnerabilities directly to vendors helps ensure that customers receive comprehensive, high-quality updates before cybercriminals learn of -- and work to exploit -- a vulnerability. While there are many ways to protect customers from attacks, the creators of the product are in the best position to understand the general risk to the broader customer base and create updates to the product or service that protect everyone.

"Vulnerability-sharing programs that do not include the software vendor are risky programs and do not promote overall customer safety," he says.

So why didn't VUPEN alert Microsoft about the bug in Office 2010? Berkrar says VUPEN alerted its VUPEN Threat Protection Program customers, and it's still determining whether the bug affects older versions of Office. "Discovering and researching this vulnerability was a long process and an important investment for VUPEN, so accepting just to get our names in the credit section of a Microsoft advisory as a compensation for this huge research work is not enough," Bekrar says.

But VUPEN says Microsoft will "be informed at a later date" about the bug, he says. A link to VUPEN's public disclosure is here.

Have a comment on this story? Please click "Discuss" below. If you'd like to contact Dark Reading's editors directly, send us a message.

Kelly Jackson Higgins is the Executive Editor of Dark Reading. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
News
Inside the Ransomware Campaigns Targeting Exchange Servers
Kelly Sheridan, Staff Editor, Dark Reading,  4/2/2021
Commentary
Beyond MITRE ATT&CK: The Case for a New Cyber Kill Chain
Rik Turner, Principal Analyst, Infrastructure Solutions, Omdia,  3/30/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-27235
PUBLISHED: 2021-04-13
An exploitable SQL injection vulnerability exists in ‘getAssets.jsp’ page of OpenClinic GA 5.173.3 in the description parameter. An attacker can make an authenticated HTTP request to trigger this vulnerability.
CVE-2020-27236
PUBLISHED: 2021-04-13
An exploitable SQL injection vulnerability exists in ‘getAssets.jsp’ page of OpenClinic GA 5.173.3 in the compnomenclature parameter. An attacker can make an authenticated HTTP request to trigger this vulnerability.
CVE-2020-13566
PUBLISHED: 2021-04-13
SQL injection vulnerabilities exist in phpGACL 3.3.7. A specially crafted HTTP request can lead to a SQL injection. An attacker can send an HTTP request to trigger this vulnerability In admin/edit_group.php, when the POST parameter action is “Delete�, the POST ...
CVE-2020-13568
PUBLISHED: 2021-04-13
SQL injection vulnerability exists in phpGACL 3.3.7. A specially crafted HTTP request can lead to a SQL injection. An attacker can send an HTTP request to trigger this vulnerability in admin/edit_group.php, when the POST parameter action is “Submit�, the POST p...
CVE-2020-27227
PUBLISHED: 2021-04-13
An exploitable unatuhenticated command injection exists in the OpenClinic GA 5.173.3. Specially crafted web requests can cause commands to be executed on the server. An attacker can send a web request with parameters containing specific parameter to trigger this vulnerability, potentially allowing e...