Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

12/2/2019
07:10 PM
Connect Directly
Twitter
LinkedIn
RSS
E-Mail
50%
50%

Kali Linux Gets New Desktop Environment & Undercover Theme

Updates to pen-testing platform are designed to improve performance and user interface, says Offensive Security, maintainer of the open source project.

Offensive Security, maintainer of the Kali Linux penetration-testing platform, has released a new version of the widely used open source project.

Key improvements in Kali Linux 2019.4 include a brand-new default desktop environment, a unified user interface, and an undercover feature that allows security researchers to use the pen-testing tool in a public setting without tipping their hand.

With the new release, Offensive Security has moved Kali Linux from Gnome to Xfce, a lightweight, open source desktop environment for Linux, BSD, and other Unix-like operating systems. The move is designed to improve performance and the user experience for pen-testers, according to Offensive Security.

Xfce, for instance, runs on all levels of Kali installs from high-end laptops to lower-end ARM-based systems. It also supports a unified user interface (UI) regardless of where the user is running Kali, whereas with Gnome some of Kali's lower-end ARM builds had a very different UI than on other platforms. Importantly, Xfce supports all the functionality the average Kali Linux user requires with none of the additional overhead associated with the Gnome desktop environment, according to Offensive Security.

"Gnome has been overkill for many Kali users, and we wanted to move to a desktop environment that does only what's needed," says Jim O'Gorman, chief content and strategy officer at Offensive Security.

Most Kali Linux users typically just want a web browser and a window manager that allows them to run multiple terminal windows at once. "By moving to Xfce, we're providing a lightweight, to-the-point experience, and a unified UI regardless of where you're running Kali." The switch allows for Kali Linux to be more responsive and use less system resources, O'Gorman says.

The Kali undercover feature meanwhile is designed to give Kali Linux users a way to remain inconspicuous when doing security assessments in public, he notes. "The classic Kali dragon is so iconic it's often a dead giveaway for what you are doing, even for people that don't work in this space," O'Gorman notes. The undercover theme is designed to appear like a Windows desktop to the casual viewer. The theme is unlikely to hold up to a detailed examination but is perfectly adequate for fooling a casual observer, he says.

Kali Linux has been downloaded millions of times for each release. But Offensive Security does not have any exact numbers on how many organizations, pen-testers, and security researchers around the world might be using it currently, O'Gorman says. "We see Kali being used in the workplace, with 'live-build,' allowing for people to generate their own image of Kali, with their settings and programs preapplied," he notes.

Kali Linux penetration testing tools come in a variety of forms including those that can be used for information gathering, vulnerability analysis, wireless attacks, and vulnerability exploitation. Well-known and widely used Kali Linux tools include Nmap, Burp Suite, and the Metasploit Framework.

Offensive Security is currently going through every aspect of the Kali Linux project to see how it can be improved and what might need to be jettisoned. The analysis has already prompted changes in how Kali's Git repository is managed, how the software is mirrored and distributed, the way new releases are packaged, what tools get packaged with each Kali release, and other aspects.

"With the 2019.4 release in the rearview mirror, we will soon begin looking at our online services, such as support forums, bug tracker, real time chat, and so on," O'Gorman says.

Check out The Edge, Dark Reading's new section for features, threat data, and in-depth perspectives. Today's top story: "A Cause You Care About Needs Your Cybersecurity Help."

Jai Vijayan is a seasoned technology reporter with over 20 years of experience in IT trade journalism. He was most recently a Senior Editor at Computerworld, where he covered information security and data privacy issues for the publication. Over the course of his 20-year ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
Navigating Security in the Cloud
Diya Jolly, Chief Product Officer, Okta,  12/4/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Navigating the Deluge of Security Data
In this Tech Digest, Dark Reading shares the experiences of some top security practitioners as they navigate volumes of security data. We examine some examples of how enterprises can cull this data to find the clues they need.
Flash Poll
Rethinking Enterprise Data Defense
Rethinking Enterprise Data Defense
Frustrated with recurring intrusions and breaches, cybersecurity professionals are questioning some of the industrys conventional wisdom. Heres a look at what theyre thinking about.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-19642
PUBLISHED: 2019-12-08
On SuperMicro X8STi-F motherboards with IPMI firmware 2.06 and BIOS 02.68, the Virtual Media feature allows OS Command Injection by authenticated attackers who can send HTTP requests to the IPMI IP address. This requires a POST to /rpc/setvmdrive.asp with shell metacharacters in ShareHost or ShareNa...
CVE-2019-19637
PUBLISHED: 2019-12-08
An issue was discovered in libsixel 1.8.2. There is an integer overflow in the function sixel_decode_raw_impl at fromsixel.c.
CVE-2019-19638
PUBLISHED: 2019-12-08
An issue was discovered in libsixel 1.8.2. There is a heap-based buffer overflow in the function load_pnm at frompnm.c, due to an integer overflow.
CVE-2019-19635
PUBLISHED: 2019-12-08
An issue was discovered in libsixel 1.8.2. There is a heap-based buffer overflow in the function sixel_decode_raw_impl at fromsixel.c.
CVE-2019-19636
PUBLISHED: 2019-12-08
An issue was discovered in libsixel 1.8.2. There is an integer overflow in the function sixel_encode_body at tosixel.c.