Vulnerabilities / Threats

3/22/2016
12:00 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

Here Are 4 Vulnerabilities Ransomware Attacks Are Exploiting Now

A zero-day exploit exposed in the Hacking Team breach is among the top weapons deployed in recent ransomware attacks, as well as lots of Flash.

Don’t blink, but there’s a common thread in the most recent ransomware attacks: they use four known Adobe Flash Player and Microsoft Silverlight software bugs that have patches available, according to new research published today.

So if you haven’t already patched recently revealed Flash flaws CVE-2015-7645, CVE-2015-8446, CVE-2015-8651, and Microsoft Silverlight’s CVE-2016-0034, you’ll “significantly” minimize your risk of getting hit by the latest in ransomware threats if you apply these updates, according to Recorded Future, which analyzed which vulns were being exploited most in ransomware attacks as of March 16.

Scott Donnelly, a director at Recorded Future, says he launched the study after talking with a friend at a local Blue Cross/Blue Shield location about worries of the potential threat of a ransomware attack. The organization relies on a vendor for its software-patching, so that made Donnelly wonder which vulnerabilities are being used most by popular exploit kits in ransomware attacks.

“There are multiple ways to get hit by ransomware. We looked at some of the recent vulnerabilities with exploits ... for patch prioritization” planning, Donnelly says.

Recorded Future says its analysis suggests that recent highly publicized attacks on hospitals and police departments in North American and Europe were most likely not targeted attacks: instead, the bad guys had cast a wide net and those poorly patched systems landed right in it.

“We’re now at the point where you can get crippled in same way as with targeted attack [as you can] by an untargeted one,” Donnelly says. “A hospital worker using an EMR [electronic medical record]... Googles a patient’s condition and gets ransomware,” for example.

The Angler, Neutrino, Magnitude, RIG, and Nuclear exploit kits spread the Flash CVE 2015-7645 exploit; Angler spreads Flash 2015-8446; Angler and Neutrino spread Flash CVE 2015-8651; and Angler spreads Silverlight CVE-2016-0034, an exploit exposed in the Hacking Team breach.

In addition to patching these four vulns, Recorded Future offers additional recommendations for thwarting ransomware attacks: set Flash to “click to play;” run browser ad-blockers to protect against malvertising-borne attacks; and perform regular backups, especially of shared files, which are often the target of ransomware attacks.

“If you don’t make the decision to keep backups offline when you’re hit, you have a binary decision: either pay the ransom or lose the data,” says Levi Gundert, director of intelligence strategies at Recorded Future.

Meanwhile, ransomware victim counts are likely more widespread than is publicly known. “So many companies don’t publicize that they’ve been hit” by ransomware, Donnelly says.

Related Content:

Interop 2016 Las VegasFind out more about ransomware at Interop 2016, May 2-6, at the Mandalay Bay Convention Center, Las Vegas. Register today and receive an early bird discount of $200.

Kelly Jackson Higgins is Executive Editor at DarkReading.com. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
komeara26
50%
50%
komeara26,
User Rank: Apprentice
3/24/2016 | 9:19:34 PM
Exploit Kits and CVE-2015-8651
Just a litle information to add....CVE-2015-8651 has also been packaged in Nuclear Pack Exploit Kit and Magnitude Exploit Kit.
Joe Stanganelli
50%
50%
Joe Stanganelli,
User Rank: Ninja
3/24/2016 | 7:58:17 PM
Re: Down with Flash
"It also requires Java."

Wow.  Double-whammy.  :/

Java has been found to have more vulnerabilities than Flash, actually -- but, on the whole, they lack the severity of Flash vulnerabilities.
DarwinC123
50%
50%
DarwinC123,
User Rank: Strategist
3/24/2016 | 12:31:18 PM
Re: Down with Flash
I totally agree with your post. I presently have flash since it is required with the kronos timekeeping workforce application. It also requires Java. ; (
Joe Stanganelli
100%
0%
Joe Stanganelli,
User Rank: Ninja
3/23/2016 | 12:01:51 PM
Down with Flash
InfoSec professionals agree, and its time industry acted.  Flash should be gone.  It should be banned.  It should be expunged.  (For goodness sakes, we have HTML5 now!)  There is no excuse anymore.

(Or, as The Register once put it: Flash apologists are "the antivaxxers of the Internet".)
WSJ Report: Facebook Breach the Work of Spammers, Not Nation-State Actors
Curtis Franklin Jr., Senior Editor at Dark Reading,  10/19/2018
6 Security Trends for 2018/2019
Curtis Franklin Jr., Senior Editor at Dark Reading,  10/15/2018
6 Reasons Why Employees Violate Security Policies
Ericka Chickowski, Contributing Writer, Dark Reading,  10/16/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Flash Poll
The Risk Management Struggle
The Risk Management Struggle
The majority of organizations are struggling to implement a risk-based approach to security even though risk reduction has become the primary metric for measuring the effectiveness of enterprise security strategies. Read the report and get more details today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-10839
PUBLISHED: 2018-10-16
Qemu emulator <= 3.0.0 built with the NE2000 NIC emulation support is vulnerable to an integer overflow, which could lead to buffer overflow issue. It could occur when receiving packets over the network. A user inside guest could use this flaw to crash the Qemu process resulting in DoS.
CVE-2018-13399
PUBLISHED: 2018-10-16
The Microsoft Windows Installer for Atlassian Fisheye and Crucible before version 4.6.1 allows local attackers to escalate privileges because of weak permissions on the installation directory.
CVE-2018-18381
PUBLISHED: 2018-10-16
Z-BlogPHP 1.5.2.1935 (Zero) has a stored XSS Vulnerability in zb_system/function/c_system_admin.php via the Content-Type header during the uploading of image attachments.
CVE-2018-18382
PUBLISHED: 2018-10-16
Advanced HRM 1.6 allows Remote Code Execution via PHP code in a .php file to the user/update-user-avatar URI, which can be accessed through an "Update Profile" "Change Picture" (aka user/edit-profile) action.
CVE-2018-18374
PUBLISHED: 2018-10-16
XSS exists in the MetInfo 6.1.2 admin/index.php page via the anyid parameter.