Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Vulnerabilities / Threats

Flaws Reported in Bank of America System

Sestus, rival to vendor of Bank of America's SiteKey authentication system, reports vulnerabilities in the Sitekey technology

The authentication technology used by Sitekey, Bank of America's online customer service system, is flawed and could make the bank vulnerable to denial-of-service attacks, a vendor said yesterday in a report that was disputed by both the bank and its primary contractor.

The two-factor authentication system offered by Bank of America, which allows a user to select a separate image file to help verify his/her identity, was developed by Passmark, an authentication tool vendor now owned by RSA Security.

But in a bit of vendor gamesmanship, the vulnerability report was issued by Sestus, a Passmark rival that also makes multi-factor authentication technology. Sestus, maker of PhishCops, has been critical of the Passmark technology in the past, publishing other documents that put Sitekey in a negative light.

In this case, however, Sestus reported the discovery of a "previously unreported vulnerability" in the Bank of America system that would enable an attacker to exploit the bank's lockout process to launch a denial-of-service attack on Sitekey, effectively preventing customers from accessing their accounts online.

"It appears that this lockout process can be exploited by malicious hackers to remotely lock out customers from their accounts en masse, or used by fraudsters in a hybrid lockout/phishing attack to access the actual account," the report said. The researchers did not publish a proof of concept with the vulnerability report.

In a series of three different scenarios, Sestus described how an attacker might use scripts and commonly-used login words to guess Bank of America customer login information, then type invalid information when the system requests the second authentication factor. Such an exploit would effectively lock users out of their accounts and tie up Bank of America systems, the vendor said. Attackers might also create a look-alike "error" page to phish personal information away from frustrated users, according to the report.

The vulnerability is not unique to Sitekey, but it could be exploited in any system that requests personal information before verifying the authenticity of the Web page, Sestus observed.

According to a Bank of America spokeswoman, the vulnerability doesn't threaten the safety of users' data. "It's not an issue that poses a risk to customers' information," she says. However, the vulnerability could lock out users if a hacker launched a denial-of-service attack, she says, and "anything that would be an inconvenience to our customers would be a concern for us."

Louie Gasparini, CTO of the RSA unit that now owns the Passmark technology, put a finer point on his response. "There's no vulnerability here that hasn't been in online banking systems for the past 10 years," he says. "This is the way the [banking authentication] system has always worked, and it's not unique to Sitekey or Passmark."

— Tim Wilson, Site Editor, Dark Reading

  • RSA Security Inc. (Nasdaq: EMC)
  • Sestus Data Corp.

    Tim Wilson is Editor in Chief and co-founder of Dark Reading.com, UBM Tech's online community for information security professionals. He is responsible for managing the site, assigning and editing content, and writing breaking news stories. Wilson has been recognized as one ... View Full Bio

    Comment  | 
    Print  | 
    More Insights
  • Comments
    Newest First  |  Oldest First  |  Threaded View
    News
    FluBot Malware's Rapid Spread May Soon Hit US Phones
    Kelly Sheridan, Staff Editor, Dark Reading,  4/28/2021
    Slideshows
    7 Modern-Day Cybersecurity Realities
    Steve Zurier, Contributing Writer,  4/30/2021
    Commentary
    How to Secure Employees' Home Wi-Fi Networks
    Bert Kashyap, CEO and Co-Founder at SecureW2,  4/28/2021
    Register for Dark Reading Newsletters
    White Papers
    Video
    Cartoon Contest
    Current Issue
    2021 Top Enterprise IT Trends
    We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
    Flash Poll
    How Enterprises are Developing Secure Applications
    How Enterprises are Developing Secure Applications
    Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
    Twitter Feed
    Dark Reading - Bug Report
    Bug Report
    Enterprise Vulnerabilities
    From DHS/US-CERT's National Vulnerability Database
    CVE-2021-31755
    PUBLISHED: 2021-05-07
    An issue was discovered on Tenda AC11 devices with firmware through 02.03.01.104_CN. A stack buffer overflow vulnerability in /goform/setmac allows attackers to execute arbitrary code on the system via a crafted post request.
    CVE-2021-31756
    PUBLISHED: 2021-05-07
    An issue was discovered on Tenda AC11 devices with firmware through 02.03.01.104_CN. A stack buffer overflow vulnerability in /gofrom/setwanType allows attackers to execute arbitrary code on the system via a crafted post request. This occurs when input vector controlled by malicious attack get copie...
    CVE-2021-31757
    PUBLISHED: 2021-05-07
    An issue was discovered on Tenda AC11 devices with firmware through 02.03.01.104_CN. A stack buffer overflow vulnerability in /goform/setVLAN allows attackers to execute arbitrary code on the system via a crafted post request.
    CVE-2021-31758
    PUBLISHED: 2021-05-07
    An issue was discovered on Tenda AC11 devices with firmware through 02.03.01.104_CN. A stack buffer overflow vulnerability in /goform/setportList allows attackers to execute arbitrary code on the system via a crafted post request.
    CVE-2021-31458
    PUBLISHED: 2021-05-07
    This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit Reader 10.1.1.37576. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handlin...