Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

2/14/2007
06:05 PM
Sharon Gaudin
Sharon Gaudin
Commentary
50%
50%

Visual C++ Flaw Leads To Y3K -- Seriously

Think the software industry learned its lesson with the whole Y2K debacle? Of course not. The Department of Homeland Security issued a warning this week that there's a flaw in Microsoft's Visual C++ programming environment that could actually cause programs written with it to crash when we pass the Year 3000. Of course, unless today's programs are around in another 993 years, it won't be a drastic issue.

Think the software industry learned its lesson with the whole Y2K debacle? Of course not.

The Department of Homeland Security issued a warning this week that there's a flaw in Microsoft's Visual C++ programming environment that could actually cause programs written with it to crash when we pass the Year 3000. Of course, unless today's programs are around in another 993 years, it won't be a drastic issue.But the point is… Have we not already learned that lesson?

"I almost had a déjà-vu moment when I read: CVE-2007-0842," writes Swa Frantzen on the SANS Institute's Internet Storm Center Web site. He's referring to the code name the government gave the flaw. "Some time handling functions in Visual C++ 8.0 can't go beyond Jan 1st 3000. Didn't the industry learn almost a decade ago that dates move on and building any arbitrary limit is a bad idea?"

No, Frantzen, seems they didn't.

The National Vulnerability Database, which is under the umbrella of the Department of Homeland Security, notes that the problem lies in the 64-bit versions of Microsoft's Visual C++ 8.0 standard library.

Johannes Ullrich, chief research officer at the SANS Institute, agrees. I talked with Ullrich Wednesday afternoon and he told me the library inside the compiler for Visual C++ basically doesn't know how to count past 3,000. "Any higher and the system will crash," he says. "Any program written with that compiler will crash beyond the Year 3000."

Ullrich, who also is chief technology officer for the Internet Storm Center, a cooperative cyberthreat monitoring and alert system, laughed and says he was "surprised" by it but mistakes happen.

After all the hubbub around the Y2K issue, not to mention all the money thrown at it, this flaw just made me laugh. At least we'll have plenty of time to get it fixed….

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
6 Emerging Cyber Threats That Enterprises Face in 2020
This Tech Digest gives an in-depth look at six emerging cyber threats that enterprises could face in 2020. Download your copy today!
Flash Poll
State of Cybersecurity Incident Response
State of Cybersecurity Incident Response
Data breaches and regulations have forced organizations to pay closer attention to the security incident response function. However, security leaders may be overestimating their ability to detect and respond to security incidents. Read this report to find out more.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-11498
PUBLISHED: 2020-04-02
Slack Nebula through 1.1.0 contains a relative path vulnerability that allows a low-privileged attacker to execute code in the context of the root user via tun_darwin.go or tun_windows.go. A user can also use Nebula to execute arbitrary code in the user's own context, e.g., for user-level persistenc...
CVE-2020-11499
PUBLISHED: 2020-04-02
Firmware Analysis and Comparison Tool (FACT) 3 has Stored XSS when updating analysis details via a localhost web request, as demonstrated by mishandling of the tags and version fields in helperFunctions/mongo_task_conversion.py.
CVE-2020-7628
PUBLISHED: 2020-04-02
install-package through 1.1.6 is vulnerable to Command Injection. It allows execution of arbitrary commands via the device function.
CVE-2020-7629
PUBLISHED: 2020-04-02
install-package through 0.4.0 is vulnerable to Command Injection. It allows execution of arbitrary commands via the options argument.
CVE-2020-7630
PUBLISHED: 2020-04-02
git-add-remote through 1.0.0 is vulnerable to Command Injection. It allows execution of arbitrary commands via the name argument.