Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

11/4/2008
01:25 PM
George V. Hulme
George V. Hulme
Commentary
50%
50%

Adobe Patches PDF Flaw

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.Fortunately, the flaw doesn't affect Adobe Reader version 9, which was released in June 2008.

Core Security, which found the vulnerability, described it this way in a statement it issued this morning:

Engineers from CoreLabs, the research arm of Core Security, determined that Adobe Reader could be exploited to gain access to vulnerable systems via the use of a specially crafted PDF file with malicious JavaScript content.

Core Securities explained that the flaw existed because of the way vulnerable versions of Adobe Reader implement the JavaScript util.printf() function. It seems that function converts the input it gets into a String, but only the first 16 digits of the input is used, and the rest is filled with "0" as filler. Unfortunately, if an unexpectedly long value is fed to the function (and it's crafted the right way) memory will be overwritten and the attacker can gain control of the application's execution. This is a normal buffer overflow.

Developers need to do a better job checking how applications handle inputs, and these types of problems can be avoided.

All of that is the bad news. The good news is that Core Security worked with Adobe and didn't announce the existence of this flaw until it was fixed.

Your options are to update your current version of Adobe Reader 8.1.2 or earlier, or disable JavaScript in that applications Edit/Preferences menu.

Core Security has published an advisory that probably gives you more information about the flaw than you'll need to know.

 

Recommended Reading:

Comment  | 
Print  | 
More Insights
Comments
Oldest First  |  Newest First  |  Threaded View
COVID-19: Latest Security News & Commentary
Dark Reading Staff 8/3/2020
'BootHole' Vulnerability Exposes Secure Boot Devices to Attack
Kelly Sheridan, Staff Editor, Dark Reading,  7/29/2020
Average Cost of a Data Breach: $3.86 Million
Jai Vijayan, Contributing Writer,  7/29/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Special Report: Computing's New Normal, a Dark Reading Perspective
This special report examines how IT security organizations have adapted to the "new normal" of computing and what the long-term effects will be. Read it and get a unique set of perspectives on issues ranging from new threats & vulnerabilities as a result of remote working to how enterprise security strategy will be affected long term.
Flash Poll
The Threat from the Internetand What Your Organization Can Do About It
The Threat from the Internetand What Your Organization Can Do About It
This report describes some of the latest attacks and threats emanating from the Internet, as well as advice and tips on how your organization can mitigate those threats before they affect your business. Download it today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-15109
PUBLISHED: 2020-08-04
In solidus before versions 2.8.6, 2.9.6, and 2.10.2, there is an bility to change order address without triggering address validations. This vulnerability allows a malicious customer to craft request data with parameters that allow changing the address of the current order without changing the ship...
CVE-2020-16847
PUBLISHED: 2020-08-04
Extreme Analytics in Extreme Management Center before 8.5.0.169 allows unauthenticated reflected XSS via a parameter in a GET request, aka CFD-4887.
CVE-2020-15135
PUBLISHED: 2020-08-04
save-server (npm package) before version 1.05 is affected by a CSRF vulnerability, as there is no CSRF mitigation (Tokens etc.). The fix introduced in version version 1.05 unintentionally breaks uploading so version v1.0.7 is the fixed version. This is patched by implementing Double submit. The CSRF...
CVE-2020-13522
PUBLISHED: 2020-08-04
An exploitable arbitrary file delete vulnerability exists in SoftPerfect RAM Disk 4.1 spvve.sys driver. A specially crafted I/O request packet (IRP) can allow an unprivileged user to delete any file on the filesystem. An attacker can send a malicious IRP to trigger this vulnerability.
CVE-2020-15943
PUBLISHED: 2020-08-04
An issue was discovered in the Gantt-Chart module before 5.5.4 for Jira. Due to a missing privilege check, it is possible to read and write to the module configuration of other users. This can also be used to deliver an XSS payload to other users' dashboards. To exploit this vulnerability, an attack...