Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

11/4/2008
01:25 PM
George V. Hulme
George V. Hulme
Commentary
50%
50%

Adobe Patches PDF Flaw

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.Fortunately, the flaw doesn't affect Adobe Reader version 9, which was released in June 2008.

Core Security, which found the vulnerability, described it this way in a statement it issued this morning:

Engineers from CoreLabs, the research arm of Core Security, determined that Adobe Reader could be exploited to gain access to vulnerable systems via the use of a specially crafted PDF file with malicious JavaScript content.

Core Securities explained that the flaw existed because of the way vulnerable versions of Adobe Reader implement the JavaScript util.printf() function. It seems that function converts the input it gets into a String, but only the first 16 digits of the input is used, and the rest is filled with "0" as filler. Unfortunately, if an unexpectedly long value is fed to the function (and it's crafted the right way) memory will be overwritten and the attacker can gain control of the application's execution. This is a normal buffer overflow.

Developers need to do a better job checking how applications handle inputs, and these types of problems can be avoided.

All of that is the bad news. The good news is that Core Security worked with Adobe and didn't announce the existence of this flaw until it was fixed.

Your options are to update your current version of Adobe Reader 8.1.2 or earlier, or disable JavaScript in that applications Edit/Preferences menu.

Core Security has published an advisory that probably gives you more information about the flaw than you'll need to know.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
COVID-19: Latest Security News & Commentary
Dark Reading Staff 9/25/2020
Hacking Yourself: Marie Moe and Pacemaker Security
Gary McGraw Ph.D., Co-founder Berryville Institute of Machine Learning,  9/21/2020
Startup Aims to Map and Track All the IT and Security Things
Kelly Jackson Higgins, Executive Editor at Dark Reading,  9/22/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Special Report: Computing's New Normal
This special report examines how IT security organizations have adapted to the "new normal" of computing and what the long-term effects will be. Read it and get a unique set of perspectives on issues ranging from new threats & vulnerabilities as a result of remote working to how enterprise security strategy will be affected long term.
Flash Poll
How IT Security Organizations are Attacking the Cybersecurity Problem
How IT Security Organizations are Attacking the Cybersecurity Problem
The COVID-19 pandemic turned the world -- and enterprise computing -- on end. Here's a look at how cybersecurity teams are retrenching their defense strategies, rebuilding their teams, and selecting new technologies to stop the oncoming rise of online attacks.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-15208
PUBLISHED: 2020-09-25
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, when determining the common dimension size of two tensors, TFLite uses a `DCHECK` which is no-op outside of debug compilation modes. Since the function always returns the dimension of the first tensor, malicious attackers can ...
CVE-2020-15209
PUBLISHED: 2020-09-25
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, a crafted TFLite model can force a node to have as input a tensor backed by a `nullptr` buffer. This can be achieved by changing a buffer index in the flatbuffer serialization to convert a read-only tensor to a read-write one....
CVE-2020-15210
PUBLISHED: 2020-09-25
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and ...
CVE-2020-15211
PUBLISHED: 2020-09-25
In TensorFlow Lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, saved models in the flatbuffer format use a double indexing scheme: a model has a set of subgraphs, each subgraph has a set of operators and each operator has a set of input/output tensors. The flatbuffer format uses indices f...
CVE-2020-15212
PUBLISHED: 2020-09-25
In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger writes outside of bounds of heap allocated buffers by inserting negative elements in the segment ids tensor. Users having access to `segment_ids_data` can alter `output_index` and then write to outside of `outpu...