Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Risk

11/4/2008
01:25 PM
George V. Hulme
George V. Hulme
Commentary
50%
50%

Adobe Patches PDF Flaw

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.

Security firm Core Security Technologies is warning users that Adobe Reader versions 8.1.2 and earlier are vulnerable to specially crafted PDF files that could be used gain access to authorized systems. You might want to check which version of Adobe Reader you're using.Fortunately, the flaw doesn't affect Adobe Reader version 9, which was released in June 2008.

Core Security, which found the vulnerability, described it this way in a statement it issued this morning:

Engineers from CoreLabs, the research arm of Core Security, determined that Adobe Reader could be exploited to gain access to vulnerable systems via the use of a specially crafted PDF file with malicious JavaScript content.

Core Securities explained that the flaw existed because of the way vulnerable versions of Adobe Reader implement the JavaScript util.printf() function. It seems that function converts the input it gets into a String, but only the first 16 digits of the input is used, and the rest is filled with "0" as filler. Unfortunately, if an unexpectedly long value is fed to the function (and it's crafted the right way) memory will be overwritten and the attacker can gain control of the application's execution. This is a normal buffer overflow.

Developers need to do a better job checking how applications handle inputs, and these types of problems can be avoided.

All of that is the bad news. The good news is that Core Security worked with Adobe and didn't announce the existence of this flaw until it was fixed.

Your options are to update your current version of Adobe Reader 8.1.2 or earlier, or disable JavaScript in that applications Edit/Preferences menu.

Core Security has published an advisory that probably gives you more information about the flaw than you'll need to know.

 

Recommended Reading:

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
COVID-19: Latest Security News & Commentary
Dark Reading Staff 7/2/2020
Ripple20 Threatens Increasingly Connected Medical Devices
Kelly Sheridan, Staff Editor, Dark Reading,  6/30/2020
DDoS Attacks Jump 542% from Q4 2019 to Q1 2020
Dark Reading Staff 6/30/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
How Cybersecurity Incident Response Programs Work (and Why Some Don't)
This Tech Digest takes a look at the vital role cybersecurity incident response (IR) plays in managing cyber-risk within organizations. Download the Tech Digest today to find out how well-planned IR programs can detect intrusions, contain breaches, and help an organization restore normal operations.
Flash Poll
The Threat from the Internetand What Your Organization Can Do About It
The Threat from the Internetand What Your Organization Can Do About It
This report describes some of the latest attacks and threats emanating from the Internet, as well as advice and tips on how your organization can mitigate those threats before they affect your business. Download it today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-9498
PUBLISHED: 2020-07-02
Apache Guacamole 1.1.0 and older may mishandle pointers involved inprocessing data received via RDP static virtual channels. If a userconnects to a malicious or compromised RDP server, a series ofspecially-crafted PDUs could result in memory corruption, possiblyallowing arbitrary code to be executed...
CVE-2020-3282
PUBLISHED: 2020-07-02
A vulnerability in the web-based management interface of Cisco Unified Communications Manager, Cisco Unified Communications Manager Session Management Edition, Cisco Unified Communications Manager IM & Presence Service, and Cisco Unity Connection could allow an unauthenticated, remote attack...
CVE-2020-5909
PUBLISHED: 2020-07-02
In versions 3.0.0-3.5.0, 2.0.0-2.9.0, and 1.0.1, when users run the command displayed in NGINX Controller user interface (UI) to fetch the agent installer, the server TLS certificate is not verified.
CVE-2020-5910
PUBLISHED: 2020-07-02
In versions 3.0.0-3.5.0, 2.0.0-2.9.0, and 1.0.1, the Neural Autonomic Transport System (NATS) messaging services in use by the NGINX Controller do not require any form of authentication, so any successful connection would be authorized.
CVE-2020-5911
PUBLISHED: 2020-07-02
In versions 3.0.0-3.5.0, 2.0.0-2.9.0, and 1.0.1, the NGINX Controller installer starts the download of Kubernetes packages from an HTTP URL On Debian/Ubuntu system.