Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Comments
What Meltdown and Spectre Mean for Mobile Device Security
Newest First  |  Oldest First  |  Threaded View
BradleyRoss
50%
50%
BradleyRoss,
User Rank: Moderator
5/4/2018 | 7:16:16 PM
New techniques are required
A number of people assume that virtual machines can't extract unauthorized data from other virtual machines on the server.  In the same way, they assume that virtual memory will stop one application from accessing the memory belonging to another application.  Spectre and Meltdown, together with problems with the Atom Tables for Microsoft Windows, are indications that these assumptions are no longer safe.  We need to either isolate applictions on systems completely with one application per computer system, or provide better protection between processing in a multi-processing environment.

A number of compilers can reduce the level of optimization by changing options.  Perhaps what we need are means to turn off optimization techniques such as look ahead pre-calculation on a per process basis to increase security.  As long as the reduced optimization is limited to processes that run less that five percent of the total cycles, the impact on performance may be minimal.
JTKeating
50%
50%
JTKeating,
User Rank: Author
5/1/2018 | 11:56:44 AM
Re: "Matter of whether companies update their employees' devices"
I completely agree, Ryan.  As I mentioned in the post, the lack of a patch management system for mobile forces us to tackle the problem a different way. As you mentioned, using policies (including deciding what users can and cannot access based on the OS level / risk of their device) is one way to drive users to the desired behavior. We have seen the difference. Some of our customers that don't enforce based on OS level have some users on version that are so old it is scary. For example, I have seen users on iOS 5... iOS is currently on 11.x! Thanks for the thoughts!
RyanSepe
100%
0%
RyanSepe,
User Rank: Ninja
4/30/2018 | 10:59:53 PM
For those that offer mobile options
For those that offer mobile devices to their users, ensure that corporate policy dictates strict oversight of the device. This couple with an Enterprise Device Management system can be a saving grace in ubiquitous exposures such as this.
RyanSepe
100%
0%
RyanSepe,
User Rank: Ninja
4/30/2018 | 10:57:29 PM
"Matter of whether companies update their employees' devices"
This point sticks out in my mind. The patches are available and the manufacturers can only make the suggestion but its the responsibility of the company to enforce compliance. Otherwise end users will non-functionality based updates like the plague.


Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
6 Emerging Cyber Threats That Enterprises Face in 2020
This Tech Digest gives an in-depth look at six emerging cyber threats that enterprises could face in 2020. Download your copy today!
Flash Poll
State of Cybersecurity Incident Response
State of Cybersecurity Incident Response
Data breaches and regulations have forced organizations to pay closer attention to the security incident response function. However, security leaders may be overestimating their ability to detect and respond to security incidents. Read this report to find out more.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-10696
PUBLISHED: 2020-03-31
A path traversal flaw was found in Buildah in versions before 1.14.5. This flaw allows an attacker to trick a user into building a malicious container image hosted on an HTTP(s) server and then write files to the user's system anywhere that the user has permissions.
CVE-2020-5344
PUBLISHED: 2020-03-31
Dell EMC iDRAC7, iDRAC8 and iDRAC9 versions prior to 2.65.65.65, 2.70.70.70, 4.00.00.00 contain a stack-based buffer overflow vulnerability. An unauthenticated remote attacker may exploit this vulnerability to crash the affected process or execute arbitrary code on the system by sending specially cr...
CVE-2020-5292
PUBLISHED: 2020-03-31
Leantime before versions 2.0.15 and 2.1-beta3 has a SQL Injection vulnerability. The impact is high. Malicious users/attackers can execute arbitrary SQL queries negatively affecting the confidentiality, integrity, and availability of the site. Attackers can exfiltrate data like the users' and admini...
CVE-2020-7009
PUBLISHED: 2020-03-31
Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
CVE-2019-13495
PUBLISHED: 2020-03-31
In firmware version 4.50 of Zyxel XGS2210-52HP, multiple stored cross-site scripting (XSS) issues allows remote authenticated users to inject arbitrary web script via an rpSys.html Name or Location field.