Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Comments
Drupal: Attacks Started Within Hours Of Patch Release
Newest First  |  Oldest First  |  Threaded View
RetiredUser
50%
50%
RetiredUser,
User Rank: Ninja
11/3/2014 | 2:19:08 PM
No Surprises Here - Time to Change the Game
The cyber criminal toolkts are getting more flexible and advanced, as are the scripting skills in languages like Python, thus making the jump from published exploit to application of it much faster.  As quickly as the vulnerability is released and the site compromised, it is pushed to anonymous sales boards and admin/root accounts are sold/resold.  The surprises here are actually that 1) more ownership for secure coding/testing/end-user fixes isn't applied to projects like Drupal and other CMS, let alone FOSS (free and open source software) in general, and 2) that the international community isn't applying more pressure to cyber criminals by thoroughly destroying the infrastructure that allows such blackmarket shops to easily pop up and profit from these crimes.

Go to Packet Storm Security and drop in Drupal or WordPress.  Every exploit database out there is full of examples of the myriad ways in which vulnerabilities in LAMP (Linux Apache MySQL PHP) and variations on that platform can be exploited.  Proprietary software isn't necessarily more secure, but what makes code more secure is accountability.  Here I go again with an incredibly unpopular viewpoint, but if the Internet was better regulated, there would be standards and audits applied to code released to the Internet that could help (not solve) maintain a more secure code base for applications that can cause serious damage when compromised.  These activities are threats to our National security, make no mistake, and the buyers in these underground markets could have more in mind than simply obtaining a springboard to tag other sites, or steal a few hundred dollars in digital goods. 

This is just another vulnerability, but a good example of how cyber criminals are improving their "time to blackmarket" with our stolen digital goods.  The question is, whose buying these goods and how long before their intentions move from theft to acts of terror?   
Robert McDougal
50%
50%
Robert McDougal,
User Rank: Ninja
10/31/2014 | 5:38:01 PM
That was fast....
I find it amazing the speed at which criminals can operate today, truly astounding.  Did Drupal release any information to customers so they can detect backdoors on their systems?


Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
How Enterprises Are Assessing Cybersecurity Risk in Today's Environment
The adoption of cloud services spurred by the COVID-19 pandemic has resulted in pressure on cyber-risk professionals to focus on vulnerabilities and new exposures that stem from pandemic-driven changes. Many cybersecurity pros expect fundamental, long-term changes to their organization's computing and data security due to the shift to more remote work and accelerated cloud adoption. Download this report from Dark Reading to learn more about their challenges and concerns.
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-4034
PUBLISHED: 2022-01-28
A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count c...
CVE-2021-40416
PUBLISHED: 2022-01-28
An incorrect default permission vulnerability exists in the cgiserver.cgi cgi_check_ability functionality of reolink RLC-410W v3.0.0.136_20121102. All the Get APIs that are not included in cgi_check_ability are already executable by any logged-in users. An attacker can send an HTTP request to trigge...
CVE-2021-40419
PUBLISHED: 2022-01-28
A firmware update vulnerability exists in the 'factory' binary of reolink RLC-410W v3.0.0.136_20121102. A specially-crafted series of network requests can lead to arbitrary firmware update. An attacker can send a sequence of requests to trigger this vulnerability.
CVE-2021-40423
PUBLISHED: 2022-01-28
A denial of service vulnerability exists in the cgiserver.cgi API command parser functionality of Reolink RLC-410W v3.0.0.136_20121102. A specially-crafted series of HTTP requests can lead to denial of service. An attacker can send an HTTP request to trigger this vulnerability.
CVE-2021-44463
PUBLISHED: 2022-01-28
Missing DLLs, if replaced by an insider, could allow an attacker to achieve local privilege escalation on the DeltaV Distributed Control System Controllers and Workstations (All versions) when some DeltaV services are started.