Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Comments
'POODLE' Attacks, Kills Off SSL 3.0
Newest First  |  Oldest First  |  Threaded View
GonzSTL
GonzSTL,
User Rank: Ninja
10/20/2014 | 11:22:56 AM
Re: protocols too old
What really gets me is that TLS was designed to replace SSL, and was introduced last century (I know that sounds really dramatic), and we still have systems that have not deprecated that protocol. I realize that systems security updates/upgrades may consume a great deal of internal resources, but in today's threat landscape, can we really afford not to do that? Have we not arrived at a point where systems operators must be nimble enough so that they can respond to security issues such as an insecure protocol in a timely fashion, before havoc breaks out? Timely is the keyword. SSL 3.0 was released in 1996; TLS 1.0 was defined in January 1999, TLS 1.1 In April 2006, and TLS 1.2 in August 2008. Here we are in 2014, still talking about deprecating SSL 3.0! The bad guys are laughing, and the good guys are scrambling. It should be the other way around.
Kelly Jackson Higgins
Kelly Jackson Higgins,
User Rank: Strategist
10/16/2014 | 4:38:32 PM
Re: Credit to Google...
...ah, but as for us journos, we're all cursing Google for those awful POODLE pun PR pitches that name has spawned.
Thomas Claburn
Thomas Claburn,
User Rank: Ninja
10/16/2014 | 4:33:59 PM
Credit to Google...
...for naming this POODLE. It's memorable enough to get people to pay attention.
Kelly Jackson Higgins
Kelly Jackson Higgins,
User Rank: Strategist
10/16/2014 | 8:54:03 AM
Re: protocols too old
I almost LOL'ed when I learned that the reason SSLv3 is still supported in many cases is for XP and IE6 users. <sigh>
securityaffairs
securityaffairs,
User Rank: Ninja
10/16/2014 | 5:43:39 AM
protocols too old
Compare the extension of POODLE to HearthBleed or BashBug is absurd, anyway this flaw raise once again the necessity to approach security by design. 

Many protocols are very dated but still supported, like SSLv3, consider that the concept of security is evolved in the last 20 years in a dramatic way. Supporting a dated protocol for which security requirements were totally different from actual needs enlarge our surface of attacks.

It is necessary to seriously consider a deep assessment of most popular protocol and standard to avoid other clamourous case.

 
Kelly Jackson Higgins
Kelly Jackson Higgins,
User Rank: Strategist
10/15/2014 | 4:42:11 PM
Re: Is it safe? Probably not
So the Metasploit module isn't out officially yet? I haven't seen anything on it if so.
theb0x
theb0x,
User Rank: Ninja
10/15/2014 | 4:41:02 PM
Re: Is it safe? Probably not
Unfortunately I can not publicly disclose that information at this time.
Kelly Jackson Higgins
Kelly Jackson Higgins,
User Rank: Strategist
10/15/2014 | 4:08:07 PM
Re: Is it safe? Probably not
If a Metasploit module is now out, then it's a bit more streamlined to pull off, for sure. But the attack still requires some proximity and targeting. Got a link to the Metasploit module by chance, @theb0x? Our commenting platform won't allow you to input a live link, but if you could provide the URL, that would be great. 

Thanks!
theb0x
theb0x,
User Rank: Ninja
10/15/2014 | 3:10:36 PM
Is it safe? Probably not.
"This is not an easy attack to carry out. It's an elaborate attack... There is a lot for the attacker to do to make it successful. The question is what's the motivation" to execute it."


This statement is completely misleading. Truth is it is an easy attack. The CVE-2014-3566 (Poodle SSL Vulnerability) PoC has already been released for Metasploit 4.10.0 (Update 2014101501).

 


 

 

 


Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
How Machine Learning, AI & Deep Learning Improve Cybersecurity
Machine intelligence is influencing all aspects of cybersecurity. Organizations are implementing AI-based security to analyze event data using ML models that identify attack patterns and increase automation. Before security teams can take advantage of AI and ML tools, they need to know what is possible. This report covers: -How to assess the vendor's AI/ML claims -Defining success criteria for AI/ML implementations -Challenges when implementing AI
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2022-41828
PUBLISHED: 2022-09-29
In Amazon AWS Redshift JDBC Driver (aka amazon-redshift-jdbc-driver or redshift-jdbc42) before 2.1.0.8, the Object Factory does not check the class type when instantiating an object from a class name.
CVE-2022-3364
PUBLISHED: 2022-09-29
Allocation of Resources Without Limits or Throttling in GitHub repository ikus060/rdiffweb prior to 2.5.0a3.
CVE-2022-39232
PUBLISHED: 2022-09-29
Discourse is an open source discussion platform. Starting with version 2.9.0.beta5 and prior to version 2.9.0.beta10, an incomplete quote can generate a JavaScript error which will crash the current page in the browser in some cases. Version 2.9.0.beta10 added a fix and tests to ensure incomplete qu...
CVE-2022-40472
PUBLISHED: 2022-09-29
ZKTeco Xiamen Information Technology ZKBio Time 8.0.7 Build: 20220721.14829 was discovered to contain a CSV injection vulnerability. This vulnerability allows attackers to execute arbitrary code via a crafted payload injected into the Content text field of the Add New Message module.
CVE-2022-36068
PUBLISHED: 2022-09-29
Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched i...