Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Comments
'POODLE' Attacks, Kills Off SSL 3.0
Newest First  |  Oldest First  |  Threaded View
GonzSTL
100%
0%
GonzSTL,
User Rank: Ninja
10/20/2014 | 11:22:56 AM
Re: protocols too old
What really gets me is that TLS was designed to replace SSL, and was introduced last century (I know that sounds really dramatic), and we still have systems that have not deprecated that protocol. I realize that systems security updates/upgrades may consume a great deal of internal resources, but in today's threat landscape, can we really afford not to do that? Have we not arrived at a point where systems operators must be nimble enough so that they can respond to security issues such as an insecure protocol in a timely fashion, before havoc breaks out? Timely is the keyword. SSL 3.0 was released in 1996; TLS 1.0 was defined in January 1999, TLS 1.1 In April 2006, and TLS 1.2 in August 2008. Here we are in 2014, still talking about deprecating SSL 3.0! The bad guys are laughing, and the good guys are scrambling. It should be the other way around.
Kelly Jackson Higgins
50%
50%
Kelly Jackson Higgins,
User Rank: Strategist
10/16/2014 | 4:38:32 PM
Re: Credit to Google...
...ah, but as for us journos, we're all cursing Google for those awful POODLE pun PR pitches that name has spawned.
Thomas Claburn
50%
50%
Thomas Claburn,
User Rank: Ninja
10/16/2014 | 4:33:59 PM
Credit to Google...
...for naming this POODLE. It's memorable enough to get people to pay attention.
Kelly Jackson Higgins
100%
0%
Kelly Jackson Higgins,
User Rank: Strategist
10/16/2014 | 8:54:03 AM
Re: protocols too old
I almost LOL'ed when I learned that the reason SSLv3 is still supported in many cases is for XP and IE6 users. <sigh>
securityaffairs
50%
50%
securityaffairs,
User Rank: Ninja
10/16/2014 | 5:43:39 AM
protocols too old
Compare the extension of POODLE to HearthBleed or BashBug is absurd, anyway this flaw raise once again the necessity to approach security by design. 

Many protocols are very dated but still supported, like SSLv3, consider that the concept of security is evolved in the last 20 years in a dramatic way. Supporting a dated protocol for which security requirements were totally different from actual needs enlarge our surface of attacks.

It is necessary to seriously consider a deep assessment of most popular protocol and standard to avoid other clamourous case.

 
Kelly Jackson Higgins
50%
50%
Kelly Jackson Higgins,
User Rank: Strategist
10/15/2014 | 4:42:11 PM
Re: Is it safe? Probably not
So the Metasploit module isn't out officially yet? I haven't seen anything on it if so.
theb0x
50%
50%
theb0x,
User Rank: Ninja
10/15/2014 | 4:41:02 PM
Re: Is it safe? Probably not
Unfortunately I can not publicly disclose that information at this time.
Kelly Jackson Higgins
100%
0%
Kelly Jackson Higgins,
User Rank: Strategist
10/15/2014 | 4:08:07 PM
Re: Is it safe? Probably not
If a Metasploit module is now out, then it's a bit more streamlined to pull off, for sure. But the attack still requires some proximity and targeting. Got a link to the Metasploit module by chance, @theb0x? Our commenting platform won't allow you to input a live link, but if you could provide the URL, that would be great. 

Thanks!
theb0x
100%
0%
theb0x,
User Rank: Ninja
10/15/2014 | 3:10:36 PM
Is it safe? Probably not.
"This is not an easy attack to carry out. It's an elaborate attack... There is a lot for the attacker to do to make it successful. The question is what's the motivation" to execute it."


This statement is completely misleading. Truth is it is an easy attack. The CVE-2014-3566 (Poodle SSL Vulnerability) PoC has already been released for Metasploit 4.10.0 (Update 2014101501).

 


 

 

 


Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
How Enterprises Are Assessing Cybersecurity Risk in Today's Environment
The adoption of cloud services spurred by the COVID-19 pandemic has resulted in pressure on cyber-risk professionals to focus on vulnerabilities and new exposures that stem from pandemic-driven changes. Many cybersecurity pros expect fundamental, long-term changes to their organization's computing and data security due to the shift to more remote work and accelerated cloud adoption. Download this report from Dark Reading to learn more about their challenges and concerns.
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-4875
PUBLISHED: 2022-01-21
IBM Cognos Controller 10.4.0, 10.4.1, and 10.4.2 is vulnerable to an XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources. IBM X-Force ID: 190838.
CVE-2020-4876
PUBLISHED: 2022-01-21
IBM Cognos Controller 10.4.0, 10.4.1, and 10.4.2 is vulnerable to an XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources. IBM X-Force ID: 190839.
CVE-2020-4877
PUBLISHED: 2022-01-21
IBM Cognos Controller 10.4.0, 10.4.1, and 10.4.2 could be vulnerable to unauthorized modifications by using public fields in public classes. IBM X-Force ID: 190843.
CVE-2020-4879
PUBLISHED: 2022-01-21
IBM Cognos Controller 10.4.0, 10.4.1, and 10.4.2 could allow a remote attacker to bypass security restrictions, caused by improper validation of authentication cookies. IBM X-Force ID: 190847.
CVE-2021-4016
PUBLISHED: 2022-01-21
Rapid7 Insight Agent, versions prior to 3.1.3, suffer from an improper access control vulnerability whereby, the user has access to the snapshot directory. An attacker can access, read and copy any of the files in this directory e.g. asset_info.json or file_info.json, leading to a loss of confident...