Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Comments
Apple: Majority Of Mac OS X Users Not At Risk To 'Shellshock'
Newest First  |  Oldest First  |  Threaded View
securityaffairs
50%
50%
securityaffairs,
User Rank: Ninja
9/30/2014 | 2:38:52 AM
Re: Apple is attempting to minimize.
I agree theb0x!
theb0x
50%
50%
theb0x,
User Rank: Ninja
9/29/2014 | 9:26:22 PM
Re: Apple is attempting to minimize.
The following conditions must be true in OSX to exploit the system:

1) Root must be enabled. The setting is pretty well hidden and the user must knowly access it. (System default is disabled in latest OSX.)

2) A local terminal session must be spawned with the following command followed by root password:

sudo systemsetup -setremotelogin on

This enables the SSH Daemon. How many average Apple users do you think have configured their systems this way? At this point I see this as nothing more than a social engineering attack for these system conditions to be true for most users. Unless they know what SSH is because they're a Sys Admin. I am not taking sides with Apple. Their security responses are a joke and always make me chuckle.
securityaffairs
50%
50%
securityaffairs,
User Rank: Ninja
9/29/2014 | 11:02:09 AM
Re: Apple is attempting to minimize.
I agree, OS X is anyway affected by the Bash bug flaw and its announcement is giving a fake sense of security to many people that aren't able to check their systems.
RyanSepe
50%
50%
RyanSepe,
User Rank: Ninja
9/29/2014 | 9:12:11 AM
Re: Apple is attempting to minimize.
Very good point Robert. I think even if there is the possibility of a vulnerable configuration within your hardware that you need to account for it. How difficult would it be for Apple to design a quick app to check if the system settings you have on your Mac are vulnerable? 

The answer is not very difficult at all if it is just a series of enables/disables. If enabled true if not than false. A quick scan should be made available for all OSX users. I think it isn't too lofty of a request considered that this vulnerability was given the highest severity rating possible by NIST.
Robert McDougal
50%
50%
Robert McDougal,
User Rank: Ninja
9/28/2014 | 12:48:25 PM
Apple is attempting to minimize.
True, in order to be vulnerable to a remote execution you need to enable some inbound service, such as SSH.  However, the fact is that ALL versions of OSX have the vulnerability.  In my testing, every version of OSX, including the beta of Yosemite, have proved to be vulnerable.

I know Apple hasn't had to deal with major vulnerabilities routinely in the past, but this isn't the way to address it.  Apple should admit that all versions of OSX have the vulnerability but, users are not exposed unless they enable X, Y or Z.  They shouldn't leave the subject up for debate by making a nebulous statement such as "systems are safe by default and not exposed to remote exploits of Bash unless users configure advanced UNIX services".  This doesn't actually explain to users how they might currently be vulnerable, or what they may do for a work around.

Apple gets an F for this response in my book.

 


COVID-19: Latest Security News & Commentary
Dark Reading Staff 7/31/2020
'BootHole' Vulnerability Exposes Secure Boot Devices to Attack
Kelly Sheridan, Staff Editor, Dark Reading,  7/29/2020
Out-of-Date and Unsupported Cloud Workloads Continue as a Common Weakness
Robert Lemos, Contributing Writer,  7/28/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Special Report: Computing's New Normal, a Dark Reading Perspective
This special report examines how IT security organizations have adapted to the "new normal" of computing and what the long-term effects will be. Read it and get a unique set of perspectives on issues ranging from new threats & vulnerabilities as a result of remote working to how enterprise security strategy will be affected long term.
Flash Poll
The Threat from the Internetand What Your Organization Can Do About It
The Threat from the Internetand What Your Organization Can Do About It
This report describes some of the latest attacks and threats emanating from the Internet, as well as advice and tips on how your organization can mitigate those threats before they affect your business. Download it today!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-14310
PUBLISHED: 2020-07-31
There is an issue on grub2 before version 2.06 at function read_section_as_string(). It expects a font name to be at max UINT32_MAX - 1 length in bytes but it doesn't verify it before proceed with buffer allocation to read the value from the font value. An attacker may leverage that by crafting a ma...
CVE-2020-14311
PUBLISHED: 2020-07-31
There is an issue with grub2 before version 2.06 while handling symlink on ext filesystems. A filesystem containing a symbolic link with an inode size of UINT32_MAX causes an arithmetic overflow leading to a zero-sized memory allocation with subsequent heap-based buffer overflow.
CVE-2020-5413
PUBLISHED: 2020-07-31
Spring Integration framework provides Kryo Codec implementations as an alternative for Java (de)serialization. When Kryo is configured with default options, all unregistered classes are resolved on demand. This leads to the "deserialization gadgets" exploit when provided data contains mali...
CVE-2020-5414
PUBLISHED: 2020-07-31
VMware Tanzu Application Service for VMs (2.7.x versions prior to 2.7.19, 2.8.x versions prior to 2.8.13, and 2.9.x versions prior to 2.9.7) contains an App Autoscaler that logs the UAA admin password. This credential is redacted on VMware Tanzu Operations Manager; however, the unredacted logs are a...
CVE-2019-11286
PUBLISHED: 2020-07-31
VMware GemFire versions prior to 9.10.0, 9.9.1, 9.8.5, and 9.7.5, and VMware Tanzu GemFire for VMs versions prior to 1.11.0, 1.10.1, 1.9.2, and 1.8.2, contain a JMX service available to the network which does not properly restrict input. A remote authenticated malicious user may request against the ...