Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Endpoint

5/14/2019
02:30 PM
Connect Directly
Twitter
LinkedIn
Google+
RSS
E-Mail
50%
50%

Microsoft Patches Wormable Vuln in Windows 7, 2003, XP, Server 2008

Microsoft releases security updates for some out-of-support systems to fix a bug that could be weaponized as a worm if exploited.

Microsoft today took the unusual step of issuing security fixes for out-of-support systems to patch a vulnerability it fears could be wormable if exploited. CVE-2019-0708 affects in-support systems Windows 7, Server 2008, and 2008 R2 and out-of-support Windows 2003 and XP.

It's a critical remote code execution flaw in Remote Desktop Services (RDS), formerly known as Terminal Services, which affects some older versions of Windows. CVE-2019-0708 is pre-authentication and requires no user interaction, meaning any future malware could propagate across vulnerable machines.

Authenticated attackers could exploit this vulnerability by connecting to a target system via Remote Desktop Protocol (RDP) and sending specially crafted requests. Microsoft says RDP itself is not vulnerable; however, it is a component of an attack chain exploiting RDS. If successful, an attacker could execute code on the target system; install programs; view, edit, or delete data; or create new accounts with full user rights. Today's fix corrects the way Remote Desktop Services handles connection requests.

Simon Pope, director of incident response for the Microsoft Security Response Center, says it's "highly likely" malicious actors will write an exploit for this vulnerability and build it into malware. Microsoft has not seen any evidence of CVE-2019-0708 being exploited in the wild, but it urges companies to update immediately, warning the bug could be weaponized as a worm.

The impact is limited to older versions of Windows that are either out of support or approaching the end-of-support life cycle. Vulnerable in-support systems with automatic updates enabled are protected. Vulnerable out-of-support versions can find guidance here.

There is a partial mitigation on affected systems with Network Level Authentication (NLA) enabled, Pope explains in a blog post. These systems are protected from wormable malware or advanced threats that could exploit this vulnerability; NLA requires authentication before the vuln can be triggered. These systems are exposed to RCE if an attacker has valid credentials.

It's worth noting CVE-2019-0708 does not affect newer versions of Windows, including Windows 10, 8.1, and 8, as well as Windows Server 2019, Server 2016, Server 2012 R2, and Server 2012.

CVE-2019-0708 isn't the only vulnerability Microsoft fixed for this month's Patch Tuesday update. The company issued patches for 79 CVEs, 22 of which were deemed Critical in severity and 57 of which were ranked Important. Two were publicly known; one is under active attack.

The bug being abused in the wild is CVE-2019-0863, a Windows Error Reporting (WER) elevation of privilege vulnerability that exists in the way WER handles files. Attackers must first gain unprivileged execution on a victim system to execute an attack. "The exploitation of this vulnerability could lead to arbitrary code execution in kernel mode, which is typically reserved for trusted functions of the operating system," says Satnam Narang, senior research engineer at Tenable. Exploitation of CVE-2019-0863 would also let an attacker view, change, or delete data, or create new accounts with admin privileges.

"While details about the use of the exploit are not available, it is likely being used in limited attacks against specific targets," writes Dustin Childs of Trend Micro's Zero-Day Initiative.

Related Content:

 

 

 

Join Dark Reading LIVE for two cybersecurity summits at Interop 2019. Learn from the industry's most knowledgeable IT security experts. Check out the Interop agenda here.

Kelly Sheridan is the Staff Editor at Dark Reading, where she focuses on cybersecurity news and analysis. She is a business technology journalist who previously reported for InformationWeek, where she covered Microsoft, and Insurance & Technology, where she covered financial ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Data Leak Week: Billions of Sensitive Files Exposed Online
Kelly Jackson Higgins, Executive Editor at Dark Reading,  12/10/2019
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: Our Endpoint Protection system is a little outdated... 
Current Issue
The Year in Security: 2019
This Tech Digest provides a wrap up and overview of the year's top cybersecurity news stories. It was a year of new twists on old threats, with fears of another WannaCry-type worm and of a possible botnet army of Wi-Fi routers. But 2019 also underscored the risk of firmware and trusted security tools harboring dangerous holes that cybercriminals and nation-state hackers could readily abuse. Read more.
Flash Poll
Rethinking Enterprise Data Defense
Rethinking Enterprise Data Defense
Frustrated with recurring intrusions and breaches, cybersecurity professionals are questioning some of the industrys conventional wisdom. Heres a look at what theyre thinking about.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2019-19782
PUBLISHED: 2019-12-13
The FTP client in AceaXe Plus 1.0 allows a buffer overflow via a long EHLO response from an FTP server.
CVE-2019-19777
PUBLISHED: 2019-12-13
stb_image.h (aka the stb image loader) 2.23, as used in libsixel and other products, has a heap-based buffer over-read in stbi__load_main.
CVE-2019-19778
PUBLISHED: 2019-12-13
An issue was discovered in libsixel 1.8.2. There is a heap-based buffer over-read in the function load_sixel at loader.c.
CVE-2019-16777
PUBLISHED: 2019-12-13
Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of pa...
CVE-2019-16775
PUBLISHED: 2019-12-13
Versions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. It is possible for packages to create symlinks to files outside of thenode_modules folder through the bin field upon installation. A properly constructed entry in the package.json bin field would allow a package publi...