Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Application Security //

Web Application Development

// // //
8/24/2018
09:05 AM
Larry Loeb
Larry Loeb
Larry Loeb

Apache Struts Critical Weakness Found, Patched

The open source framework for Java-based web apps has a critical flaw the Apache Software Foundation is trying to counter.

A critical-level remote code execution vulnerability (CVE-2018-11776) has been identified in Apache Struts. Struts is an open source framework used in the development of Java-based web apps. The vulnerability has been classified as critical because the flaw could allow remote attackers to execute their code on a server that is running the Struts-developed app.

The Apache Software Foundation announced that it has released a new version of Struts that patches the issue. Affected versions include Struts 2.3 through Struts 2.3.34, as well as Struts 2.5 through Struts 2.5.16. ASF strongly recommends that users upgrade to Struts 2.3.35 or Struts 2.5.17 immediately, even though a workaround that they characterize as "weak" is possible.

Adding urgency, Tenable has blogged, "A working proof of concept (PoC) has been discovered and verified on Github by Tenable's research team. In addition, there are indications that attackers are already probing for vulnerable Apache Struts instances."

Man Yue Mo from the Semmle Security Research team has been credited with identifying the problem.

A previous vulnerability in Struts (CVE-2017-5638) that was also discovered by Semmle has been blamed as the cause of the massive data breach that occurred at Equifax. In that instance, the financial records of more than 140 million users were exposed.

There are specific configurations of Struts that enable the vulnerability.

They are:

  1. The alwaysSelectFullNamespace flag is set to true in the Struts configuration. This automatically occurs if the application uses the Struts Convention plugin.
  2. The application's Struts configuration file contains an tag that does not specify the optional namespace attribute or specifies a wildcard namespace ("/*").

Dayne Topkin via Unsplash
Dayne Topkin via Unsplash

Semmle notes, "If your application's configuration does not meet these two conditions, you are likely not vulnerable to the two attack vectors described. However, new attack vectors that apply to different configurations may be discovered in the near future."

The researchers found that vulnerable applications may be attacked by threat actors injecting their own namespace as a parameter in an HTTP request. It seems that the value of that parameter is insufficiently validated by the Struts framework, and can be any OGNL string.

OGNL ("Object-Graph Navigation Language") is a domain-specific language that is used to customize Apache Struts' behavior.

Mo describes the process that led to the exposure of the vulnerability in a blog. He looks at the underlying data flow of Struts and how libraries that are used in determining results will affect it.

He also wonders how this vulnerability was missed by everyone. He thinks they were just not looking widely enough.

He notes in the blog that, "In my opinion, it's because the similarities between [previous vulnerabilities] are, in a sense, local, in that they all occur in a similar location in the source code (all in the Rest plugin). They are linked by the tainted source, rather than the location of the source code, so any software or tool that would successfully find variants like this would need to be able to perform […] semantic analysis across the whole code base."

What should worry the security professional is that further vulnerabilities may be exposed by this approach to Struts. Attention in the upcoming days will be needed.

Correction (8/24/2018): This article was updated to correct the mention of the Equifax breach that had identified the company as Experian.

Related posts:

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Edge-DRsplash-10-edge-articles
I Smell a RAT! New Cybersecurity Threats for the Crypto Industry
David Trepp, Partner, IT Assurance with accounting and advisory firm BPM LLP,  7/9/2021
News
Attacks on Kaseya Servers Led to Ransomware in Less Than 2 Hours
Robert Lemos, Contributing Writer,  7/7/2021
Commentary
It's in the Game (but It Shouldn't Be)
Tal Memran, Cybersecurity Expert, CYE,  7/9/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
How Machine Learning, AI & Deep Learning Improve Cybersecurity
Machine intelligence is influencing all aspects of cybersecurity. Organizations are implementing AI-based security to analyze event data using ML models that identify attack patterns and increase automation. Before security teams can take advantage of AI and ML tools, they need to know what is possible. This report covers: -How to assess the vendor's AI/ML claims -Defining success criteria for AI/ML implementations -Challenges when implementing AI
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2022-42247
PUBLISHED: 2022-10-03
pfSense v2.5.2 was discovered to contain a cross-site scripting (XSS) vulnerability in the browser.php component. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into a file name.
CVE-2022-41443
PUBLISHED: 2022-10-03
phpipam v1.5.0 was discovered to contain a header injection vulnerability via the component /admin/subnets/ripe-query.php.
CVE-2022-33882
PUBLISHED: 2022-10-03
Under certain conditions, an attacker could create an unintended sphere of control through a vulnerability present in file delete operation in Autodesk desktop app (ADA). An attacker could leverage this vulnerability to escalate privileges and execute arbitrary code.
CVE-2022-42306
PUBLISHED: 2022-10-03
An issue was discovered in Veritas NetBackup through 8.2 and related Veritas products. An attacker with local access can send a crafted packet to pbx_exchange during registration and cause a NULL pointer exception, effectively crashing the pbx_exchange process.
CVE-2022-42307
PUBLISHED: 2022-10-03
An issue was discovered in Veritas NetBackup through 10.0.0.1 and related Veritas products. The NetBackup Primary server is vulnerable to an XML External Entity (XXE) Injection attack through the DiscoveryService service.