1/28/2015
01:30 PM
Connect Directly
Google+
Twitter
RSS
E-Mail

'Ghost' Not So Scary After All

The latest open-source Linux vulnerability is serious but some security experts say it's not that easy to abuse and use in an attack.



Another day, another open-source Linux bug:  a serious buffer overflow vulnerability affecting many Linux systems that was revealed yesterday by Qualys isn't so easy to exploit, according to some security experts.

Ghost or CVE-2015-0235, which was discovered by Qualys researchers, is a flaw in Linux's GNU C Library, aka glibc, that would allow an attacker to wrest control of a system without authenticating to it. It's found in various Linux appliances and affects Debian 7, Red Hat Enterprise Linux 6 and 7, CentOS 6 and 7, and Ubuntu 12.04, as well as other Linux implementations. Glibc versions 2.2 through 2.17 are vulnerable to Ghost.

The good news is that a patch is available for all of the affected Linux systems, but the even better news is that while it's serious, most security experts say it's not anything to panic about because exploiting it is no easy task.

Qualys created a proof-of-concept exploit that demonstrates how Ghost could bypass anti-exploitation features such as ASLR, to breach an Exim email server, and the company plans to release a Metasploit module for Ghost soon. The security firm says an attacker could merely send an email to a Linux system and gain access to it.

Wolfgang Kandek, CTO at Qualys, says while an exploitable prospects aren't necessarily easy to find, there are likely others. "Ghost has multiple remote vectors, [and] we only know of one so far," he says, referring to the Exim proof-of-concept.

According to Qualys' research, it's a major flaw that would be relatively simple to exploit.

But other security expert disagree. HD Moore, chief research officer at Rapid7, says it's best to check with your Linux appliance vendor to see if there's a patch. "To be clear, this is not the end of the Internet as we know it, nor is it another Heartbleed. In a general sense, it’s not likely to be an easy bug to exploit," Moore says.

Pawan Kinger, director of Trend Micro's Deep Security Labs, notes that Ghost doesn't affect newer Linux implementations since the underlying issue was fixed in 2013, so the number of systems that could be vulnerable to attacks is "limited." An attacker also would require a tiny exploit of 4- or 8 bytes for the initial attack, which also makes it less likely to be used.

"With only four or eight bytes as the initial exploit vector, gaining further access is highly dependent on application design and memory usage. This is a significant barrier to exploitation," Kinger said in a blog post today.

Matasano Security, meanwhile, has posted a blog with technical analysis and details on software vulnerable to Ghost.

Kelly Jackson Higgins is the Executive Editor of Dark Reading. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Email This  | 
Print  | 
RSS
More Insights
Copyright © 2020 UBM Electronics, A UBM company, All rights reserved. Privacy Policy | Terms of Service