Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Application Security

1/28/2015
01:30 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

'Ghost' Not So Scary After All

The latest open-source Linux vulnerability is serious but some security experts say it's not that easy to abuse and use in an attack.

Another day, another open-source Linux bug:  a serious buffer overflow vulnerability affecting many Linux systems that was revealed yesterday by Qualys isn't so easy to exploit, according to some security experts.

Ghost or CVE-2015-0235, which was discovered by Qualys researchers, is a flaw in Linux's GNU C Library, aka glibc, that would allow an attacker to wrest control of a system without authenticating to it. It's found in various Linux appliances and affects Debian 7, Red Hat Enterprise Linux 6 and 7, CentOS 6 and 7, and Ubuntu 12.04, as well as other Linux implementations. Glibc versions 2.2 through 2.17 are vulnerable to Ghost.

The good news is that a patch is available for all of the affected Linux systems, but the even better news is that while it's serious, most security experts say it's not anything to panic about because exploiting it is no easy task.

Qualys created a proof-of-concept exploit that demonstrates how Ghost could bypass anti-exploitation features such as ASLR, to breach an Exim email server, and the company plans to release a Metasploit module for Ghost soon. The security firm says an attacker could merely send an email to a Linux system and gain access to it.

Wolfgang Kandek, CTO at Qualys, says while an exploitable prospects aren't necessarily easy to find, there are likely others. "Ghost has multiple remote vectors, [and] we only know of one so far," he says, referring to the Exim proof-of-concept.

According to Qualys' research, it's a major flaw that would be relatively simple to exploit.

But other security expert disagree. HD Moore, chief research officer at Rapid7, says it's best to check with your Linux appliance vendor to see if there's a patch. "To be clear, this is not the end of the Internet as we know it, nor is it another Heartbleed. In a general sense, it’s not likely to be an easy bug to exploit," Moore says.

Pawan Kinger, director of Trend Micro's Deep Security Labs, notes that Ghost doesn't affect newer Linux implementations since the underlying issue was fixed in 2013, so the number of systems that could be vulnerable to attacks is "limited." An attacker also would require a tiny exploit of 4- or 8 bytes for the initial attack, which also makes it less likely to be used.

"With only four or eight bytes as the initial exploit vector, gaining further access is highly dependent on application design and memory usage. This is a significant barrier to exploitation," Kinger said in a blog post today.

Matasano Security, meanwhile, has posted a blog with technical analysis and details on software vulnerable to Ghost.

Kelly Jackson Higgins is the Executive Editor of Dark Reading. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Oldest First  |  Newest First  |  Threaded View
RyanSepe
50%
50%
RyanSepe,
User Rank: Ninja
1/28/2015 | 2:39:53 PM
Easy Mitigiation
If your company keeps up with leveraging current distros then you might not be in danger anyway. The most recent versions of glibc are not vulnerable. These are a product of more current distros and if your enterprise maintains a streamlined patch and change management process you could be in the clear. 

However, it is good to check for saftey. I believe that Nessus and Qualys vulnerability scanners have the ability to detect this.
Joe Stanganelli
50%
50%
Joe Stanganelli,
User Rank: Ninja
1/28/2015 | 10:04:18 PM
open-source bug exposure
It's fascinating to me how, in the wake of Heartbleed and Shellshock, every single moderate vulnerability in a significant open-source project is getting significant attention.

Which perhaps is a good thing, considering how pre-Shellshock, the over-pious open-source zealots would persistently insist that open source was always superior and safer and perfect and could brush your teeth while baking bread and teaching you how to play jazz piano.
Kelly Jackson Higgins
50%
50%
Kelly Jackson Higgins,
User Rank: Strategist
1/29/2015 | 7:57:21 AM
Re: open-source bug exposure
Good points, @Joe. Here's a good piece by Jai Vijayan about the open-source code problem for enterprises: http://www.darkreading.com/growing-open-source-use-heightens-enterprise-security-risks-/d/d-id/1318767?
Joe Stanganelli
50%
50%
Joe Stanganelli,
User Rank: Ninja
1/29/2015 | 9:36:48 PM
Re: open-source bug exposure
I love the defense of flawed open source so many throw up that's basically, "Don't blame the developers!  They're just six unpaid guys who live in a trailer park, and one of them doesn't even have thumbs."

Would you feel the same way about medical malpractice if the hospital's lawyers were like, "Come on, don't blame that poor old surgeon; he's blind! Which makes it really hard for him to find his Parkinson's medication!"?

People want solutions that work satisfactorily.  End of story.
Marilyn Cohodas
50%
50%
Marilyn Cohodas,
User Rank: Strategist
1/30/2015 | 11:40:32 AM
Re: open-source bug exposure
Good point, @Joe Stanganelli. But outside the issue of secure application software development is the issue of patching, especially in this particular instance where there a patch is available for all of the affected Linux systems.
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
6 Emerging Cyber Threats That Enterprises Face in 2020
This Tech Digest gives an in-depth look at six emerging cyber threats that enterprises could face in 2020. Download your copy today!
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-1927
PUBLISHED: 2020-04-02
In Apache HTTP Server 2.4.0 to 2.4.41, redirects configured with mod_rewrite that were intended to be self-referential might be fooled by encoded newlines and redirect instead to an an unexpected URL within the request URL.
CVE-2020-8144
PUBLISHED: 2020-04-01
The UniFi Video Server v3.9.3 and prior (for Windows 7/8/10 x64) web interface Firmware Update functionality, under certain circumstances, does not validate firmware download destinations to ensure they are within the intended destination directory tree. It accepts a request with a URL to firmware u...
CVE-2020-8145
PUBLISHED: 2020-04-01
The UniFi Video Server (Windows) web interface configuration restore functionality at the “backup� and “wizard� endpoints does not implement sufficient privilege checks. Low privileged users, belonging to the PUBLIC_GROUP ...
CVE-2020-8146
PUBLISHED: 2020-04-01
In UniFi Video v3.10.1 (for Windows 7/8/10 x64) there is a Local Privileges Escalation to SYSTEM from arbitrary file deletion and DLL hijack vulnerabilities. The issue was fixed by adjusting the .tsExport folder when the controller is running on Windows and adjusting the SafeDllSearchMode in the win...
CVE-2020-6009
PUBLISHED: 2020-04-01
LearnDash Wordpress plugin version below 3.1.6 is vulnerable to Unauthenticated SQL Injection.