Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Application Security

1/28/2015
01:30 PM
Connect Directly
Twitter
RSS
E-Mail
50%
50%

'Ghost' Not So Scary After All

The latest open-source Linux vulnerability is serious but some security experts say it's not that easy to abuse and use in an attack.

Another day, another open-source Linux bug:  a serious buffer overflow vulnerability affecting many Linux systems that was revealed yesterday by Qualys isn't so easy to exploit, according to some security experts.

Ghost or CVE-2015-0235, which was discovered by Qualys researchers, is a flaw in Linux's GNU C Library, aka glibc, that would allow an attacker to wrest control of a system without authenticating to it. It's found in various Linux appliances and affects Debian 7, Red Hat Enterprise Linux 6 and 7, CentOS 6 and 7, and Ubuntu 12.04, as well as other Linux implementations. Glibc versions 2.2 through 2.17 are vulnerable to Ghost.

The good news is that a patch is available for all of the affected Linux systems, but the even better news is that while it's serious, most security experts say it's not anything to panic about because exploiting it is no easy task.

Qualys created a proof-of-concept exploit that demonstrates how Ghost could bypass anti-exploitation features such as ASLR, to breach an Exim email server, and the company plans to release a Metasploit module for Ghost soon. The security firm says an attacker could merely send an email to a Linux system and gain access to it.

Wolfgang Kandek, CTO at Qualys, says while an exploitable prospects aren't necessarily easy to find, there are likely others. "Ghost has multiple remote vectors, [and] we only know of one so far," he says, referring to the Exim proof-of-concept.

According to Qualys' research, it's a major flaw that would be relatively simple to exploit.

But other security expert disagree. HD Moore, chief research officer at Rapid7, says it's best to check with your Linux appliance vendor to see if there's a patch. "To be clear, this is not the end of the Internet as we know it, nor is it another Heartbleed. In a general sense, it’s not likely to be an easy bug to exploit," Moore says.

Pawan Kinger, director of Trend Micro's Deep Security Labs, notes that Ghost doesn't affect newer Linux implementations since the underlying issue was fixed in 2013, so the number of systems that could be vulnerable to attacks is "limited." An attacker also would require a tiny exploit of 4- or 8 bytes for the initial attack, which also makes it less likely to be used.

"With only four or eight bytes as the initial exploit vector, gaining further access is highly dependent on application design and memory usage. This is a significant barrier to exploitation," Kinger said in a blog post today.

Matasano Security, meanwhile, has posted a blog with technical analysis and details on software vulnerable to Ghost.

Kelly Jackson Higgins is the Executive Editor of Dark Reading. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio
 

Recommended Reading:

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Marilyn Cohodas
50%
50%
Marilyn Cohodas,
User Rank: Strategist
1/30/2015 | 11:40:32 AM
Re: open-source bug exposure
Good point, @Joe Stanganelli. But outside the issue of secure application software development is the issue of patching, especially in this particular instance where there a patch is available for all of the affected Linux systems.
Joe Stanganelli
50%
50%
Joe Stanganelli,
User Rank: Ninja
1/29/2015 | 9:36:48 PM
Re: open-source bug exposure
I love the defense of flawed open source so many throw up that's basically, "Don't blame the developers!  They're just six unpaid guys who live in a trailer park, and one of them doesn't even have thumbs."

Would you feel the same way about medical malpractice if the hospital's lawyers were like, "Come on, don't blame that poor old surgeon; he's blind! Which makes it really hard for him to find his Parkinson's medication!"?

People want solutions that work satisfactorily.  End of story.
Kelly Jackson Higgins
50%
50%
Kelly Jackson Higgins,
User Rank: Strategist
1/29/2015 | 7:57:21 AM
Re: open-source bug exposure
Good points, @Joe. Here's a good piece by Jai Vijayan about the open-source code problem for enterprises: http://www.darkreading.com/growing-open-source-use-heightens-enterprise-security-risks-/d/d-id/1318767?
Joe Stanganelli
50%
50%
Joe Stanganelli,
User Rank: Ninja
1/28/2015 | 10:04:18 PM
open-source bug exposure
It's fascinating to me how, in the wake of Heartbleed and Shellshock, every single moderate vulnerability in a significant open-source project is getting significant attention.

Which perhaps is a good thing, considering how pre-Shellshock, the over-pious open-source zealots would persistently insist that open source was always superior and safer and perfect and could brush your teeth while baking bread and teaching you how to play jazz piano.
RyanSepe
50%
50%
RyanSepe,
User Rank: Ninja
1/28/2015 | 2:39:53 PM
Easy Mitigiation
If your company keeps up with leveraging current distros then you might not be in danger anyway. The most recent versions of glibc are not vulnerable. These are a product of more current distros and if your enterprise maintains a streamlined patch and change management process you could be in the clear. 

However, it is good to check for saftey. I believe that Nessus and Qualys vulnerability scanners have the ability to detect this.
News
Inside the Ransomware Campaigns Targeting Exchange Servers
Kelly Sheridan, Staff Editor, Dark Reading,  4/2/2021
Commentary
Beyond MITRE ATT&CK: The Case for a New Cyber Kill Chain
Rik Turner, Principal Analyst, Infrastructure Solutions, Omdia,  3/30/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
How Enterprises are Developing Secure Applications
How Enterprises are Developing Secure Applications
Recent breaches of third-party apps are driving many organizations to think harder about the security of their off-the-shelf software as they continue to move left in secure software development practices.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-31414
PUBLISHED: 2021-04-16
The unofficial vscode-rpm-spec extension before 0.3.2 for Visual Studio Code allows remote code execution via a crafted workspace configuration.
CVE-2021-26073
PUBLISHED: 2021-04-16
Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or ...
CVE-2021-26074
PUBLISHED: 2021-04-16
Broken Authentication in Atlassian Connect Spring Boot (ACSB) from version 1.1.0 before version 2.1.3: Atlassian Connect Spring Boot is a Java Spring Boot package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Spring Boot app occurs with a se...
CVE-2018-19942
PUBLISHED: 2021-04-16
A cross-site scripting (XSS) vulnerability has been reported to affect earlier versions of File Station. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions: QTS 4.5.2.1566 build 20210202 (and later) QT...
CVE-2021-27691
PUBLISHED: 2021-04-16
Command Injection in Tenda G0 routers with firmware versions v15.11.0.6(9039)_CN and v15.11.0.5(5876)_CN , and Tenda G1 and G3 routers with firmware versions v15.11.0.17(9502)_CN or v15.11.0.16(9024)_CN allows remote attackers to execute arbitrary OS commands via a crafted action/setDebugCfg request...