Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Application Security

Adobe Software at Center of Two Vulnerability Disclosures

Newly discovered Photoshop and Ghostscript vulnerabilities allow remote code execution.

In a pair of apparently unrelated notices this week, remote execution vulnerabilities in two products built around Adobe image manipulation products were disclosed - as well as a security update for one of them.

In the first, Adobe announced updates to the Windows and MacOS versions of  Adobe Photoshop CC 2017 and 2018. According to the company, the critical vulnerabilities could allow remote code execution by unauthorized users. In announcing the updates, designated CVE-2018-12810 and CVE-2018-12811, Adobe describes the issues broadly while giving no details about the vulnerabilities or any known "in the wild" exploits.

Each of those two flaws was given a priority ranking of three, meaning that they are remediation for vulnerabilities in products that are not historically prime targets for threat exploits.

The second remote execution flaw announced today is much broader in potential impact: the vulnerability lies in the -dSAFER functionality of Ghostscript, an open source interpreter that allows programs such as GIMP (a popular open source alternative to Adobe Photoshop) to work with Adobe's PostScript and PDF page description languages.

Because Ghostscript is used in both applications and websites to allow display and modification of .PDF and other Adobe format files, even a rapid update to the interpreter would likely take quite a long time to be fully deployed across the Internet.

In a post to loss-security announcing the new vulnerabilities, Tavis Ormandy, the researcher who discovered them, recommended that developers disable "…PS, EPS, PDF and XPS coders in policy.xml by default."

Ormandy, who is on Google's Project Zero team, noted that he has found at least one exploit of the vulnerability in the wild, and that there are similar vulnerabilities that can be exploited with similar tactics. Further, he demonstrated that some of the methods for exploiting the vulnerabilities are trivial, requiring no advanced coding skills or security knowledge.

The new vulnerabilities are not the first to be found in -dSAFER. In a related post, Ormandy noted that he has posted -dSAFER sandbox escapes (methods allowing program execution to escape from the software sandbox designed to limit the effects of malicious code) in the past. 

"This exploit has the potential for file system access leading to sensitive data leak and more as it can be the beachhead opportunity for a more comprehensive data breach," says Stephen Giguere, a sales engineer at Synopsys said.

Related Content:

 

Learn from the industry's most knowledgeable CISOs and IT security experts in a setting that is conducive to interaction and conversation. Early bird rate ends August 31. Click for more info

Curtis Franklin Jr. is Senior Editor at Dark Reading. In this role he focuses on product and technology coverage for the publication. In addition he works on audio and video programming for Dark Reading and contributes to activities at Interop ITX, Black Hat, INsecurity, and ... View Full Bio
 

Recommended Reading:

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Why Vulnerable Code Is Shipped Knowingly
Chris Eng, Chief Research Officer, Veracode,  11/30/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
2021 Top Enterprise IT Trends
We've identified the key trends that are poised to impact the IT landscape in 2021. Find out why they're important and how they will affect you today!
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-16123
PUBLISHED: 2020-12-04
An Ubuntu-specific patch in PulseAudio created a race condition where the snap policy module would fail to identify a client connection from a snap as coming from a snap if SCM_CREDENTIALS were missing, allowing the snap to connect to PulseAudio without proper confinement. This could be exploited by...
CVE-2018-21270
PUBLISHED: 2020-12-03
Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an out-of-bounds read because of allocation of uninitialized buffers when a number is passed in the input stream (when using Node.js 4.x).
CVE-2020-26248
PUBLISHED: 2020-12-03
In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.
CVE-2020-29529
PUBLISHED: 2020-12-03
HashiCorp go-slug before 0.5.0 does not address attempts at directory traversal involving ../ and symlinks.
CVE-2020-29534
PUBLISHED: 2020-12-03
An issue was discovered in the Linux kernel before 5.9.3. io_uring takes a non-refcounted reference to the files_struct of the process that submitted a request, causing execve() to incorrectly optimize unshare_fd(), aka CID-0f2122045b94.