Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

Application Security

7/29/2020
03:10 PM
50%
50%

70,000+ WordPress Sites Affected by Critical Plug-in Flaw

A vulnerability in the wpDiscuz plug-in could let attackers remotely execute code on the servers of affected websites.

A critical security flaw in wpDiscuz, a WordPress plug-in, could enable cybercriminals to remotely execute malicious code on vulnerable website servers. The bug has a CVSS score of 10.0.

wpDiscuz is an Ajax real-time comment system that lets users keep their comments in their database. The plug-in, billed as an alternative to Disqus and Jetpack Comments, has more than 70,000 users. It comes with multiple layouts, interactive comment box, and other features.

In a recent version of the plug-in, wpDiscuz added an option for users to add image attachments in their comments. Its implementation lacked security protections and created a critical flaw that allowed attackers to upload arbitrary files, including PHP files, explains Chloe Chamberland of Wordfence, the security company where this vulnerability was discovered, in a blog post. 

Attackers could add image identifying features to files in order to pass the file content verification check. If successful, they could achieve remote code execution on a vulnerable website's server and traverse the hosting account to infect more websites hosted in the account where malicious code was uploaded.

"This would effective give the attacker complete control over every site on your server," Chamberland writes. The vulnerability was discovered in June and reported to the wpDiscuz team, which issued a fix in version 7.0.5 on July 23. 

Read more details in the Wordfence disclosure here.  

 

 

Register now for this year's fully virtual Black Hat USA, scheduled to take place August 1–6, and get more information about the event on the Black Hat website. Click for details on conference information and to register.

Dark Reading's Quick Hits delivers a brief synopsis and summary of the significance of breaking news events. For more information from the original source of the news item, please follow the link provided in this article. View Full Bio
 

Recommended Reading:

Comment  | 
Print  | 
More Insights
Comments
Oldest First  |  Newest First  |  Threaded View
GVTeam
50%
50%
GVTeam,
User Rank: Apprentice
7/30/2020 | 12:31:54 PM
All is fixed!
The problem is 100% fixed and wpDiscuz is safe.
You can ignore this if you've already updated to 7.0.5 or higher version (current version is 7.0.6).

This was fixed and the new version 7.0.5 was released a week ago. There is not any issues with current wpDiscuz version. It's 100% secure now.

This kind of issues happens with almost all WordPress plugins, so there is no reason to worry if you've updated and up to date. Just keep updating your plugins and make sure you're using the latest versions.

About 50% of wpDiscuz users are currently using 7.x.x versions. It's about 35,000 websites.
30,000 of them have already updated to secure 7.0.5 and higher versions during last week. And about 3,000 websites are updating every day.

So in one two days there almost certainly won't be any website with old unsecure 7.0.0 – 7.0.4 versions and almost all websites will be up to date and safe.


Thank you!
wpDiscuz Developers
COVID-19: Latest Security News & Commentary
Dark Reading Staff 10/13/2020
Where Are the 'Great Exits' in the Data Security Market?
Dave Cole, Cofounder and CEO, Open Raven,  10/13/2020
Overcoming the Challenge of Shorter Certificate Lifespans
Mike Cooper, Founder & CEO of Revocent,  10/15/2020
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Special Report: Computing's New Normal
This special report examines how IT security organizations have adapted to the "new normal" of computing and what the long-term effects will be. Read it and get a unique set of perspectives on issues ranging from new threats & vulnerabilities as a result of remote working to how enterprise security strategy will be affected long term.
Flash Poll
How IT Security Organizations are Attacking the Cybersecurity Problem
How IT Security Organizations are Attacking the Cybersecurity Problem
The COVID-19 pandemic turned the world -- and enterprise computing -- on end. Here's a look at how cybersecurity teams are retrenching their defense strategies, rebuilding their teams, and selecting new technologies to stop the oncoming rise of online attacks.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2020-15256
PUBLISHED: 2020-10-19
A prototype pollution vulnerability has been found in `object-path` <= 0.11.4 affecting the `set()` method. The vulnerability is limited to the `includeInheritedProps` mode (if version >= 0.11.0 is used), which has to be explicitly enabled by creating a new instance of `object-path` and settin...
CVE-2020-15261
PUBLISHED: 2020-10-19
On Windows the Veyon Service before version 4.4.2 contains an unquoted service path vulnerability, allowing locally authenticated users with administrative privileges to run malicious executables with LocalSystem privileges. Since Veyon users (both students and teachers) usually don't have administr...
CVE-2020-6084
PUBLISHED: 2020-10-19
An exploitable denial of service vulnerability exists in the ENIP Request Path Logical Segment functionality of Allen-Bradley Flex IO 1794-AENT/B 4.003. A specially crafted network request can cause a loss of communications with the device resulting in denial-of-service. An attacker can send a malic...
CVE-2020-6085
PUBLISHED: 2020-10-19
An exploitable denial of service vulnerability exists in the ENIP Request Path Logical Segment functionality of Allen-Bradley Flex IO 1794-AENT/B 4.003. A specially crafted network request can cause a loss of communications with the device resulting in denial-of-service. An attacker can send a malic...
CVE-2020-10746
PUBLISHED: 2020-10-19
A flaw was found in Infinispan version 10, where it permits local access to controls via both REST and HotRod APIs. This flaw allows a user authenticated to the local machine to perform all operations on the caches, including the creation, update, deletion, and shutdown of the entire server.