Dark Reading is part of the Informa Tech Division of Informa PLC

This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them.Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.

ABTV

8/30/2019
09:00 AM
Larry Loeb
Larry Loeb
Larry Loeb
50%
50%

Cisco Maxes Out Its CVE Severity

Cisco had to take itself to the virtual woodshed this week after issuing a security advisory about its IOS XE operating system.

Cisco had to take itself to the virtual woodshed this week as it issued a security advisory about the IOS XE operating systemthat is used by many of its hardware devices.

The advisory points out CVE-2019-12643, where the authentication flaw was assigned a severity score of 10 out of 10. You just don't see that kind of number a lot. They must mean it when they call this one critical.

For the full vulnerability to express itself, a vulnerable IOE instantiation must be running an outdated version of the IOE virtual service containers. It's a chain that they admit can bypass authentication.

Specifically, the vulnerability affects Cisco devices when all of the following conditions are met: (1)The device runs an affected Cisco IOS XE Software release and (2) the device has an installed and enabled affected version of the Cisco REST API virtual service container.

The advisory admits why it happened. "The vulnerability is due to an improper check performed by the area of code that manages the REST API authentication service," it said. "An attacker could exploit this vulnerability by submitting malicious HTTP requests to the targeted device. A successful exploit could allow the attacker to obtain the token-id of an authenticated user. This token-id could be used to bypass authentication and execute privileged actions through the interface of the REST API virtual service container on the affected Cisco IOS XE device."

Affected hardware devices include Cisco 4000 Series Integrated Services Routers, Cisco ASR 1000 Series Aggregation Services Routers, Cisco Cloud Services Router 1000V Series and Cisco Integrated Services Virtual Router.

Scott Caveza, research engineering manager at Tenable, comments that: "While the flaw is critical, it's important to note there are a number of requirements for successful exploitation, including the device has both installed and enabled an affected version of the Cisco REST API virtual service container. In addition, a user must be logged into the device in order to obtain the token-id."

The way out of this one is to patch. Yes, they did fix the code. You must have version 16.09.03 of the REST API virtual device container ("iosxe-remote-mgmt.16.09.03.ova") on board, which corrects the authentication bypass bug.

Cisco also took a smart proactive step in the IOS XE code by releasing a optional hardened version of XE that it had developed which will not allow installation or activation of a vulnerable-to-the-flaw container device. Cisco also says in the advisory that, "If the device was already configured with an active vulnerable container, the IOS XE Software upgrade will deactivate the container, making the device not vulnerable. In that case, to restore the REST API functionality, customers should upgrade the Cisco REST API virtual service container to a fixed software release."

That Cisco found it itself ("This vulnerability was found during internal security testing.") and that it was not known to have been exploited in the wild counts for something here. Just having to write the advisory was punishment enough.

— Larry Loeb has written for many of the last century's major "dead tree" computer magazines, having been, among other things, a consulting editor for BYTE magazine and senior editor for the launch of WebWeek.

Comment  | 
Print  | 
More Insights
Comments
Oldest First  |  Newest First  |  Threaded View
How to Better Secure Your Microsoft 365 Environment
Kelly Sheridan, Staff Editor, Dark Reading,  1/25/2021
Attackers Leave Stolen Credentials Searchable on Google
Kelly Sheridan, Staff Editor, Dark Reading,  1/21/2021
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win an Amazon Gift Card! Click Here
Latest Comment: This comment is waiting for review by our moderators.
Current Issue
2020: The Year in Security
Download this Tech Digest for a look at the biggest security stories that - so far - have shaped a very strange and stressful year.
Flash Poll
Assessing Cybersecurity Risk in Today's Enterprises
Assessing Cybersecurity Risk in Today's Enterprises
COVID-19 has created a new IT paradigm in the enterprise -- and a new level of cybersecurity risk. This report offers a look at how enterprises are assessing and managing cyber-risk under the new normal.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2021-3331
PUBLISHED: 2021-01-27
WinSCP before 5.17.10 allows remote attackers to execute arbitrary programs when the URL handler encounters a crafted URL that loads session settings. (For example, this is exploitable in a default installation in which WinSCP is the handler for sftp:// URLs.)
CVE-2021-3326
PUBLISHED: 2021-01-27
The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.
CVE-2021-22641
PUBLISHED: 2021-01-27
A heap-based buffer overflow issue has been identified in the way the application processes project files, allowing an attacker to craft a special project file that may allow arbitrary code execution on the Tellus Lite V-Simulator and V-Server Lite (versions prior to 4.0.10.0).
CVE-2021-22653
PUBLISHED: 2021-01-27
Multiple out-of-bounds write issues have been identified in the way the application processes project files, allowing an attacker to craft a special project file that may allow arbitrary code execution on the Tellus Lite V-Simulator and V-Server Lite (versions prior to 4.0.10.0).
CVE-2021-22655
PUBLISHED: 2021-01-27
Multiple out-of-bounds read issues have been identified in the way the application processes project files, allowing an attacker to craft a special project file that may allow arbitrary code execution on the Tellus Lite V-Simulator and V-Server Lite (versions prior to 4.0.10.0).