Vulnerabilities / Threats
2/24/2011
12:04 PM
50%
50%

'Severe' DNS Vulnerability Leaves Systems Open To Attack

Security experts urge organizations running vulnerable versions of BIND to upgrade immediately to avoid a potential denial of service strike.

Top 10 Security Stories Of 2010
(click image for larger view)
Slideshow: Top 10 Security Stories Of 2010

The Internet Systems Consortium has issued a warning that certain versions of BIND are vulnerable to a denial of service attack. BIND is the most widely used domain name system protocol implementation.

The latest version of BIND, 9.7.3, is not affected, but versions 9.7.1 through 9.7.2-P3 are vulnerable. Attackers could exploit the vulnerability to create a denial of service attack because of the way that BIND handles incremental zone transfers (IXFR), which is a technique for transferring data on top of the transmission control protocol (TCP).

"When an authoritative server processes a successful IXFR transfer or a dynamic update, there is a small window of time during which the IXFR/update -- coupled with a query -- may cause a deadlock to occur," according to the ISC's security advisory issued on Tuesday. "This deadlock will cause the server to stop processing all requests. A high query rate and/or a high update rate will increase the probability of this condition."

According to the ISC, this severe vulnerability can be remotely exploited, although no related attacks have been seen in the wild.

DNS is the technique used to resolve domain names into IP addresses. Accordingly, security experts are urging any organizations running a vulnerable version of BIND to upgrade immediately. "IXFRs between authoritative name servers are a vital part of keeping DNS both alive and correct," said Paul Ducklin head of technology for antivirus firm Sophos in the Asia-Pacific region, in a blog post.

With 300,000 new computers being connected to the Internet every day, as well as the role of DNS in supporting cloud computing, its importance continues to increase. "DNS servers are at the heart of many cloud-style security services, providing the mechanism by which up-to-date blocklist data is published," said Ducklin.

He also noted that Apple OS X includes a copy of BIND, though most people don't run it. Even if they do, however, the latest Mac operating system, OS X 10.6.6, includes the older BIND 9.6, which is not vulnerable to the above exploit. "Sometimes, being behind the curve is a good thing," he said.

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
FTC Opens Probe into Equifax Data Breach
Jai Vijayan, Freelance writer,  9/14/2017
1.9 Billion Data Records Exposed in First Half of 2017
Kelly Jackson Higgins, Executive Editor at Dark Reading,  9/20/2017
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: Jan, check this out! I found an unhackable PC.
Current Issue
Security Vulnerabilities: The Next Wave
Just when you thought it was safe, researchers have unveiled a new round of IT security flaws. Is your enterprise ready?
Flash Poll
[Strategic Security Report] How Enterprises Are Attacking the IT Security Problem
[Strategic Security Report] How Enterprises Are Attacking the IT Security Problem
Enterprises are spending more of their IT budgets on cybersecurity technology. How do your organization's security plans and strategies compare to what others are doing? Here's an in-depth look.
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.