Vulnerabilities / Threats
2/7/2013
11:42 AM
50%
50%

Barracuda Issues Security Update, Apologizes To Customers

Security appliance manufacturer apologizes for leaving hardcoded, undocumented accounts in its products.

Who Is Anonymous: 10 Key Facts
Who Is Anonymous: 10 Key Facts
(click image for larger view and for slideshow)
Barracuda Networks Monday issued a product update designed to address some of the security vulnerabilities that have been identified in some of its appliances, as well as a mea culpa for building hardcoded, undocumented backdoors into its products.

"I regret now some of the choices we made and apologize to our customers and partners who feel misled or deceived by the way it was implemented," said Zach Levow, CTO of Barracuda Neworks, in a blog post. "I assure you we are working day and night to make further changes that integrate the feedback and expectations you have shared with us."

The security warning that hardcoded -- and undocumented -- backdoor accounts exist in multiple Barracuda Networks appliances was issued Jan. 24 by Austria-based information security consultancy SEC Consult.

Levow confirmed the security vulnerabilities identified by SEC Consult, which involved two specific problems. "The first concern was an access point that could allow Barracuda's Technical Support department access to Barracuda appliances without explicit permission from the appliance administrator," he said. "The second concern was an access point that could allow access by a non-Barracuda employee."

[ How secure is your iPhone? Read iPhone Security Unbreakable? Security Gurus Disagree. ]

Appliances affected by the vulnerabilities include the Barracuda Spam & Virus Firewall, Barracuda Web Filter, Barracuda Message Archiver, Barracuda SSL VPN, Barracuda Web Application Firewall version 7.6.4 and earlier, and CudaTel appliances. Despite some prior reports to the contrary, the company said the following products aren't vulnerable to any of the disclosed vulnerabilities: Barracuda Backup, Barracuda NG Firewall, Barracuda Firewall, Barracuda Load Balancer, Barracuda Link Balancer, and Barracuda Web Application Firewall (versions 7.7 and later).

To address the vulnerabilities, Barracuda Networks Monday released an update, Security Definition 2.0.7, that disables access to the devices, except from Barracuda's own IP addresses. A previous Security Definition, 2.0.5, was released in coordination with SEC Consult's security warning, and disabled "all remote access to non-essential accounts," said Levow.

Those updates have only partially mitigated the unauthorized access vulnerability, because they still leave some hardcoded accounts on the appliances for support purposes. Furthermore, Barracuda's current approach to support requires that customers who deploy appliances behind a firewall, but have difficulty configuring the appliance, must then move the appliance to a public IP address, so that Barracuda can remotely troubleshoot the device's configuration. That, however, leaves the appliances vulnerable to unauthorized, remote access.

Barracuda is still trying to find a better approach. "Because we have not had any incidents reported or detected due to these reported vulnerabilities, we do not want to rush changes that could make the situation worse for our customers," said Levow. He said the security vulnerabilities highlight the struggle vendors face "to best balance the need for security with the need to provide the highest level and fastest support to our customers."

Attend Interop Las Vegas May 6-10, and attend the most thorough training on Apple deployment at the NEW Mac & iOS IT Conference. Join us in Las Vegas for access to 125+ workshops and conference classes, 350+ exhibiting companies, and the latest technology. Use Priority Code DIPR02 by Feb. 9 to save up to $500 off the price of Conference Passes. Register for Interop today!

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
macker490
50%
50%
macker490,
User Rank: Ninja
2/10/2013 | 3:42:31 PM
re: Barracuda Issues Security Update, Apologizes To Customers
...left hard coded accounts"
?

an absolute beginners' mistake
Drew Conry-Murray
50%
50%
Drew Conry-Murray,
User Rank: Ninja
2/8/2013 | 1:54:28 AM
re: Barracuda Issues Security Update, Apologizes To Customers
When security vendors make a mistake, I think it's the right move to 'fess up right away and get a fix out to customers as quickly as possible. Yes, it's embarassing, but in the long run you'll be better off instead of trying to obsfuscate or drag your feet.

Drew Conry-Murray
Editor, Network Computing
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2013-6501
Published: 2015-03-30
The default soap.wsdl_cache_dir setting in (1) php.ini-production and (2) php.ini-development in PHP through 5.6.7 specifies the /tmp directory, which makes it easier for local users to conduct WSDL injection attacks by creating a file under /tmp with a predictable filename that is used by the get_s...

CVE-2014-9652
Published: 2015-03-30
The mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote atta...

CVE-2014-9653
Published: 2015-03-30
readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory ...

CVE-2014-9705
Published: 2015-03-30
Heap-based buffer overflow in the enchant_broker_request_dict function in ext/enchant/enchant.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 allows remote attackers to execute arbitrary code via vectors that trigger creation of multiple dictionaries.

CVE-2014-9709
Published: 2015-03-30
The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Dark Reading Radio
Archived Dark Reading Radio
Good hackers--aka security researchers--are worried about the possible legal and professional ramifications of President Obama's new proposed crackdown on cyber criminals.