Vulnerabilities / Threats

12/16/2015
04:30 PM
Connect Directly
Twitter
LinkedIn
RSS
E-Mail
50%
50%

SQL Injection, XSS Flaws Found In Network Management System Products

Patches available for two flaws, pending for four others.

UPDATED DEC. 17 -- Security vendor Rapid7 today disclosed cross-site scripting (XSS) and SQL injection vulnerabilities it found in network management system products from Spiceworks, Ipswitch, Castle Rock Computing, and Opsview.

Patches are currently available for two of the disclosed vulnerabilities. Two patches are pending from Castle Rock, which has yet to disclose a date when they would become available and Ipswitch, which was supposed to release patches for two flaws today but doesn’t appear to have done so.

In an alert, Rapid7 principal security research manager Tod Beardsley described network management systems as presenting a valuable target for attackers.

“By subverting these systems, and attacker can often pull an immense amount of valuable intelligence about the internal infrastructure,” he said. “The fact that many of these protocols are delivered over SNMP is also very interesting; too often, designers of management software which is intended for internal use don't consider the insider threat,” Beardsley wrote.

Beardsley told Dark Reading there’s a presumption within many organizations to implicitly trust data from an SNMP device simply because it is an internal protocol and the devices are assumed to be known devices. “You don’t usually think of SNMP data as user supplied, but that’s exactly what it is,” he says. “If I have a device on your network, I can say whatever I want to say.”

The Spiceworks vulnerability affects the company’s Spiceworks Desktop Web application. In its alert Rapid7 described the vulnerability as an XSS flaw resulting from insufficient filtering of data supplied via SNMP. The flaw, which has been patched, basically allows an unauthenticated user to execute arbitrary code in an authenticated user’s browser and use that access to launch further attacks.

Two of the vulnerabilities that Rapid7 disclosed this week affect the WhatsUpGold network monitoring and performance management product from Ipswitch. One of them is a persistent XSS flaw while the other is a SQL injection error. According to Rapid7, the XSS flaw in WhatsUpGold does not require the attacker to be authenticated and enables threat actors to steal data, modify system configurations, and generally take full control of a compromised system. The SQL injection error in WhatsUpGold requires an attacker to be authenticated to the system first but allows data to be extracted from the application’s underlying database.

An Ipswitch spokeswoman Thursday said the company has released a patch for the vulnerabilities identified by Rapid7.

“At Ipswitch, we take the security of our products very seriously. As soon as the vulnerability was detected, Ipswitch developed a fix which was released on December 16 and is now available to all customers through the customer portal," she said in an emailed statement.

Of the remaining three flaws, two were in Castle Rock’s SNMPc Enterprise and its SNMPc OnLine Web-based monitoring tool, respectively. As with Ipswitch, one of the flaws is a XSS error while the other is a SQL injection issue. The XSS flaw allows an unauthenticated attacker to compromise data and change system configuration while the SQL injection error enables access to the application’s database. Patches are pending for both flaws.

The sixth flaw, also an XSS error, exists in Opsview’s Web application component. The flaw lets attackers execute arbitrary code in an authenticated user’s browser session, which can then be used to launch further attacks on the Web application. Opsview has released a patch for the bug.

In order to exploit any of these flaws, an attacker would at minimum need to have some presence on the internal network, either via a previous compromise or by using a conference room or a waiting room to gain access, Beardsley says. The XSS flaws do not require the attacker to be authenticated on the network, while the SQL injection errors do require authentication and allow privilege escalation.

 

Jai Vijayan is a seasoned technology reporter with over 20 years of experience in IT trade journalism. He was most recently a Senior Editor at Computerworld, where he covered information security and data privacy issues for the publication. Over the course of his 20-year ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
White House Cybersecurity Strategy at a Crossroads
Kelly Jackson Higgins, Executive Editor at Dark Reading,  7/17/2018
The Fundamental Flaw in Security Awareness Programs
Ira Winkler, CISSP, President, Secure Mentem,  7/19/2018
Number of Retailers Impacted by Breaches Doubles
Ericka Chickowski, Contributing Writer, Dark Reading,  7/19/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: This comment is waiting for review by our moderators.
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-14492
PUBLISHED: 2018-07-21
Tenda AC7 through V15.03.06.44_CN, AC9 through V15.03.05.19(6318)_CN, and AC10 through V15.03.06.23_CN devices have a Stack-based Buffer Overflow via a long limitSpeed or limitSpeedup parameter to an unspecified /goform URI.
CVE-2018-3770
PUBLISHED: 2018-07-20
A path traversal exists in markdown-pdf version <9.0.0 that allows a user to insert a malicious html code that can result in reading the local files.
CVE-2018-3771
PUBLISHED: 2018-07-20
An XSS in statics-server <= 0.0.9 can be used via injected iframe in the filename when statics-server displays directory index in the browser.
CVE-2018-5065
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have a Use-after-free vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.
CVE-2018-5066
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.