Vulnerabilities / Threats
7/9/2015
01:55 PM
Connect Directly
Twitter
RSS
E-Mail
100%
0%

OpenSSL Fixes High-Severity, Narrow-Scope Vulnerability

Bug allows attackers to issue invalid certificates, but is difficult to exploit and only affects OpenSSL versions released since last month.

Today, OpenSSL released a fix for a new "high-severity" vulnerability that could enable man-in-the-middle attackers to impersonate a certificate authority, issue invalid certs, trick applications into treating the invalid cert like a legitimate one, and intercept or modify "secure" communications. The vulnerability, CVE-2015-1793, impacts any application that verifies certificates, including SSL/TLS/DTLS clients and servers.

Sounds bad, but the bug only affects OpenSSL versions 1.0.1n, 1.0.1o, 1.0.2b, and 1.0.2c, the oldest of which was released in June. No exploits have been reported so far, and security researchers say that exploitation would not be easy.

CVE-2015-1793 is an alternative chains certificate forgery bug. As the advisory explains:

    During certificate verification, OpenSSL (starting from version 1.0.1n and 1.0.2b) will attempt to find an alternative certificate chain if the first attempt to build such a chain fails. An error in the implementation of this logic can mean that an attacker could cause certain checks on untrusted certificates to be bypassed, such as the CA flag, enabling them to use a valid leaf certificate to act as a CA and "issue" an invalid certificate.

Users of 1.0.1n /1.0.1o have been advised to upgrade to 1.0.1p and users of 1.0.2b/1.0.2c have been advised to upgrade to 1.0.2d.

Although the vulnerability could be nasty, experts say it is not in the same category of other recent SSL vulnerabilities like Heartbleed and FREAK. First, because it requires that the attacker already have a certain degree of access to the target.

According to Chris Eng, vice-president of research for Veracode, exploiting CVE-2015-1793 "is not quick or easy, making it nowhere near as serious as Heartbleed. For starters, an attacker can’t simply directly attack a vulnerable server due to the nature of the vulnerability.

"Going after an individual is also challenging," Eng says, "since the major browsers -- Chrome, Firefox, IE -- don’t use OpenSSL. Even if a user with a vulnerable niche browser were to be targeted, the culprit would have to first deploy a man-in-the-middle (MitM) attack to get access to the browser itself. From there, they would need to serve a forged certificate to the browser directly."

"This vulnerability is only useful to an active attacker who is already capable of performing a man-in-the-middle (MITM) attack, either locally or upstream from the victim," Tod Beardsley of Rapid7 wrote today. "This limits the feasibility of attacks to actors who are already in a privileged position on one of the hops between the client and the server, or locally on the same LAN and can impersonate DNS servers or gateway routers. In short, the vulnerability is not useful for passive attacks, or for widespread, untargeted attacks."

Further, the scope of the attack is narrow.

"Since the bug only affects a few OpenSSL versions that were released in June 2015," says Eng, "major operating systems like RHEL, Ubuntu and CentOS are not vulnerable since they hadn’t yet incorporated the problematic updates at time of release."

"A certificate validation flaw in a TLS library largely affects only clients," says Ivan Ristic, director of engineering at Qualys. "Servers need certificate validation only when mutual authentication is enabled, which is a minor use case. ...  there's certainly lots of server-type tools that might use OpenSSL for client operations. For them, this vulnerability is potentially significant, but attackers would need to exploit them on a case-by-case basis. As such, this is nowhere near Heartbleed."

"To be clear," says Eng, "this is a bad vulnerability and a nice find by the BoringSSL team; however, the overall impact is expected to be minimal.”

Sara Peters is Senior Editor at Dark Reading and formerly the editor-in-chief of Enterprise Efficiency. Prior that she was senior editor for the Computer Security Institute, writing and speaking about virtualization, identity management, cybersecurity law, and a myriad ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Why Cybersecurity Must Be an International Effort
Kelly Sheridan, Associate Editor, Dark Reading,  12/6/2017
NIST Releases New Cybersecurity Framework Draft
Jai Vijayan, Freelance writer,  12/6/2017
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Write a Caption, Win a Starbucks Card! Click Here
Latest Comment: This comment is waiting for review by our moderators.
Current Issue
The Year in Security: 2017
A look at the biggest news stories (so far) of 2017 that shaped the cybersecurity landscape -- from Russian hacking, ransomware's coming-out party, and voting machine vulnerabilities to the massive data breach of credit-monitoring firm Equifax.
Flash Poll
The State of Ransomware
The State of Ransomware
Ransomware has become one of the most prevalent new cybersecurity threats faced by today's enterprises. This new report from Dark Reading includes feedback from IT and IT security professionals about their organization's ransomware experiences, defense plans, and malware challenges. Find out what they had to say!
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2017-0290
Published: 2017-05-09
NScript in mpengine in Microsoft Malware Protection Engine with Engine Version before 1.1.13704.0, as used in Windows Defender and other products, allows remote attackers to execute arbitrary code or cause a denial of service (type confusion and application crash) via crafted JavaScript code within ...

CVE-2016-10369
Published: 2017-05-08
unixsocket.c in lxterminal through 0.3.0 insecurely uses /tmp for a socket file, allowing a local user to cause a denial of service (preventing terminal launch), or possibly have other impact (bypassing terminal access control).

CVE-2016-8202
Published: 2017-05-08
A privilege escalation vulnerability in Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) releases earlier than v7.4.1d and v8.0.1b could allow an authenticated attacker to elevate the privileges of user accounts accessing the system via command line interface. With affected version...

CVE-2016-8209
Published: 2017-05-08
Improper checks for unusual or exceptional conditions in Brocade NetIron 05.8.00 and later releases up to and including 06.1.00, when the Management Module is continuously scanned on port 22, may allow attackers to cause a denial of service (crash and reload) of the management module.

CVE-2017-0890
Published: 2017-05-08
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.