Vulnerabilities / Threats

6/27/2017
05:44 PM
Connect Directly
Twitter
LinkedIn
Google+
RSS
E-Mail
50%
50%

Massive Skype Zero-Day Enables Remote Crashes

A security researcher uncovered a Skype vulnerability that could allow hackers to remotely execute code and crash software if exploited.

A critical vulnerability in Skype for Web could allow attackers to remotely execute code and crash systems. Microsoft has fixed the flaw, which remains a threat to anyone who has not updated their software.

Vulnerability Lab security researcher Benjamin Kunz Mejri discovered the zero-day vulnerability during a team conference call. It affects Skype versions 7.2, 7.35, and 7.36, and is considered a high-security risk with a 7.2 CVSS score.

Researchers state the stack buffer overflow flaw, CVE-2017-9948, has a "critical impact" to local and remote Skype users. Attackers can crash the software with a request to overwrite the register of the active software process. This lets them execute their own malicious code on affected and connected systems via Skype.

"The limitation of the transmitted size and count for images via print of the remote session clipboard has not secure limitation or restriction," Vulnerability Lab states. "Attackers are able to crash the software with one request to overwrite the eip register of the active software process."

This flaw affects the 'MSFTEDIT.DLL' dynamic link library of the Windows 8 (x86) operating system, researchers explain, and it is located in the "clipboard format" function of the Skype software. Attackers need only a low-privilege Skype account to launch a successful attack and do not need to interact with victims.

The vulnerability was reported to Microsoft's Security Response Center on May 16, and Microsoft issued a patch for the problem in Skype version 7.37 on June 8. Users are urged to update their software to avoid cyberattacks.

Related Content:

Kelly Sheridan is the Staff Editor at Dark Reading, where she focuses on cybersecurity news and analysis. She is a business technology journalist who previously reported for InformationWeek, where she covered Microsoft, and Insurance & Technology, where she covered financial ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Weaponizing IPv6 to Bypass IPv4 Security
John Anderson, Principal Security Consultant, Trustwave Spiderlabs,  6/12/2018
'Shift Left' & the Connected Car
Rohit Sethi, COO of Security Compass,  6/12/2018
Why CISOs Need a Security Reality Check
Joel Fulton, Chief Information Security Officer for Splunk,  6/13/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-10617
PUBLISHED: 2018-06-18
Delta Electronics Delta Industrial Automation DOPSoft version 4.00.04 and prior utilizes a fixed-length heap buffer where a value larger than the buffer can be read from a .dpa file into the buffer, causing the buffer to be overwritten. This may allow remote code execution or cause the application t...
CVE-2018-10621
PUBLISHED: 2018-06-18
Delta Electronics Delta Industrial Automation DOPSoft version 4.00.04 and prior utilizes a fixed-length stack buffer where a value larger than the buffer can be read from a .dpa file into the buffer, causing the buffer to be overwritten. This may allow remote code execution or cause the application ...
CVE-2018-10623
PUBLISHED: 2018-06-18
Delta Electronics Delta Industrial Automation DOPSoft version 4.00.04 and prior performs read operations on a memory buffer where the position can be determined by a value read from a .dpa file. This may cause improper restriction of operations within the bounds of the memory buffer, allow remote co...
CVE-2015-4664
PUBLISHED: 2018-06-18
An improper input validation vulnerability in CA Privileged Access Manager 2.4.4.4 and earlier allows remote attackers to execute arbitrary commands.
CVE-2018-9021
PUBLISHED: 2018-06-18
An authentication bypass vulnerability in CA Privileged Access Manager 2.8.2 and earlier allows remote attackers to execute arbitrary commands with specially crafted requests.